Abrowser shows Google, Facebook, Amazon, etc links on the homepage by default

4 Antworten [Letzter Beitrag]
LloydLynx
Offline
Beigetreten: 05/21/2021

I installed Trisquel 9.0 in a VM, ran updates and restarted, then opened Abrowser. I'm quite surprised that the default browser on a distro of this nature would have this on the homepage by default. My question is why? And is this an intentional decision?

I've attached a screenshot showing what Abrowser looks like the first time it was opened.

This isn't a fluke either. I got this same result when installing Trisquel 9.0 onto bare metal a few months ago.

AnhangGröße
Screenshot at 2021-08-17 19-49-02.png134.56 KB
nadebula.1984
Offline
Beigetreten: 05/01/2018

This problem is inherited from Firefox. Maybe it's forgotten when customizing Abrowser...

amenex
Offline
Beigetreten: 01/03/2015

Look in the Settings link, which is revealed by clicking on what's known as
the "hamburger" ikon (three horizontal lines, one above the other). Opening
the Settings menu, you'll see an entry called Home. The Home menu has checkboxes
labeled Web Search, Shortcuts, Recent Activity, and Snippets. Someone has selected
Sponsored Shortcuts for you. If you want peaceful use of Abrowser, uncheck all
selections and then see how it goes.

andyprough
Offline
Beigetreten: 02/12/2015

Librewolf does not do this. In about:config, the following lines are greyed out:
browser.newtabpage.activity-stream.showSponsored
browser.newtabpage.activity-stream.showSponsoredTopSites

I'm not sure how the Librewolf devs did this. Possibly with their hand-crafted user.js. I doubt that it is an option during compilation, but I could be wrong. I used to build the nightly version of Firefox frequently and knew where to find the list of compile options, but I haven't done that for awhile.

Legimet
Offline
Beigetreten: 12/10/2013

You can "lock" a preference in Firefox in the preferences file, that's probably what the Librewolf devs did.