Can't install Onionshare in Trisquel 9

3 Antworten [Letzter Beitrag]
GNUser
Offline
Beigetreten: 07/17/2013

Hey,

So, I wanted to ask if anyone has had this error. I added Micah's PPA as mentioned here https://onionshare.org/#downloads
However when trying to install I get a missing package called python3-flask-httpauth
Has anyone faced the same issue? I was under the impression that all python3 related issues were solved.
Thanks in advance.

Magic Banana

I am a member!

Offline
Beigetreten: 07/24/2010

That package is not in Ubuntu 18.04, on which Trisquel 9 is based: https://packages.ubuntu.com/search?suite=bionic&searchon=names&keywords=python3-flask-httpauth

GNUser
Offline
Beigetreten: 07/17/2013

Funny thing, I assumed as much by checking the very same link that you posted. LOL
However, I wonder why the PPA is trying to require that dependency when it correctly checked my OS version?
In any event, I checked the github page and the software seems to be free. The only dependencies it shows are met in Trisquel repository (didn't check versions, only names though). I suppose I could get the file from Debian and try to force it, or it won't work anyway?

GNUser
Offline
Beigetreten: 07/17/2013

Well good news, I got the deb file from here https://packages.debian.org/buster/all/python3-flask-httpauth/download
And now it works like a charm! I was able to install it and after that I got Onionshare to install and run! Yay!
Thanks anyway for the help Magic Banana ;)