¿Se puede instalar ClipGrab en Trisquel 8.0?

5 replies [Last post]
miangg
Offline
Joined: 03/02/2020

Buenas tardes.

Estoy interesado en instalar en Trisquel 8.0 una aplicación llamada "ClipGrab" que permite grabar vídeos de Youtube y otras webs, pero me encuentro con problemas que no sé si son debidos a la naturaleza de Trisquel (100% Software Libre) o por mi falta de conocimientos sobre GNU/Linux.

Tras ingresar en la web de la aplicación (https://clipgrab.org/), me encuentro con un enlace que permite descargar un instalador del tipo AppImage. Según el vídeo de Youtube en el que descubrí esta aplicación, hay que dar permisos de ejecución a ese archivo para poder abrirlo y que se instale la aplicación. Así me funcionó sin problemas en otra distro llamada MX Linux, pero en Trisquel lo único que ocurre es que se crea un archivo de texto sencillo de 0 bytes con un nombre lleno de símbolos seguidos de "(codificación no válida)".

La otra posibilidad que da la página web es descargar el código fuente en un archivo comprimido del tipo tar.gz. Tras descargarlo y descomprimirlo, me encuentro con un archivo README en el que se dan unas instrucciones para la compilación (según ellos, muy sencillas):

> You need to install the Qt5 developer libraries in order to compile the program.

> On Ubuntu and Debian-based system, you can install the necessary libraries like this:

sudo apt install qtbase5-dev qtwebengine5-dev

Pues bien, soy incapaz de encontrar la librería "qtwebengine5-dev" para poderla instalar, porque no se encuentra en APT ni en Synaptic.

Así pues, estoy atascado en este punto. Por ello les pido un poco de ayuda o asesoría sobre qué camino tomar para poder instalar "qtwebengine5-dev", a no ser que el problema tenga su origen en que la librería no es 100% software libre y, por lo tanto, no tiene cabida en Trisquel.

Debo decir que también he intentado la aplicación "youtube-dl", pero no me funciona, o bien no es posible disponer de la última versión.

Les doy las gracias de antemano y espero que alguien me pueda dar alguna pista o información valiosa.

Muchas gracias y saludos.

Ark74

I am a member!

Offline
Joined: 07/15/2009

Disculpa, desconozco ClipGrab absolutamente.

De igual manera los AppImage, son formatos poco recomendables, ya tienden a convertirse en un binario que no sabes como se compiló. Dicho hecho, no tengo nada en contra de ellos solo que si puedes evitarlos, sería preferible.

Regresando al tema de las librerías el tema que encuentras es que necesitas ejecutar T9 en adelante para tener compatibilidad con dicho software.

qtwebengine5-dev

Pertenece a T9/U18.04 en adelante.

Saludos

miangg
Offline
Joined: 03/02/2020

Muchas gracias por la información, Ark74.

Veremos si con la llegada de Trisquel 9.0 podré emplear ClipGrab.

De todos modos, me gustaría saber si alguien por aquí emplea alguna aplicación para descargar vídeos de Youtube, ya sea a través del terminal o del escritorio. Conozco «youtube-dl», pero aún no me he familiarizado con ella. A mí en realidad me interesa descargar esos vídeos para poder extraer de ellos el audio.

Saludos.

S-PJJ
Offline
Joined: 12/27/2019

¡Buenas!

Como alternativa te puedo escribir lo que yo hago si quiero extraer el audio de algún vídeo. Lo que hago es descargarme el vídeo desde "youtube-dl" (en el foro puedes encontrar la forma de como usarlo, es muy fácil realmente), después con el editor de vídeos "Kdenlive" extraigo el audio del vídeo (lo malo es que está en formato .wav), por último con "Audacity" le cambio la extensión a .ogg a ese audio que he extraído y listo. Así es como lo hago, posiblemente haya otra forma más rápida de hacerlo, posiblemente la puedas encontrar indagando por la web.

¡Un abrazo!.

juancuyo
Offline
Joined: 05/15/2013

Hola, buenas tardes, hace varios años que uso youtube-dl desde la pagina oficial en la solapa instalar sigue las instrucciones, asegurate de tener instalado curl, por las dudas primero, sudo apt-get install curl y luego las lineas que se describen en el instructivo https://youtube-dl.org/ y para descargar formatos de video o audio esta guia rapida https://geekland.eu/descargar-videos-internet-youtube-dl/ para elegir tipo de audio o tipos de video Te recomiendo un poquito de paciencia y lee el manual

vita_cell
Offline
Joined: 07/19/2015

Hola, es muy buen software ClipGrab. Esta hecho con toolkit Qt5, por lo tanto librerias de Qt5 son necesarias. Creo que esto incluye al Webkit tambien. Luego tienes un software un poco peor en manejo, que es Youtube-dl y Youtube-dl-gui.

AppImage es muchisimo mejor que Flatpak y Snap, pero esta el hecho de que dentro de AppImage se pueden meter funciones indeseables, pero si no se meten cosas malas, AppImage es algo muy bueno. En mi opinion personal, es mucho mas fiable compilar cosas por tu propia cuenta, ya que en un binario ya montado, tienes que confiar en la palabra del que lo compilo.
----------------------------------------------------------------------------------------------------------

> You need to install the Qt5 developer libraries in order to compile the program.
+ Necesitas librerias Qt5, y para compilar necesilas las librerias *-dev (no las necesitas en distribuciones como Arch o Slackware (ni las basadas en estas)).
----------------------------------------------------------------------------------------------------------

qtwebengine5-dev:
https://packages.ubuntu.com/search?keywords=webengine
https://packages.ubuntu.com/focal/qtwebengine5-dev #20.04
https://packages.ubuntu.com/bionic/qtwebengine5-dev #18.04

Pero segun se, Trisquel-8 se basa en Ubuntu-16, asi que la cosa cambia.
El paquete qtwebengine5 simplemente no hay en Ubuntu 16. Al menos no esta disponible como compilado.

https://packages.ubuntu.com/search?keywords=webengine&searchon=names&suite=eoan&section=all
Aqui si le das arriba para filtrar al "Xenial", veras que no esta el paquete que buscas.
----------------------------------------------------------------------------------------------------------

El problema de "youtube-dl" con "no funciona" a mi no me dice nada, los adivinos estan de vacaciones, por lo tanto no puedo ayudar. Si expones el problema quizas si que podremos intentar ayudarte.