Coincé sur une session Kodi

8 replies [Last post]
Stem
Offline
Joined: 05/03/2017

Bonsoir,

Après avoir installé kodi, j'ai ouvert une session dessus. Depuis, plus moyen d'accéder à ma session de bureau puisque maintenant, ça se connecte automatiquement sur kodi au démarrage, et kodi ne propose pas d'option de déconnexion. Du coup, comment je fais pour retrouver mon bureau ?

Merci.

Magic Banana

I am a member!

Offline
Joined: 07/24/2010

À l’écran de connexion graphique, tape Ctrl+Alt+F1 pour obtenir une session texte. Après t’y être connecté, vois avec la commande suivante s’il n’y aurait pas dans ~/.config/autostart un fichier correspondant à Kodi :
$ ls ~/.config/autostart
Si c’est le cas, supprime-le (je suppose ici que le fichier est ~/.config/autostart/kodi.desktop) :
rm ~/.config/autostart/kodi.desktop
Repasse à la session graphique d’un Alt+F7 et vois si en t’y connectant tu retrouves ton bureau.

Si le système démarre dans Kodi (tu n’arrives pas même à l’écran de connexion graphique de Trisquel), alors il est en fait un « service » que systemd lance. Le désactiver (de nouveau depuis une session texte) devrait être aussi simple que :
$ sudo systemctl disable kodi

Stem
Offline
Joined: 05/03/2017

Aucune des deux opérations ne marche: il n'y a aucun fichier nommé kodi dans autostart et la 2ème commande me dit «no such file or directory».

Stem
Offline
Joined: 05/03/2017

Finalement, j'ai trouvé: désinstaller kodi via ledit terminal.

Magic Banana

I am a member!

Offline
Joined: 07/24/2010

Je ne pensais que tu voulais totalement désinstaller Kodi. Du coup, le comment Kodi démarre tout seul n’est pas élucidé.

Stem
Offline
Joined: 05/03/2017

En fait, c'est de ma faute. J'avais sélectionné l'option «ouvrir ma session automatiquement». Donc fatalement, si j'ouvre une session sur kodi, c'est elle qui va démarrer toute seule à l'ouverture de session. D'ailleurs, l'écran de login est revenu après la désinstallation de kodi.

Magic Banana

I am a member!

Offline
Joined: 07/24/2010

Je suppose que cela ne se configure pas dans l’application elle-même (sinon, tu aurais décoché une case et ton problème airait été réglé). Était-ce à l’installation du paquet que l’on te demandait cela ? Si oui, alors la commande 'sudo dpkg-reconfigure kodi', exécutée dans une session texte, t’aurait permis de repasser par l’étape de configuration du paquet.

Stem
Offline
Joined: 05/03/2017

Non, pas du tout. J'ai coché l'option «ouvrir la session automatiquement» lors de l'installation de Trisquel.

Magic Banana

I am a member!

Offline
Joined: 07/24/2010

OK. Mais ça n'explique pas comment Kodi était automatiquement lancé au démarrage de ta session. Je croyais que seules les commandes dans les fichiers dans ~/.config/autostart étaient automatiquement lancées au démarrage de la session.