issues after updating to Trisquel 8

3 replies [Last post]
kerdadit
Offline
Joined: 06/06/2018

Last night I upgraded from Trisquel 7 to 8 by changing: /etc/apt/sources.list and just replacing "belenos" with "flidas". And then I ran:

sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade

It seems to have succeeded because now:

> user@Taurinus-X200:~/Documents$ lsb_release -a
> No LSB modules are available.
> Distributor ID: Trisquel
> Description: Trisquel GNU/Linux 8.0, Flidas
> Release: 8.0
> Codename: flidas

But I am experiencing some weird problems, for example, my clock has completely disappeared. And when I hover over things in the start menu, there's no highlighting of the things I hover over like there normally would be. Just weird things like that. But perhaps the most useful information is the warnings I get now when running apt update.

When I run apt-get update, I get this:

W: Unknown Multi-Arch type 'no' for package 'kwin'
W: Unknown Multi-Arch type 'no' for package 'kwin-dev'
W: Unknown Multi-Arch type 'no' for package 'kwin-wayland'
W: Unknown Multi-Arch type 'no' for package 'kwin-x11'
W: Unknown Multi-Arch type 'no' for package 'libkf5sysguard-dev'
W: Unknown Multi-Arch type 'no' for package 'libxapian-dev'
W: Ignoring Provides line with DepCompareOp for package php-psr-http-message-implementation
W: Ignoring Provides line with DepCompareOp for package php-psr-log-implementation
W: Ignoring Provides line with DepCompareOp for package php-seclib
W: Ignoring Provides line with DepCompareOp for package php-sabre-http
W: Ignoring Provides line with DepCompareOp for package php-math-biginteger
W: Ignoring Provides line with DepCompareOp for package pypy-cffi
W: Ignoring Provides line with DepCompareOp for package pypy-cffi-backend-api-max
W: Ignoring Provides line with DepCompareOp for package pypy-cffi-backend-api-min
W: Ignoring Provides line with DepCompareOp for package python-cffi-backend-api-max
W: Ignoring Provides line with DepCompareOp for package python-cffi-backend-api-min
W: Ignoring Provides line with DepCompareOp for package python3-cffi-backend-api-max
W: Ignoring Provides line with DepCompareOp for package python3-cffi-backend-api-min
W: Unknown Multi-Arch type 'no' for package 'compiz-core'
W: Unknown Multi-Arch type 'no' for package 'compiz-gnome'
W: Ignoring Provides line with DepCompareOp for package php-math-biginteger
W: Ignoring Provides line with DepCompareOp for package pypy-cffi
W: Ignoring Provides line with DepCompareOp for package pypy-cffi-backend-api-max
W: Ignoring Provides line with DepCompareOp for package pypy-cffi-backend-api-min
W: Ignoring Provides line with DepCompareOp for package python-cffi-backend-api-max
W: Ignoring Provides line with DepCompareOp for package python-cffi-backend-api-min
W: Ignoring Provides line with DepCompareOp for package python3-cffi-backend-api-max
W: Ignoring Provides line with DepCompareOp for package python3-cffi-backend-api-min
W: Ignoring Provides line with DepCompareOp for package xserver-xorg
W: You may want to run apt-get update to correct these problems

I'm not sure if the warnings has anything to do with my issues. I certainly wouldn't like to see these warnings every time I run apt-update, but I would also like to fix these bugs I'm having. I can't even find the settings panel in the start menu anymore.

Any advice is greatly appreciated.

jxself
Offline
Joined: 09/13/2010

I didn't upgrade to Trisquel 8. I reformatted and reinstalled. Trisquel 8 works great for me.

chaosmonk

I am a member!

I am a translator!

Offline
Joined: 07/07/2017

Run

$ sudo apt install trisquel

and reboot.

kerdadit
Offline
Joined: 06/06/2018

Thanks both of you. For the record, I tried what you suggested first, Chaosmonk. I got a bunch of notices with the following error:

E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

So I just gave up and tried installing from a USB again. That worked out so now I'm happily typing away on a perfectly working Trisquel 8 installation.