Laptop wifi + carte sd

40 replies [Last post]
Kyzen
Offline
Joined: 03/30/2016

Bonjour,

Je suis nouveau et je viens de faire l'acquisition d'un laptop :

http://www.ldlc.com/fiche/PB00206243.html

Comme je m'en doutais la wifi ne fonctionne pas sans driver proprio, souhaitant éviter de dépenser 50 dollars dans un adaptateur wifi usb, je me permet de vous soliciter pour savoir si celui-ci fairait l'affaire :

https://www.amazon.fr/TP-Link-TL-WN821N-Adaptateur-sans-Mbps/dp/B00194XKXA/ref=sr_1_2?ie=UTF8&qid=1460035059&sr=8-2&keywords=TP-LINK+300Mbps+Wireless+N+USB+Adapter

Selon h-node il me semble que c'est le cas, je voudrais juste une "validation".

De plus, cette ordinateur possède un lecteur carte SD, et je n'es pas de carte sd sous la main.
Avec la commande "lshw" voila ce que je vois :

*-generic
description: Unassigned class
product: RTS5286 PCI Express Card Reader
vendor: Realtek Semiconductor Co., Ltd.
physical id: 0
bus info: pci@0000:01:00.0
version: 01
width: 32 bits
clock: 33MHz
capabilities: pm msi pciexpress msix vpd bus_master cap_list
configuration: driver=rtsx_pci latency=0
resources: irq:132 memory:81300000-8130ffff
fonctionne-il ?

Merci d'avance. ;)

Substance2004
Offline
Joined: 11/05/2013

N'y a-t-il peut-être non plus la solution de changer directement la carte wifi dans le PC si t'es un petit peu bricoleur et minutieux, comme ça, plus besoin d'adaptateur que tu peux perdre par ailleurs pendant tes déplacements.
Ça doit se trouver pour pas cher, même en seconde main. Le design se paye souvent plus que les composants.
Ce qui permet du coup de revendre celle que tu as déjà...

Kyzen
Offline
Joined: 03/30/2016

Merci de t'a réponse.

J'y est pensé, malheuresement le problème c'est que je crois qu'il ne s'ouvre pas (ce qui est étrange vu que quand je le commande LDLC doit le "préparer" et installer le disque dur). En effet en dessous il est d'un seul bloc et j'ai beau dévissé sa ne s'ouvre pas. (a moins que les composants soit dessous le clavier mais je ne pense pas).

L'avantage de l'usb c'est que je suis sûr de ne rien casser ^^.

photo1.jpg photo2.jpg
nmrk.n
Offline
Joined: 11/01/2013

Le 07/04/2016 16:42, alexandre a écrit :
> Merci de t'a réponse.
>
> J'y est pensé, malheuresement le problème c'est que je crois qu'il ne
> s'ouvre pas (ce qui est étrange vu que quand je le commande LDLC doit
> le "préparer" et installer le disque dur). En effet en dessous il est
> d'un seul bloc et j'ai beau dévissé sa ne s'ouvre pas. (a moins que
> les composants soit dessous le clavier mais je ne pense pas).
>
> L'avantage de l'usb c'est que je suis sûr de ne rien casser ^^.
------------------------------------------------------------------------
Eh oui, c'est assez gonflant cette façon de tout clipser en faisant en
sorte que ce soit invisible et en plus de ne pas fournir de mode
d'emploi à ce sujet.

Vive les vis apparentes pour tout.

Des fois il est possible de trouver sur internet l'expérience d'un
prédécesseur qui a réussi à démonter un matériel et explique comment
faire mais c'est pas gagné.

--
nmrk.n
[FSF Associate Member]

Magic Banana

I am a member!

Offline
Joined: 07/24/2010

J'ai acheté, il y a deux ou trois ans, un adaptateur TL-WN722N qui lui ressemble beaucoup (mais avec une antenne détachable). Il possède un chipset AR9271 supporté par Linux-libre. L'ennui c'est que le modèle ne dit pas tout. Les constructeurs changent le chipset (ce qui importe) dans un même modèle. Plus l'achat de l'utilisateur qui a complété h-node est vieux, plus le risque est grand... et l'information de quand date l'achat n'est pas sur h-node. J'imagine qu'il peut aussi y avoir des différences d'un pays à l'autre.

À toi de voir... Si tu prends le risque et qu'il paie, ce serait bien de l'écrire sur les forums Trisquel, histoire d'aider d'autres utilisateurs. C'est comme cela que j'ai choisi le TL-WN722N. J'en ai acheté un. Il a fonctionné. J'en ai acheté quatre de plus ! Ainsi, je peux en donner aux personnes de ma famille (mon épouse, mes parents et mon frère) qui me font confiance avec l'achat d'un ordinateur et l'installation de Trisquel. T'en donner/vendre un n'est pas une option : j'habite au Brésil.

Maintenant, pour aucun risque, il y a http://libre.thinkpenguin.com et http://tehnoetic.com

En tout cas, je ne te recommande pas Amazon. Vois https://stallman.org/amazon.html par exemple.

Mangy Dog

I am a member!

I am a translator!

Offline
Joined: 03/15/2015

Bonjour Kyzen

de plus https://www.thinkpenguin.com/catalog/wireless-networking-gnulinux ou l'adapteur TL-WN722N t'éviterons un démontage ;-)

Le cas ou il t'arriverais de devoir verifier ou changer ta RAM, nettoyer ton ventilo,ou remplacer ton HDD il y des vis "cachées" derrière les bitonios en platisque qui servent de cales,une carte téléphonique peut etre aussi utile pour faire levier "cascailler légèremnet"tout en faisant le tour du 'joint' qui réunit les deux parties assemblées pour décoler celui-ci l'ordinateur portable dans la meme position que sur ta photo=l'écran dessous et bien a plat

Bonne Journée a tous
et bon weekend

aciao!

copy of Hiden screws.png
Kyzen
Offline
Joined: 03/30/2016

Merci de vos réponses, je pense que je vais donc passer par ThinkPenguin, sa ne sert à rien de prendre des risques :p.

Merci à MangyDog pour l'astuce :p.

Magic Banana

I am a member!

Offline
Joined: 07/24/2010

Utilise le lien http://libre.thinkpenguin.com pour que 25% des bénéfices sur ton achat soient donnés au projet Trisquel.

Kyzen
Offline
Joined: 03/30/2016

Re, je me perrmet de poster ici, pour éviter de réouvrir un topic.

Quand je regarde une vidéo (480p) à l'aide de vlc, ou même "video" fourni avec la distribution. Mon processeur tourne à 80% des quatres coeurs. Je soupçonne que "l'acceleration matériel" ne sois pas activée, car même si ce n'es pas un processeur puissant (intel celeron n3150) il devrait être capable de supporter une simple vidéo :p (il est même censé être capable de décoder du x265).

Comment l'activer ?

De plus j'ai quelques problèmes de son, cette fois si pas avec vlc mais dans les applications comme "flare" ou encore la voix éléctronique pour mal entendant activé par défault (je l'es désactivé :p), c'est difficile à décrire mais en gros sa fait des bruits de "radio quand tu et sur une onde non occupé" (je n'es pas trouvé un meilleur moyen de décrire ^^) environ toute les 5 secondes. Je tiens à précisé que ce problème n'es pas rencontré avec vlc, donc pas un soucis matériel.

Merci d'avance.

Magic Banana

I am a member!

Offline
Joined: 07/24/2010

Tu peux essayer de mettre à jour Linux-libre, le noyau : https://trisquel.info/fr/wiki/actualiser-le-kernel-linux-libre

Kyzen
Offline
Joined: 03/30/2016

J'ai fait une bêtise apparement. J'ai fait :

sudo apt-get install --install-recommends {linux-generic,xserver-xorg,libgl1-mesa-glx,libegl1-mesa-drivers}-lts-utopic

Après je rallume et ecran noir, je ne peux rien faire :\

Je réinstalle ?

Magic Banana

I am a member!

Offline
Joined: 07/24/2010

Non.

Je suis surpris de ton problème. C'est la première fois depuis des années que j'entends parler de noyau qui ne démarre pas. Peut-être que le noyau fonctionne très bien et que c'est la pile graphique (que tu aussi mise à jour) qui pose problème. Cela est facile à voir : disons une minute après l'allumage de la machine (lorsque tu devrais te trouver devant l'écran où choisir ton nom d'utilisateur), si tu appuies sur Ctrl+Alt+F1, obtiens-tu une session texte dans laquelle te connecter ? Si oui, alors tu peux exécuter cette commande et tout devrait rentrer dans l'ordre :
$ sudo apt-get remove {xserver-xorg,libgl1-mesa-glx,libegl1-mesa-drivers}-lts-utopic

Maintenant, si c'est réellement le noyau qui pose problème alors il te faut démarrer sur le noyau précédent... ce qui est inutilement compliqué avec Trisquel. Il te faut en effet connaître ou désactiver le mot de passe GRUB. Pour connaître ce mot de passe :

  1. Démarre un système Live (comme celui que tu as du utiliser pour installer Trisquel);
  2. À partir du point de montage du système de fichiers racine du système installé, navigue jusqu'à /etc/grub.d
  3. Si ce n'est déjà fait (c'est à dire si tu n'as pas navigué jusqu'au /etc/grub.d du système installé avec 'cd'), ouvre ce répertoire dans un terminal : clic droit dans la fenêtre puis "Ouvrir dans un terminal" avec le navigateur de fichiers de Trisquel;
  4. Exécuter 'sudo cat 01_PASSWORD' (pas de mot de passe sur le système Live) te montrera alors le mot de passe GRUB (cinq chiffres à la toute fin);
  5. Redémarre et affiche le menu GRUB en maintenant la touche "Shift" enfoncée (si je ne m'abuse : j'ai configuré GRUB pour que ce menu s'affiche toujours);
  6. Choisis la deuxième entrée : "Advanced options" ou quelque chose du genre;
  7. Entre "grub" comme nom d'utilisateur et le mot de passe que tu viens de lire;
  8. Tu peux alors choisir de démarrer le noyau précédent;
  9. Une fois le système démarré, tu peux supprimer le dernier noyau qui ne fonctionne pas (par exemple depuis le "Gestionnaire de paquets Synaptic" dans le "Paramètres système".

Tout cela est bien plus compliqué que ça ne devrait être. En effet, le mot de passe GRUB ne sert qu'à nous compliqué la vie. Il n'apporte aucune réelle sécurité. Même les développeurs de GRUB le disent : https://www.gnu.org/software/grub/manual/grub.html#Security

Si tu veux, je t'explique ensuite comment supprimer le mot de passe GRUB.

Kyzen
Offline
Joined: 03/30/2016

Un grand merci, Tu viens de me sauver la vie :p

J'ai du utiliser la seconde solution avec grub.

Kyzen
Offline
Joined: 03/30/2016

Je dois bien supprimer ce qui est en bleu ? "linux-generic-lts_utopic" ?

Edit : je remarque également qu'Orca consomme pas mal de ressource processeur, celon la docu ubuntu, il s'agit d'un outil pour les mal_voyant, je peux faire un petit : apt-get remove orca ?

Screenshot from 2016-04-09 17:55:16.png
Magic Banana

I am a member!

Offline
Joined: 07/24/2010

"linux-generic-lts-utopic" mais surtout ses dépendances ("linux-generic-lts-utopic" n'installe rien en lui-même) : "linux-image-generic-lts-utopic", "linux-headers-generic-lts-utopic", "linux-image-3.16.0-69-generic" et "linux-headers-3.16.0-69-generic".

Maintenant tu peux essayer d'installer un noyau encore plus récent... Veux-tu des instructions pour enlever le mot de passe GRUB ?

Il n'y aucune raison pour qu'Orca consomme des ressources (autres qu'une dizaine de Mo de disque) si tu ne l'utilises pas. À l'écran de connexion graphique, Ctrl+S permet d'activer ou de désactiver Orca. Dans une session graphique, c'est Alt+Super+S (Super est la touche Windows sur la plupart des clavier). Ou alors depuis "Accessibilité" dans les "Paramètres systèmes".

Tu peux désinstaller le paquet "gnome-orca" si tu veux. "trisquel-recommended" en dépend mais il s'agit d'un meta-paquet (comme "linux-generic-lts-utopic") qui n'installe rien en lui même. Il n'existe que pour installer facilement toutes ses dépendances. Le supprimer signifie donc seulement que tu ne suis plus la sélection de logiciels que l'équipe derrière Trisquel a choisi. Par exemple, il est possible que Trisquel 8 aura, par défaut, des logiciels qui ne sont pas dans Trisquel 7. Ce seront de nouvelles dépendances de "trisquel-recommended". Lorsque tu mettras à jour ta distribution, ces logiciels ne seront donc pas automatiquement installés. Rien ne t'empêchera de les installer à la main ou même d'installer "trisquel-recommended" qui te ramènera aussi "gnome-orca".

Kyzen
Offline
Joined: 03/30/2016

Merci,

Est-ce que tu pourrais me dire exactement ce que je dois déinstaller pour ne pas à avoir a faire la manip avec le grub ? Ainsi que comment bien mettre à jour son noyau ? Histoire de ne pas tout casser :p

"Veux-tu des instructions pour enlever le mot de passe GRUB ?"

Oui, je veux bien.

Magic Banana

I am a member!

Offline
Joined: 07/24/2010

Est-ce que tu pourrais me dire exactement ce que je dois déinstaller pour ne pas à avoir a faire la manip avec le grub ?

Je te l'ai dit dans le premier paragraphe. C'est "linux-image-3.16.0-69-generic" qui est véritablement le noyau qui ne fonctionne pas sur ton système. Mais si tu ne supprimes pas aussi "linux-image-generic-lts-utopic" et "linux-generic-lts-utopic", il te sera de nouveau proposé en mise à jour. Quant aux "headers", il te sont inutiles puisque tu n'utiliseras pas cette version du noyau (en fait, tu ne veux peut-être les "headers" d'aucune version du noyau, ces derniers servant principalement à compiler des pilotes additionnels).

Lorsque tu supprimes le noyau le plus récent avec le gestionnaire de paquets, ce dernier se charge de mettre à jour la configuration de GRUB pour que la version précédente soit utilisée.

Ainsi que comment bien mettre à jour son noyau ?

Comme je te l'écrivais : "c'est la première fois depuis des années que j'entends parler de noyau qui ne démarre pas". Je ne pense pas que tu ais fait quoi que ce soit de mal. Il s'agit a priori d'un problème entre ton matériel et la version 3.16 de Linux. Essaie donc une version plus récente pour voir (comme la version 4.5 prise sur le dépôt de jxself) : https://trisquel.info/fr/wiki/actualiser-le-kernel-linux-libre

Pour ce qui est de te débarrasser du mot de passe GRUB, tu peux tout simplement supprimer /etc/grub.d/01_PASSWORD depuis un terminal :
$ sudo rm /etc/grub.d/01_PASSWORD
Si tu préfères seulement commenter ses lignes (et donc être capable de remettre ce mot de passe facilement), il s'agit d'avoir toutes les lignes qui commencent par le caractère "#" puis d'enregistrer le fichier. Tu peux utiliser n'importe quel éditeur de texte (ici GEdit, l'éditeur de texte par défaut dans Trisquel) :
$ gksu gedit /etc/grub.d/01_PASSWORD

Dans les deux cas, il te faut ensuite exécuter cette commande pour que le changement soit effectif :
$ sudo update-grub

Mais, si tu veux, avant, tu peux faire d'autres changements simple à la configuration de GRUB. En éditant /etc/default/grub :
$ gksu gedit /etc/default/grub

Par exemple commenter 'GRUB_DISABLE_RECOVERY="true"' permet d'ajouter au menu des entrées pour directement démarrer dans un terminal root (aucun mot de passe demandé). Ce peut être pratique en cas de problème et, encore une fois, ne réduit pas la sécurité de ton système (puisque seul un accès physique à l'ordinateur permet d’interagir avec GRUB et que, dans cette situation, il y a bien d'autres façon de prendre le contrôle de la machine).

Kyzen
Offline
Joined: 03/30/2016

Je viens d'installer le noyau 4.5, et tout fonctione nickel grâce à toi ;)

Merci pour le temps que tu m'a consacré :)

Kyzen
Offline
Joined: 03/30/2016

Rebonjour, j'étais en train de dezipper un fichier, quand le système à planté, (la souris ne bouge plus, pas de raccourci clavier disponible). Je redémarre l'ordinateur, et depuis impossible de boot sur le noyau 4.5, écran noir avec un tiret blanc en haut à gauche, je n'es même pas accès au mode texte sans interface graphique. J'ai même essayé de déinstaller avec synaptic le noyau 4.5 puis le réinstaller. Sans succès :/ .

Heuresement, je peux boot sur un noyau plus ancien. C'est gênant, car le noyau 4.5 était bien plus performant et fonctionnait parfaitement jusque la.

Avait-vous des idées ?

Merci d'avance

Magic Banana

I am a member!

Offline
Joined: 07/24/2010

Tu as des problèmes curieux. Vérifie donc donc ta RAM et ton disque avec, respectivement, memtest86+ (dans le dépôt Trisquel, à choisir depuis le menu GRUB) et un auto-test que tu peux lancer depuis le menu (le bouton avec l'engrenage en haut à droite) de "Disques" dans les "Paramètres système".

Kyzen
Offline
Joined: 03/30/2016

Je viens de faire cela, zéro erreur.

Mangy Dog

I am a member!

I am a translator!

Offline
Joined: 03/15/2015

Kizen,
ceci ne sont que des suggestions et remarques:

installe le bureau XFCE (Meta-package)via le gestionnaire de paquets Synaptic cela a resolu pour moi il y a un an sur un PC (qui a rendu l'âme depuis :)

j'avais sous GNOME les même symptomes =systeme qui "freeze"souris bloquée, obliger de faire un arret manuel ou même l'ouverture de Synaptic causait un freeze generale (avec 2GO de RAM)

Pour le noyau plus récent je rajouterais que mon PC actuel vieux de 11 ans ne boot en aucune maniere Trisquel7 apres "moultes tentatives" mais GnewSense Ucclia, ConnochaetOS 14.1 ou Debian 8 fonctionne apres installation =pas d'écran noir apres installation(mais ce ne sont pas les mêmes noyaux que Trisquel)

évidemment cela depend beaucoup des composants Hardware,CPU,Bridges,chipsets,carte graphique

Donc si ton ou tes anciens noyaux fonctionnent de manière satisfaisante,le Bureau XFCE ou meme LXDE étant plus lèger tu gagneras en performance

tu peux aussi vérifier dans
var/log/messages

#grep -i error /var/log/messages
#less /var/log/messages

Kyzen
Offline
Joined: 03/30/2016

Merci de ta réponse, cependant je ne pense pas que ce soit gnome qui pose problème (pas de problème avec un noyau plus ancien). De plus, le noyau 4.5 est meilleur et plus performant car évite des bugs de son et de décodage vidéo sur ma config (Si tu regarde les composants du laptop, c'est un proco de 2015, je pense au contraire qu'il faut absolument être sur la dernière version).

Les commandes :

grep -i error /var/log/messages

ou

less /var/log/messages

Ne fonctionne pas chez moi :/.

Hier, je me suis rendu compte que si j'attend un peu après avoir essayé de booter sur le noyau 4.5 (en attendant devant l'écran noir). Au bout d'un moment j'ai le message d'erreur suivant :

[ 103.691313] NMI watchdog : Watchdog detected hard LOCKUP on cpu 3
_

Magic Banana

I am a member!

Offline
Joined: 07/24/2010

Il est, d'une certaine façon, attendu que le dernier noyau pris sur un dépôt externe soit moins stable...

Tu peux peut-être essayer Linux-libre 4.2 qui est dans le dépôt Trisquel (un paquet "linux-image-*-lts-wily" de ton choix).

Mangy Dog

I am a member!

I am a translator!

Offline
Joined: 03/15/2015

Pour var/log/messages il faut ce rendre dans le répertoir ~/var

$sudo
#cd /var/log
ensuite
grep -i error /var/log/messages
plus fournis
less /var/log/messages

si tu as du mal a etre sudo tu peux temporairement
utuliser su -

Pour
103.691313] NMI watchdog : Watchdog detected hard LOCKUP on cpu 3

il y un bug "similaire"du noyau 4.2.0-22-generic Ubuntu
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1004313
qui coure de 2013 jusqu'a aujourd'hui
https://en.wikipedia.org/wiki/Watchdog_timer

Magic Banana

I am a member!

Offline
Joined: 07/24/2010

Ou alors utiliser l'utilitaire "Journaux système".

Kyzen
Offline
Joined: 03/30/2016

Je suis dans l'utilitaire, quelles info sont importantes ?

Magic Banana

I am a member!

Offline
Joined: 07/24/2010

Essaie de démarrer sur le noyau problématique. Puisqu'il plante, tu redémarres et, cette fois, choisis un noyau fonctionnel. Ensuite, dans "Journaux système", lis les informations dans le fichier "syslog" qui se réfèrent au démarrage précédent. Il s'agit de lignes où il est écrit "kernel: " puis entre crochet un numéro qui est, en fait, un nombre de secondes depuis le commencement du démarrage. Il te faut donc regarder juste avant le temps "0.000000" qui correspond au dernier démarrage. Peut-être y liras-tu un message d'erreur. Suis-je clair ?

Sinon tu peux juste nous mettre en pièce jointe ton fichier /var/log/syslog entier...

Mangy Dog

I am a member!

I am a translator!

Offline
Joined: 03/15/2015

https://fr.wikibooks.org/wiki/Le_syst%C3%A8me_d%27exploitation_GNU-Linux/Les_fichiers_journaux_syslog

Dans chaque ligne d'évènement on distingue :

La date à laquelle l'évènement a été declenché
Le processus déclencheur de l'évènement
Le processus ayant demandé l'ajout du message correspondant au log
Le niveau de gravité du message priorité

messages d'erreurs dans Log viewer (Journaux Systeme)
Voir https://fr.wikipedia.org/wiki/Syslog

0 Emergency emerg (panic) Système inutilisable.
1 Alert alert Une intervention immédiate est nécessaire.
2 Critical crit Erreur critique pour le système.
3 Error err (error) Erreur de fonctionnement.
4 Warning warn (warning) Avertissement (une erreur peut intervenir si aucune action n'est prise).
5 Notice notice Événement normal méritant d'être signalé.
6 Informational info Pour information.
7 Debugging debug Message de mise au point.

Kyzen
Offline
Joined: 03/30/2016

Je suis aller à " /var/log/"

J'ai pris tout les .log qui je pense est ce dont on a besoin pour comprendre ce qui ce passe.

petit fichier linux help.7z

Magic Banana

I am a member!

Offline
Joined: 07/24/2010

Pourquoi as-tu préféré un lien sur www.petit-fichier.fr à une pièce jointe à ton message sur notre forum ?

J'ai regardé les logs du noyau, kern.log. La dernière fois que tu as démarré un noyau 4.5 était le 12 avril à 10:13:34, heure locale... et tout s'est bien passé jusqu'à 11:09:44. Là le pilote graphique d'Intel, i915, a commencé à relater des erreurs. Mais je doute que l'affichage ait totalement gelé à ce moment là. Cela a dû arrivé à 17:11:32 où le "Direct Rendering Management" indique qu'il est bloqué sur l'"anneau de rendu" (ne ma demande pas ce que c'est) et t'invite à rapporter un bogue avec /sys/class/drm/card0/error (le rapport de plantage) en pièce jointe. À 17:11:38, il essaie par deux fois de réinitialiser le chipset graphique mais tu l'as coupé en arrêtant brusquement le système.

À 17:50:19, c'est un noyau 3.13 qui démarre. Il n'y a rien entre les deux. Donc ce n'est pas que le noyau 4.5 plante, c'est qu'il ne commence même pas à démarrer ! Essaie donc d'exécuter 'sudo update-grub' dans un terminal et vois si tu arrives alors à démarrer le noyau 4.5. Ou installe et utilise le noyau 4.2 (qui est sûrement plus stable et dans le dépôt Trisquel) comme je te l'ai déjà suggéré : https://trisquel.info/forum/laptop-wifi-carte-sd#comment-93936

Kyzen
Offline
Joined: 03/30/2016

Bonjour, je reviens après quelques jours.

J'ai tenté la solution radical, réinstaller. Tout ce passe bien ,j'update vers le noyau 4.5 et même problème :/.

Jusque la on pourrait ce dire que mon pc ne supporte pas le noyau 4.5 (ce qui serait bizarre, car il fonctionnait bien mieux sur le noyau 4.5 jusque la.)

Mais ce qui est "flippant" c'est qu'avant j'ai essayé de passer du côté obscur (comprennait j'ai essayé d'installer windows 7, 8.1, ubuntu 16.04). Impossible, le programme d'installation ne lance même pas (bloqué sur le logo ubuntu/Windows). Que ce soit avec ou sans UEFI/BIOS, secure boot ou non, en gros mon pc n'accepte d'installer et utiliser seulement trisquel 7 avec le noyau 3.13. Comme si il avait ban tout le reste :( .

Magic Banana

I am a member!

Offline
Joined: 07/24/2010

Il n'y a vraiment aucune raison pour que Trisquel gêne l'installation d'un autre système d'exploitation.

Kyzen
Offline
Joined: 03/30/2016

Je sais bien, mais je vois pas autre chose. Seul Trisquel accepte de s'installer.

Kyzen
Offline
Joined: 03/30/2016

Mon pc doit être hanté par Richard Stallman, je viens d'essayer avec Gnewsense, sa boot bien :/

Sa règle pas mon problème mais au moins, je connais deux distro qui boot ^^.

EDIT : je viens d'essayé Ubuntu sans succès, je vais donc réinstaller Trisquel puis poster les démarches que je fais d'habitude pour update le noyau, je dois forcément mal m'y prendre.

Kyzen
Offline
Joined: 03/30/2016

Donc voila ce que je fais pour installer le noyau 4.5 :

echo 'deb http://linux-libre.fsfla.org/pub/linux-libre/freesh/ freesh main' | sudo tee -a /etc/apt/sources.list

wget https://jxself.org/gpg.inc

sudo apt-key add gpg.inc

sudo apt-get update

sudo apt-get install linux-libre64 linux-libre64-headers

sudo update-grub2

Ensuite je redémarre le pc. Et sa ne boot pas correctement

Magic Banana

I am a member!

Offline
Joined: 07/24/2010

Ça semble bien. Tu n'as pas besoin des "headers" mais il n'y a pas de raison non plus pour que le paquet pose problème. Essaie donc la version 4.2, comme je te l'ai déjà suggéré : https://trisquel.info/forum/laptop-wifi-carte-sd#comment-93936

Kyzen
Offline
Joined: 03/30/2016

je vais prier pour pas que sa foire mon installation :p

Kyzen
Offline
Joined: 03/30/2016

Quelles commandes doit-je excecuter ? Afin d'être sûr d'installer le noyau 4.2 et pas autre chose.

Mangy Dog

I am a member!

I am a translator!

Offline
Joined: 03/15/2015

Tu peut tout simplement te servir du Gestionnaire de paquets Synaptic disponible dans "ajouter supprimer des logiciels"

de la tu installe le ou les noyaux que tu souhaite ;-)

Magic Banana

I am a member!

Offline
Joined: 07/24/2010

Oui. Un des paquets "linux-image-*-lts-wily".