mate-settings-daemon overwrites SSH_AUTH_SOCK

No replies
kenogo
Offline
Joined: 11/20/2019

I'm trying to use gpg-agent for SSH by setting the environment variable SSH_AUTH_SOCK in ~/.pam_environment. But it gets overwritten by two autostart processes that I need to disable for it to work. The first one is gnome keyring's SSH-agent. That one makes sense to disable and I understand why it would overwrite SSH_AUTH_SOCK. However, disabling it isn't enough, I also have to disable mate-settings-daemon. But then I don't get to keep my settings, which I would obviously like to.

Does anyone here know how mate-settings-daemon works and what could be the cause of this behavior?