openjdk-9-jdk and ca-certificates

1 reply [Last post]
Roedor
Offline
Joined: 12/03/2017

Hello, i was trying to install "openjdk-9-jdk" but i got this on the shell:

sudo apt-get install openjdk-9-jdk

"dpkg: error processing archive /var/cache/apt/archives/openjdk-9-jdk_9~b114-0ubuntu1_i386.deb (--unpack):
trying to overwrite '/usr/lib/jvm/java-9-openjdk-i386/include/linux/jawt_md.h', which is also in package openjdk-9-jdk-headless:i386 9~b114-0ubuntu1

Errors were encountered while processing:
/var/cache/apt/archives/openjdk-9-jdk_9~b114-0ubuntu1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)"

So i tried to force the overwrite with this:

sudo apt-get -o Dpkg::Options::="--force-overwrite" install openjdk-9-jdk

And that worked but the same command also did this: "Setting up ca-certificates-java (20160321ubuntu1)"

Adding a bunch of .pem files with strange names like "amazon_root china_internet_network_information" and a lot of other suspicious sites.

I panicked so uninstalled with remove, autoremove and purge but maybe i should do a fresh install of Trisquel.

What are those things ? I don't know what to do...

Magic Banana

I am a member!

Offline
Joined: 07/24/2010

The "ca-certificates" package (a dependence of "ca-certificates-java") provides the files you are referring to. Its description is:

This package includes PEM files of CA certificates to allow SSL-based
applications to check for the authenticity of SSL connections.

It includes, among others, certificate authorities used by the Debian
infrastructure and those shipped with Mozilla's browsers.

Please note that Debian can neither confirm nor deny whether the
certificate authorities whose certificates are included in this package
have in any way been audited for trustworthiness or RFC 3647 compliance.
Full responsibility to assess them belongs to the local system
administrator.

See https://en.wikipedia.org/wiki/Certificate_authority for more information.