Aramo ISO Beta 5 (Jan 24 2023)

18 respuestas [Último envío]
Ark74

I am a member!

I am a translator!

Desconectado/a
se unió: 07/15/2009

Hello guys,

Great news, just one month ago we were launching the 4th beta ISO set, and after the holidays we have the latest and greatest ISOs set.

This includes several updates and fixes, while we might keep using the Beta label for the ISOs set, Aramo is very well usable and solid at this point.

Here some of the main changes since Beta 4 ISO,

  • small fixes and tweaks on the mate session and mate-teak
  • kyling got some artwork tweaks too
  • ifupdown pending issue got fixed
  • trisquel GNOME desktop now is offered as an option on the tasksel menu (debian-installer/netinstaller)
  • fixed the external PPA repositories parsing
  • small fixes and tweaks for the kde session
  • fixed update-notifier icon on notification area

Work in progress,

  • aramo archive cleaning from old packages - thanks for the reminder Simon

Find the latest BETA images at:
http://cdbuilds.trisquel.org/aramo/

All the feedback is welcome, current and new issues will be followed/tracked at the Trisquel's GitLab instance, please ask for your account at the devel mailing list or the #trisquel-dev channel.

Thank you all for all your previous feedback to all early testers and the community in general.

Cheers!

Ark74

I am a member!

I am a translator!

Desconectado/a
se unió: 07/15/2009

Hello again,

One important change on this ISO set that was missing is the use of a new partman recipe on the install process.

  • Update on the partitioning recipe by defaulting to ext4 and requiring to define a swap partition, as well as improving EFI requirements.

Please test this new recipe on a VM or a test computer, remember to always do proper backups on production machines as migration among filesystems (xfs,ext4,etc) will erase existing data.

You can find the new recipes while booting the live mode ISO images at,
/usr/lib/partman/recipes/*

Cheers!

Magic Banana

I am a member!

I am a translator!

Desconectado/a
se unió: 07/24/2010

Executing in a terminal:
$ sudo sed -i 's/Prompt=lts/Prompt=normal/' /etc/update-manager/release-upgrades
$ sudo do-release-upgrade -d
Recherche d'une nouvelle version d'Trisquel
Les mises à niveau vers la version de développement sont seulement
disponibles depuis la dernière version prise en charge.

In English:
Upgrades to the development release are only
available from the latest supported release.

I run Trisquel 10, the "latest supported release". Shouldn't 'sudo do-release-upgrade -d' upgrade Trisquel 10 to Trisquel 11 beta?

Ark74

I am a member!

I am a translator!

Desconectado/a
se unió: 07/15/2009

Since version 6.0 all releases are LTS, so Prompt=lts should stay as lts.

The meta data for upgrading among releases is not yet published (at the time of writing):

That's the reason it's not available.

Update: Please note that the "Beta 5" label refers to the ISOs set images, not the distro itself.

eric23
Desconectado/a
se unió: 06/30/2017

I am trying Triskel 11.0 beta 5 an X200 with Libreboot version from Nov 2021. I was able to boot it, but there was no graphical boot menu. It gives me a "boot" prompt and I input help and gives me a menu with options of F2 - F10. I was not able to read any menu option because it boots automatically.

Booting in the install image and installation, I see a message checking to see a new Ubuntu version is available. I guess it isn't trying to update to Ubuntu right?

/lib/systemd/system/update-notifier-motd.timer

I tried to get the installer to update to the latest by having the box checked, but it didn't seem to upgrade. It claims that it would save time after the installation.

Are packages like ubuntu-artwork supposed to be available?

Avron
Desconectado/a
se unió: 08/18/2020

Which entry in the Libreboot menu did you try?

With 20220710 Libreboot on X200 and Trisquel 11.00 beta 4, if I choose "Search ISOLINUX menu (USB)", I get into the menu that proposes the usual options ("Try Trisquel without installing", "Install Trisquel", "Install Trisquel in text mode", "Check disc for defects", ...).

eric23
Desconectado/a
se unió: 06/30/2017

I have seabios too though. So if I press escape at the seabios boot prompt, it gives three choices. 1, AHCI? I think, 2, is boot from usb, 3, is cbfs, that gives me the menu having the option "search ISOLINUX menu (USB)". Then if I select that option it gives the graphical Trisquel usb boot screen.

prospero
Desconectado/a
se unió: 05/20/2022

The popup volume bar that appeared on scrolling while hovering over the sound icon does not show on Aramo, similar to what was discussed for Nabia.

The mate-indicator-applet issue report mentioned in the other thread refers to differences between the old indicator-sound and the newer ayatana-indicator-sound, so I tried to replace the latter with the former, after which no sound indicator would show up at all in the indicator applet. So I reversed back to ayatana-indicator-sound, which is the upstream package that should be responsible for that behavior anyway.

I tried to visit there: https://wiki.ayatana-indicators.org/AyatanaIndicatorSound but am currently greeted by an "Unhandled Exception". I found an archived version but could not make anything of it. Not sure what this is supposed to mean: As a hidden treasure, when the pointer is over the title, whether the menu is open or not, clicking a mousewheel up or down should invoke the Louder] or Quieter] action respectively. (As usual, this should result in a notification bubble showing the volume change.)

Is it a wish, a requirement, or is it the description of the expected behavior? Should we deem the hidden treasure lost at sea?

Ark74

I am a member!

I am a translator!

Desconectado/a
se unió: 07/15/2009

On every major update mate desktop details suffer changes from the main development team.

Since last time, when using a LiveCD of nabia you could get a volume bar when scrolling, I've now tested both Aramo and Jammy (mate) LiveCDs and none of those show such bar.

If your keyboard has special/extra volume keys, you still can check the bar when using those keys, but seems like the bar on mouse scroll is now lost on the old-archive sea.

prospero
Desconectado/a
se unió: 05/20/2022

Thank you for checking again. Yes, the disappearance was most probably caused by MATE switching to the ayatana-indicator thing. I am still using the ancient scroll method, but I just discovered that the right/left arrows could be used to fine tune the volume up/down when the volume bar in the menu is highlighted.

UPDATE: note that Super+Tab will switch focus away from the desktop and to the panel indicator, and let us navigate to the sound volume bar.

I have a feeling that XFCE has a more conservative approach to this kind of changes, I may give it a try on Aramo.

UPDATE 2: XFCE is not using ayatana, and indeed shows a volume indicator on scrolling over the sound icon:

XFCE_volume_notification.png
Avron
Desconectado/a
se unió: 08/18/2020

I have a feeling that XFCE has a more conservative approach to this kind of changes

It takes time for users to get familiar with some environment and arrange it as they like. What some people can consider as an improvement can be a terrible regression for others. So indeed, not changing what a user sees, if the user did not take an action for the change, seems a good idea.

prospero
Desconectado/a
se unió: 05/20/2022

Based on the description from the 2021 version of the ayatana wiki, I believe this may be an oversight by the ayatana people, rather than a deliberate change. If nobody complained, it had little chance to be fixed. Note that if nobody complained, it can hardly be called a terrible regression either.

UPDATE: after some deeper inquiry and various experiments, ayatana-indicator is increasingly looking like the culprit: I was able to reproduce that behavior on Xfce by installing ayatana-indicator-sound, adding xfce4-indicator-plugin to the Xfce panel and removing xfce4-pulseaudio-plugin from the panel. As long as xfce4-pulseaudio-plugin is present on the panel, the popup volume indicator will show, whichever sound icon is hovered over while scrolling. Once it is removed, the popup is not showing any more.

prospero
Desconectado/a
se unió: 05/20/2022

The https://wiki.ayatana-indicators.org/ pages are were briefly back to life today, including https://wiki.ayatana-indicators.org/AyatanaIndicatorSound#Title.

Maybe the hidden treasure is going to be fully recovered, after all... being buried even deeper as we speak. The pages now say "Not Found".

sdi-p
Desconectado/a
se unió: 10/04/2015

Aramo Date and Time Manager
my clock is ~half a day off

with the GUI the time zone is correct, however the NTP sync is set to off, and the slider is grayed out.

running in terminal:
(mate-time-admin:599459): Gtk-CRITICAL **: 22:07:52.288: gtk_lock_button_set_permission: assertion 'GTK_IS_LOCK_BUTTON (button)' failed

===
then I discovered NTP package was not installed. after installing it still fails.
reboot did not help.

=== edit
after reboot the clock is now correct, but the GUI options are still greyed out.
this matters to me because I do travel into other time zones

Ark74

I am a member!

I am a translator!

Desconectado/a
se unió: 07/15/2009

IIRC, you need not ntp but systemd-timesyncd, it's disabled by default as a general policy of not having services pinging home.
By default no application on the default installation should open ports, or ping anywhere.

That also includes time sync.
Regards

sdi-p
Desconectado/a
se unió: 10/04/2015

using Synaptic I installed systemd-timesyncd
ntp was removed.

same thing, all options are greyed out.

Ark74

I am a member!

I am a translator!

Desconectado/a
se unió: 07/15/2009

Since this is a service you might want to first edit /etc/systemd/timesyncd.conf

Here an example:
[Time]
NTP=0.debian.pool.ntp.org
FallbackNTP=1.debian.pool.ntp.org 2.debian.pool.ntp.org 3.debian.pool.ntp.org

Then check status with,
timedatectl show-timesync --all
timedatectl timesync-status

Now you should have ntp enabled.

all options are greyed out.

Yeah, the GUI is not very useful, let me look closer.

Regards.

Ark74

I am a member!

I am a translator!

Desconectado/a
se unió: 07/15/2009

A missing package was causing this behavior, it been included and should arrive in the latest update of trisquel packages.
Cheers! o/

sdi-p
Desconectado/a
se unió: 10/04/2015

updated... it works as expected now.

Thanks