[Brother HL-L2320D]: Printer Does Not Install

6 respuestas [Último envío]
se unió: 06/22/2018

In yet another attempt to find and use a printer without needing proprietary software drivers (as well as being able to save paper by being able to print on both sides of it), I recently purchased the Brother HL-L 2320D printer, as I was under the impression that using the package, printer-driver-brlaser, would allow me to use this printer on Trisquel GNU/Linux 8.0.

Unfortunately, I have not been able to use the printer, even after installing the package, printer-driver-brlaser, something that is contrary to what is reportedly described in the description of that particular driver, where the Brother HL-L 2320D was found to "work" with it.

My technical expertise in solving this issue is low, and I am uncertain where to begin troubleshooting to solve this problem. When reading information in the forum, or elsewhere, I frequently encounter package names such as "Cups", "Ghostscript", "Foomatic", and I lack a systematic approach to know where to actually begin to solve this, as I don't believe that randomly installing or uninstalling the aforementioned packages, in a wild attempt to make my printer work will build my understanding, let alone solve this problem.

Any suggestions would most certainly be welcome.

The description of the Brother driver may be found at https://github.com/pdewacht/brlaser

se unió: 06/22/2018

I forgot to mention that the Installed Version of Package "printer-driver-brlaser" is 3-5~ubuntu1

My initial hunch is that 3-5~ubuntu1 may not be up to date with the latest developments that have incorporated drivers for Brother printers, such as the Brother HL-L 2320D

While not familiar at all with how one is to update packages from Github, I am looking at the source code as well as issues during development. For example, at this page (https://github.com/pdewacht/brlaser/issues/37), the Brother HL-L 2320D is mentioned as being able to "duplex print" as well as use the "CUPS server". This was mentioned on May 1 of (presumably) this year.

I am also searching through my files for any file related to "brlaser", using keywords like "brlaser", "printer-driver-brlaser", and "ppd" in the hopes that I may find clues about this current version of "printer-driver-brlaser" version 3-5~ubuntu1, and whether there is any information related to my printer.


I am a member!

I am a translator!

se unió: 07/07/2017

> My initial hunch is that 3-5~ubuntu1 may not be up to date with the
> latest developments that have incorporated drivers for Brother printers,
> such as the Brother HL-L 2320D

I got my Brother printer working by running "system-config-printer". It
provides a configuration wizard which searches the Gutenprint repository
for the best-matching free driver for your printer and installs it.

se unió: 06/22/2018


I continued my search within Github, (specifically at https://github.com/pdewacht/brlaser) for a clue as to why the Brother HL-L2320D is not working on Trisquel GNU/Linux 8.0, and I found two "Closed" posts, and one "Open" post under the "Issues" tab that relate directly to my printer.

The first "Closed" post, created on May 23rd, 2018, entitled "HL-L2320D works too #25" (found at https://github.com/pdewacht/brlaser/issues/25) details how people have confirmed they are having success printing "text files" as well as "pdf"s with the Brother HL-L2320D, using Version 5 of "printer-driver-brlaser".

The second "Closed" post was created on October 16th, 2019, entitled "Brother HL-L2300D not available #51", (found at https://github.com/pdewacht/brlaser/issues/51) details how SUSE ships a version of "printer-driver-brlaser" that is not up-to-date, and that the recommended solution to enable "support for the HL-L2300D &co", as it was introduced in "version 5" is to compile "brlaser from source" which may allow the Brother "HL-L2300D &co" to actually work as intended on SUSE.

The only "Open" post I found, created on October 25, 2019, entitled "HL-L2320D can't print this pdf" (found at https://github.com/pdewacht/brlaser/issues/52) details how a person is having problems printing a PDF page, using Version 5 of "printer-driver-brlaser". The recommended solution for this issue, it appears, is to use Version 6 of "printer-driver-brlaser".

It then appears to me, that the current version of "printer-driver-brlaser", Version 3-5~ubuntu1 for Trisquel GNU/Linux 8.0 is indeed out-of-date, and that using version 6, created on September 22, 2019, may actually enable my printer to work. As mentioned earlier, I do not have alot of technical expertise, and am unfamiliar with compiling software from areas beyond the official repos, such as from Github. This will be my next step, and I will report back when I learn how to do this.

se unió: 06/30/2017

I tried Chaosmonk's suggestion of using system-config-printer to set up my printer and it offered "Generic PCL 6/PCL XL Printer Foomatic/pxlcolor (recommended)" which apparently prints as well as the similar model's gutenprint driver.

I called the command with "sudo" from a terminal such as gnome-terminal

sudo system-config-printer

Apparently for the Brother HL-L2370D printer, a generic driver is good enough. Mine is a black and white printer that printed with no issues. As far as other features such check ink/toner levels, that might be a reason to use another driver.

se unió: 11/29/2019

I hadn't realized some Brother Printers could be used with only free software. I thought that was only the HP ones. Interesting it is.

se unió: 06/22/2018



I downloaded the software from Github (https://github.com/pdewacht/brlaser.git), and followed the instructions on how to compile and install the program found within the file "README.md". After the program was compiled and installed, I started CUPS in Abrowser, where I found and selected the driver, "Brother HL-L2320D series, using brlaser v6". I then proceeded to print a test page which unfortunately did not produce the desired result - nothing happened. As the instructions for the software noted, CUPS might need to be restarted, which I promptly did (by restarting the computer).

After restarting the computer, I went to [System-> Administration-> Printers], which opened the 'Printer Properties' window where I tried to print another test page, but, again, nothing happened. Looking within the 'Printer Options' setting, I noticed that the Resolution was '1200HQ'. I changed this setting, to '600 DPI', and then proceeded to print another test page, and....it worked!

I will now try printing different file formats to see if they do print as well, but, so far I am impressed that I now have a working printer that uses free software!