Re: Cannot boot my system any longer

Sin respuestas
Zelphir Kaltstahl
se unió: 11/11/2019

I fixed it now.

I looked in the GRUB console and searched for how to run fsck from
there, but could not find anything. Probably it is not available at that

Somehow when rebooting again I got so far as to see the (initram) thing.
There I had access to fsck.ext4. That I ran and allowed it to fix all it
found. Notably it did mention fixes for the inodes and adding them to
bad sectors list as well as a problem with, which it
also offered to fix. I allowed that as well.

Next I got into the login screen. There I could not log in. Whenever I
logged in, it would immediately bring me back to the login screen again.
I think my X session crashed always immediately.

So I went into TTY1. First had no Internet connection, because
wpasupplicant also had some issue. I ran some commands to give me the
status of the network manager hinting at wpasupplicant. Probably that
did not work, because it needs libcrypto or something. I needed to
connect via ethernet cable. Did that.

With Internet connection I started to `sudo apt-get install --reinstall
...` things, in hope to find the correct packages, which would place a
new in the system directories. I guessed, that some
trisquel meta package might reinstall all the system stuff, but that did
not help.

I also tried deleting my `.Xauthority` and `.ICEauthority` files, with
no luck.

`cat .xsession-errors` hinted at something, I think that is, where I got
a hint about `libssl`.

`sudo aptitude search ssl | grep -E '^i.*'` helped me find all
supposedly installed SSL related packages.

`sudo apt-get install --reinstall libssl-dev libssl1.0.0 openssl`
reinstalled them and probably ``.

After another `reboot`. I was able to log in again.

Anyway, thanks for reading my ramblings. Perhaps this will help anyone
in the future. Or even myself, if I face this situation again.

I guess I will have to be careful to not rely on anything being safely
stored on this SSD in the future. Hopefully I wont have to frequently do
this kind of procedure and hopefully my SSD will last a while longer. It
is rather new after all or is supposed to be.

Best regards,

On 05.09.20 14:30, Zelphir Kaltstahl wrote:
> Hello Trisquel Users!
> My system does not start any longer, since a few minutes ago. I am now
> writing this e-mail my other notebook. I saw a weird message first,
> which already made me suspicious, when I tried to git push my
> repository, on which I just finished some commit. It told me something
> like the following: (I will put tripple dots, where I am not sure any
> more. I have it stored on the device itself in a text file. If only I
> could reach it to copy paste the error I have seen.)
> ~~~~START~~~~
> /lib/…linux-x86-64…/
> ... (something about magic bytes or something) ...
> ELF file headers
> ~~~~~END~~~~~
> So I already thought: "Hmmm? That's weird. How could that file have
> become corrupted? I hope my system still works, if I restart. Perhaps
> updating Trisquel will repair the file?"
> And so I did run the software updater, which updated 250MB of stuff,
> also many lib…something… files, but not libcrypto, as far as I could see.
> Then I restarted, hoping it will simply start in a normal way, but
> unfortunately I was shocked and my system does not start any longer!
> There are some errors shown, which seem to indicate, that there are
> EXT4 file system errors. Perhaps it's really only the software, the
> files being corrupted and not my hardware (please!)? The SSD in my
> system should in theory be quite new still.
> I have the following system:
> - Trisquel 8, updated to the latest updates
> - X200 notebook, refurbished, with new SSD 256GB
> I will attach a photo of the screen, which shows the error. (Is that
> OK on the mailing list?)
> The errors it shows are:
> ~~~~START~~~~
> EXT4-fs error (device sda1): ext4_ext_check_inode: 505: inode #1445422: comm crda: pblk 0 bad header/extend: invalid magic - magic df6b, entries 37, max 4(0), depth 0(0)
> ~~~~~END~~~~~
> This repeats a dozen times with different time stamps in front.
> Then "crda" becomes "wpa_supplicant" (What does it have to do with
> network?):
> ~~~~START~~~~
> EXT4-fs error (device sda1): ext4_ext_check_inode: 505: inode #1445422: comm wpa_supplicant: pblk 0 bad header/extend: invalid magic - magic df6b, entries 37, max 4(0), depth 0(0)
> ~~~~~END~~~~~
> And then changes back to:
> ~~~~START~~~~
> EXT4-fs error (device sda1): ext4_ext_check_inode: 505: inode #1445422: comm crda: pblk 0 bad header/extend: invalid magic - magic df6b, entries 37, max 4(0), depth 0(0)
> ~~~~~END~~~~~
> Then the system does nothing any longer.
> I can still enter the GRUB. I hope I can somehow "repair the EXT4 file
> system"? Something like check disk?
> I had such a productive start into Saturday and now this.
> So my questions are:
> (1) Is there a way to fix the problem? Perhaps some commands from GRUB
> and recovery console? How can I fix it?
> (2) Is it the hardward, or is it "only" corrupted system files? (I
> love my X200 and working with it and I really really dislike losing
> work or notes.)
> (3) Is there any more info I could provide? Perhaps I can run some
> diagnostic tools on recovery console from GRUB or so?
> Best regards,
> Zelphir