System backup snapshots

22 respuestas [Último envío]
amuza
Desconectado/a
se unió: 02/12/2018

Hi,

I recently tested this Timeshift program [0] in a non-Trisquel machine and I liked it very much. Deja-dup was backing up the home directory and Timeshift was doing snapshots of all the rest.

I could browse files from snapshots and I could even solve a non-booting system situation I happened to have just by easily restoring its daily snapshot. I found it very convenient for a non-expert user like me, so I would like to have it on Trisquel and lower my fears to break things.

I don't know anything about the Timeshift project so I thought in those cases it would be a bit better to install from source instead of trusting a binary when I find no relationship to my personal web of trust. But, as I don't know much about building from source, I failed.

I posted the problem I got at https://github.com/teejee2008/timeshift/issues/618
but I did not get any reply. This is what I posted:


amuuza@trisquel8:~/git/timeshift$ make all
cd src; make all
make[1]: Entering directory '/home/amuuza/git/timeshift/src'
Package vte-2.91 was not found in the pkg-config search path.
Perhaps you should add the directory containing `vte-2.91.pc'
to the PKG_CONFIG_PATH environment variable
No package 'vte-2.91' found
/bin/bash: line 0: test: -lt: unary operator expected
Package gtk+-3.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `gtk+-3.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'gtk+-3.0' found
/bin/bash: line 0: test: -gt: unary operator expected
#timeshift-gtk
valac -X -D'GETTEXT_PACKAGE="timeshift"' \
--Xcc="-lm" --Xcc="-O3" -D VTE_291 \
Core/*.vala Gtk/*.vala Utility/*.vala Utility/Gtk/*.vala \
-o timeshift-gtk \
--pkg glib-2.0 --pkg gio-unix-2.0 --pkg posix \
--pkg gee-0.8 --pkg json-glib-1.0 \
--pkg gtk+-3.0 --pkg vte-2.91
error: Package `gee-0.8' not found in specified Vala API directories or GObject-Introspection GIR directories
error: Package `vte-2.91' not found in specified Vala API directories or GObject-Introspection GIR directories
Compilation failed: 2 error(s), 0 warning(s)
makefile:51: recipe for target 'app-gtk' failed
make[1]: *** [app-gtk] Error 1
make[1]: Leaving directory '/home/amuuza/git/timeshift/src'
makefile:2: recipe for target 'all' failed
make: *** [all] Error 2

Now I have tried again to troubleshoot, I found this, but got stuck again:

amuuza@trisque8:~/git/timeshift/src$ sudo apt search vte-2.91
Sorting... Done
Full Text Search... Done
gir1.2-vte-2.91/flidas,now 0.42.5-1ubuntu1 amd64 [installed,automatic]
GObject introspection data for the VTE library

libvte-2.91-0/flidas,now 0.42.5-1ubuntu1 amd64 [installed,automatic]
Terminal emulator widget for GTK+ 3.0 - runtime files

libvte-2.91-common/flidas,flidas,now 0.42.5-1ubuntu1 all [installed,automatic]
Terminal emulator widget for GTK+ 3.0 - common files

libvte-2.91-dev/flidas 0.42.5-1ubuntu1 amd64
Terminal emulator widget for GTK+ 3.0 - development files

libvte-2.91-doc/flidas,flidas 0.42.5-1ubuntu1 all
Terminal emulator widget for GTK+ 3.0 - documentation

So I would be very grateful if someone here could help me to install it from source, tell about their trust in the Timeshift project or just suggest any other tool similar to Timeshift you might use or know about.

Thank you!

[0] https://github.com/teejee2008/timeshift

Magic Banana

I am a member!

Desconectado/a
se unió: 07/24/2010

I would try to install the libvte-2.91-dev package.

amuza
Desconectado/a
se unió: 02/12/2018

Hey, thank you Magic Banana!

I have just tried, this is what I get:

amuuza@trisquel8:~/git/timeshift/src$ sudo apt install libvte-2.91-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
libvte-2.91-dev : Depends: libgnutls-dev (>= 3.2.7) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
amuuza@trsiquel8:~/git/timeshift/src$
amuuza@trisquel8:~/git/timeshift/src$
amuuza@trisquel8:~/git/timeshift/src$ sudo apt install libgnutls-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
libgnutls-dev : Depends: libgnutls30 (= 3.4.10-4ubuntu1.4) but 3.5.18-1ubuntu1+8.0trisquel1 is to be installed
Depends: libgnutls-openssl27 (= 3.4.10-4ubuntu1.4) but 3.5.18-1ubuntu1+8.0trisquel1 is to be installed
Depends: libgnutlsxx28 (= 3.4.10-4ubuntu1.4) but 3.5.18-1ubuntu1+8.0trisquel1 is to be installed
E: Unable to correct problems, you have held broken packages.
amuuza@trisquel8:~/git/timeshift/src$

Magic Banana

I am a member!

Desconectado/a
se unió: 07/24/2010

The same happens if I try to install libgnutls-dev on my system. It looks like a bug...

amuza
Desconectado/a
se unió: 02/12/2018

Thanks.

If you think it is worth it to report the bug, and you also know how and where, please let me know.

Magic Banana

I am a member!

Desconectado/a
se unió: 07/24/2010

That would be there: https://trisquel.info/node/add/project-issue/trisquel

It would help to discover whether the bug still exists on Trisquel 9, trying to install libgnutls-dev on the live system: http://jenkins.trisquel.info/makeiso-etiona/iso/

If the bug does not exist anymore, it is probably not worth fixing it (apparently, nobody but you has faced it, in more than two years of existence of Trisquel 8). If it still exists, it would be be good to discover whether it exists as well on Ubuntu 18.04 (Trisquel 9 is based on it), trying to install libgnutls-dev on Ubuntu's live system. If Ubuntu 18.04 suffers from the bug, it should be reported and fixed upstream (and Trisquel 9 would profit from the correction).

amuza
Desconectado/a
se unió: 02/12/2018


amuuza@trisquel8:~$ sudo apt install libgnutls30
[sudo] password for maritecla:
Reading package lists... Done
Building dependency tree
Reading state information... Done
libgnutls30 is already the newest version (3.5.18-1ubuntu1+8.0trisquel1).
The following packages were automatically installed and are no longer required:
android-libadb android-libbase android-libcutils android-liblog ash drbl
icc-profiles-free ipcalc jami-all nextcloud-client nextcloud-client-l10n
nilfs-tools partclone partimage pigz python-nbxmpp python-pyasn1
scribus-data wakeonlan
Use 'sudo apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 63 not upgraded.
amuuza@trisquel8:~$
amuuza@trisquel8:~$
amuuza@trisquel8:~$ sudo apt install libgnutls-openssl27
Reading package lists... Done
Building dependency tree
Reading state information... Done
libgnutls-openssl27 is already the newest version (3.5.18-1ubuntu1+8.0trisquel1).
The following packages were automatically installed and are no longer required:
android-libadb android-libbase android-libcutils android-liblog ash drbl
icc-profiles-free ipcalc jami-all nextcloud-client nextcloud-client-l10n
nilfs-tools partclone partimage pigz python-nbxmpp python-pyasn1
scribus-data wakeonlan
Use 'sudo apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 63 not upgraded.
amuuza@trisquel8:~$
amuuza@trisquel8:~$
amuuza@trisquel8:~$
amuuza@trisquel8:~$ sudo apt install libgnutlsxx28
Reading package lists... Done
Building dependency tree
Reading state information... Done
libgnutlsxx28 is already the newest version (3.5.18-1ubuntu1+8.0trisquel1).
The following packages were automatically installed and are no longer required:
android-libadb android-libbase android-libcutils android-liblog ash drbl
icc-profiles-free ipcalc jami-all nextcloud-client nextcloud-client-l10n
nilfs-tools partclone partimage pigz python-nbxmpp python-pyasn1
scribus-data wakeonlan
Use 'sudo apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 63 not upgraded.
amuuza@trisquel8:~$

nadebula.1984
Desconectado/a
se unió: 05/01/2018

What about installing it from Debian's current stable (buster) repository?

https://packages.debian.org/buster/timeshift

amuza
Desconectado/a
se unió: 02/12/2018

That's ok, I guess I can trust Debian.

But that link is for Buster, that's the latest Debian, isn't that a problem?

Thanks

nadebula.1984
Desconectado/a
se unió: 05/01/2018

timeshift is only available in Debian 10 (buster) or later, or Ubuntu 19.10 (eoan) or later.

If you want to install timeshift from Trisqual's repository, it will be available in Trisquel 10 (based on Ubuntu 20.04 LTS). ETA: 2-3 years (Trisquel 9 hasn't been released yet).

Magic Banana

I am a member!

Desconectado/a
se unió: 07/24/2010

If the package does not require recent versions of its dependencies, it can be installed on an older distribution. Downloading the package on https://packages.debian.org/buster/amd64/timeshift/download and double-clicking on it, GDebi, which is installed by default, tells some dependency cannot be satisfied on Trisquel 8: libgnutls30 must be at least at version 3.6.5. The same problem would occur on Trisquel 9, which is based on Ubuntu 18.04 Bionic Beaver: https://packages.ubuntu.com/bionic-updates/libgnutls30

One can then try to download http://security.debian.org/debian-security/pool/updates/main/g/gnutls28/libgnutls30_3.6.7-4+deb10u4_amd64.deb and install it in the same way. Doing so on Trisquel 8, GDebi tells that installing that package would break the existing libgnutls-openssl27 package (trisquel-minimal indirectly depends on it). I would stop trying to use the Debian package at that point. Beyond the incompatibility, notice that manually installed packages are not automatically updated. For security-critical packages such as libgnutls30, it is a significant problem: if you would install the version from Debian Buster and would not manually update it, it would stay at the present version until you update to Trisquel 10.

amuza
Desconectado/a
se unió: 02/12/2018

"What about installing it from Debian's current stable (buster) repository?"

So, I guess that was some kind of misunderstanding and there is no way to install Timeshift in Trisquel8 from Buster's repository. Please correct me if I'm wrong.

amuza
Desconectado/a
se unió: 02/12/2018

At http://jenkins.trisquel.info/makeiso-etiona/iso/

I see there are Triskel and Trisquel iso files, what's the difference?

Magic Banana

I am a member!

Desconectado/a
se unió: 07/24/2010

triskel and trisquel (notice the spelling difference) provide different sets of default packages. Mainly, triskel comes with the KDE desktop environment and trisquel with the MATE desktop environment. You can have the full list of packages in any ISO by reading the file with the same URL plus the suffix ".manifest".

amuza
Desconectado/a
se unió: 02/12/2018

Magic explanations!

chaosmonk

I am a member!

I am a translator!

Desconectado/a
se unió: 07/07/2017

> The same happens if I try to install libgnutls-dev on my system. It looks like a bug...

Yes, [first reported][1] in early 2019.

Welcome to Trisquel.

[1]: https://trisquel.info/en/issues/25393

chaosmonk

I am a member!

I am a translator!

Desconectado/a
se unió: 07/07/2017

> For security-critical packages such as libgnutls30, it is a significant problem: if you would install the version from Debian Buster and would not manually update it, it would stay at the present version until you update to Trisquel 10.

Trisquel's version of libgnutls is not receving security updates either. Compare Ubuntu's [changelog][1] to the [versions][2] available in Trisquel.

[1]: http://changelogs.ubuntu.com/changelogs/pool/main/g/gnutls28/gnutls28_3.4.10-4ubuntu1.8/changelog

[2]: http://archive.trisquel.info/trisquel/pool/main/g/gnutls28/

Magic Banana

I am a member!

Desconectado/a
se unió: 07/24/2010

The version APT proposes on my Trisquel 8 system is 3.5.18-1-ubuntu1+8.0trisquel1. Is it because I have enabled backports? There is no such backport in xenial-backports. In bionic-updates, the version is 3.5.18-1ubuntu1.4, which indeed looks more recent than the one APT proposes me. However, I am not certain I read all that correctly.

EDIT: http://archive.trisquel.info/trisquel/pool/main/g/gnutls28/ actually contains version 3.5.18-1ubuntu1.4, which apparently entered the repository five days after the date indicated in https://changelogs.ubuntu.com/changelogs/pool/main/g/gnutls28/gnutls28_3.5.18-1ubuntu1.4/changelog . Only for Trisquel 9? I am confused.

chaosmonk

I am a member!

I am a translator!

Desconectado/a
se unió: 07/07/2017

I just asked quidam about this. Apparently, gnutls is supposed to be backported from Ubuntu bionic, but since 3.5.18-1ubuntu1 in 2018 new versions have not been getting automatically built. According to quidam it may have been an issue with GPG keys. He says it is fixed now and an up-to-date gnutls should be in the repo shortly.

Btw, I only tuned into the meeting briefly to report this issue, but it appeared that they were working on the fonts-ubuntu issue, so hopefully that should be fixed soon as well.

Magic Banana

I am a member!

Desconectado/a
se unió: 07/24/2010

Thank you for the excellent news.

amuza
Desconectado/a
se unió: 02/12/2018

Really nice news, thank you. I understand there is no need to report the bug anymore and I will shortly be able to keep trying my installation.

amuza
Desconectado/a
se unió: 02/12/2018

This message is not a complaint.

He says it is fixed now and an up-to-date gnutls should be in the repo shortly.

Apparently I was close to be able to install Timeshift in Trisquel, but now I don't know if there is already an available solution, if new problems appeared or if I just simply have to wait for some more time.

Please let me know if anyone has any news or suggestion.

Thanks!

amuza
Desconectado/a
se unió: 02/12/2018

When I said "to install Timeshift", I meant to build it from source.