Trisquel 9 : make indisponible et paquet build-essential non installable

4 respuestas [Último envío]
eean
Desconectado/a
se unió: 07/06/2011

Bonjour,

J'ai effectué une recherche dans le présent forum, ainsi que dans les forums anglophone et hispanophone, mais je n'ai pas trouvé de sujet correspondant qui pourrait m'aider.

Je suis sous Trisquel 9 et j'ai besoin de compiler avec make.

Je tente donc d'installer le paquet build-essential qui est censé fournir la commande make.

Malheureusement, j'obtiens l'erreur suivante :


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :
Les paquets suivants contiennent des dépendances non satisfaites :
build-essential : Dépend: libc6-dev mais ne sera pas installé ou
libc-dev
Dépend: g++ (>= 4:7.2) mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

Il y a donc des problèmes de dépendances.

Lorsque j'essaie d'installer libc6-dev, nouveau problème de dépendance :


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :
Les paquets suivants contiennent des dépendances non satisfaites :
libc6-dev : Dépend: libc6 (= 2.27-3ubuntu1.2) mais 2.27-3ubuntu1.3 devra être installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

Si quelqu'un a une solution, ou au moins un début d'explication, son aide sera grandement appréciée. :-)

BurritoJohn
Desconectado/a
se unió: 12/13/2020

Bonjour, en spécifiant la version de libc6 à l'installation ça donne quoi ? (Commande à vérifier suivant le lien en dessous)

apt-get install libc6=2.27-3ubuntu1.3

Dixit cette solution à un problème similaire: https://www.linuxquestions.org/questions/debian-26/unable-to-install-libc6-dev-527112/

riquet607
Desconectado/a
se unió: 02/01/2018

Bonjour,
Le gestionnaire de mise à jour vient de me proposer entre autre d'installer libc6-dev sur Trisquel 9 : est-ce une coïncidence ?
Dépendance satisfaite ? A vérifier...

Magic Banana

I am a member!

Desconectado/a
se unió: 07/24/2010

La description du paquet build-essential commence ainsi :

If you do not plan to build Debian packages, you don't need this package.

Comme tu ne veux pas construire de paquet Debian, juste l’utilitaire make et probablement un compilateur pour un langage spécifique (buil-essential dépend notamment de g++, pour compiler du C++, qui n’est peut-être pas le langage dans lequel est écrit le logiciel que tu veux compiler), installer plutôt le paquet make et le compilateur dont tu as besoin.

eean
Desconectado/a
se unió: 07/06/2011

Bonjour,

Merci à tous pour votre aide. :-)

@riquet607, en effectuant une mise à jour des paquets aujourd'hui, j'ai effectivement constaté que les dépendances initialement manquantes pour build-essential étaient proposées. J'ai donc effectué les mises à jour et j'ai pu installer build-essential dans la foulée.

@Magic Banana, c'est vrai que j'ai l'habitude de ne pas m'embêter à installer make et gcc (ou g++) séparément et que j'installe donc généralement plutôt le paquet build-essential en considérant (à tort ?) qu'il embarque par défaut les éléments dont j'aurai potentiellement besoin pour compiler la plupart des applications nécessitant une installation à partir des sources. Toutefois, suite à ta réponse, j'ai effectivement pu constater que make et autres étaient disponibles séparément. J'aurais donc sans doute pu procéder ainsi dès le départ.

Je considère le sujet résolu, mais je n'ai plus la possibilité d'éditer mon post initial pour signaler la résolution.