Remove obsolete helpers in flidas

Proyecto:Trisquel
Versión:8.0
Componente:Packages
Categoría:informe de fallo
Prioridad:normal
Asignado:No asignado
Estado:active
Descripción

(I couldn't select version 8.0, but this is for 8.0)

We need to clean up the package helpers. Some are obsolete because a licensing issue was fixed upstream, package no longer in repo, etc.

A few obsolete helpers are:

  • cabal-install-1.20: flidas has a newer version. Someone might want to backport ghc 8, and I think that would be better placed in backports.
  • ghc-7.8.3: Same as above.
  • grace: Fixed upstream. The included copy of cephes was relicensed under the GPL with permission from the author, and the new license is there in xenial.
  • sane-backends: Fixed upstream. snprintf.c was replaced with the free version. (However, this is not the case for the other sane packages that have helpers)
  • tcltrf: Fixed upstream. Debian (and Ubuntu) have a free implementation of RIPEMD.
  • unrar-free: Fixed upstream. unrar-free was updated to utilize unar if it encounters a RARv3 archive. It now recommends unar instead of the nonfree unrar.
  • xchat: Package no longer exists. (However, a helper might need to be made for the fork hexchat.)

If you find more, please post them below.

Sáb, 08/13/2016 - 15:57
  • gnome-orca: Backports from utopic.
  • red5: Backports from vivid.
  • virtualbox: Package no longer exists in main or universe. This helper can be removed in both belenos and flidas.
  • wxmaxima: This one backports from utopic.
Sáb, 08/13/2016 - 23:34
Versión:7.0» 8.0

I added the proper project version to the issue tracker, so I've updated this first 8.0 issue to reflect so.

Dom, 08/14/2016 - 05:38

Hexchat mentions Firefox; we should probably change that to Abrowser or remove the reference entirely.

Lun, 08/15/2016 - 22:16

It would be better to use the default web browser, x-www-browser.