Retrieving mail from old hard drives into IceDove

5 réponses [Dernière contribution]
Hors ligne
A rejoint: 01/03/2015

In another thread I asked about bringing mail (stored in Mozilla-style profiles) into IceDove, and now what seemed like an open-and-shut process has gotten more complicated.

First, the /home directory on my old debian hard drive has me in it, but there's no Mail folder there ... but that hard drive has old mail stored all over the place, because I backed it up to those places. Same for my NAS.

One way is for me to copy & paste these old mail files (which I _have_ learned to recognize by their companion .snm, .msf, or .sbd files) into the corresponding places in my IceDove installation alomgside similar files (but with different names, of course). I've also learned not to bring along the dot*** files ...

Another way would be for me to let IceDove ferret them out ... but I'm not sure that IceDove is allowed (or even can) do that any more like Netscape/Mozilla used to do. Does the MoveMail function do that ?

Hors ligne
A rejoint: 07/10/2013

I just copied my old ".thunderbird" folder from my old machine and renamed it to ".icedove" on my new machine. That worked perfectly well.

Hors ligne
A rejoint: 01/03/2015

Continuing my saga ... After collecting vast quantities of old email repositories into one place on my NAS, I chose to start with the "easiest" one: The Thunderbird installation on my *indows laptop. I managed to do this by opening two instances of Terminal (one to help me keep track of the long path statements and the other for the heavy lifting). Then I moved just that one Profiles folder from NAS to a partition on a slave hard drive mounted in the desktop installation of Trisquel. That folder has been set up to keep track of my stored emails according to the source ISP account from which I originally pop'ed them down to the laptop. I used mv /sourcepath/filename /destinationpath/filename01 and so on. Except for a glitch having to do with Thunderbird filenames containing spaces, this went OK.

Except for one ISP which I no longer use: Trisquel's Icedove had no account set up for that ISP. Let's call it There are many files and mini-folders in this fairly well organized Inbox, but Icedove won't recognize as a valid folder, even though Terminal & Trisquel are happy with it, as they are for other accounts which I had already set up when I installed Icedove.

So far I have just tried to set up this account as a "MoveMail" account ... as it doesn't seem right to use it as a popmail account ... but Icedove says "unable to locate mail spool file" when I try "Get Messages" and it won't accept as the folder under which this myriad of messages is organized.

Three other accounts under Icedove have mixed results: One has two Inboxes, called Inbox (original to the Icedoce installation) and Inbox01 (which is where I have put the Thunderbird emails) and this one is completely successful; A second account has two inboxes which are labelled strangely, as Terminal sees them as Inbox01 and Inbox02 (both my settings) whereas there is no folder called just Inbox. Icedove initially had two such folders called Inbox (original to the Icedove installation and containing emails OK) and under that a subfolder called INBOX (greyed out and inaccessible, even after I renamed it to Inbox01) in this second account. A third account looks like the first account, but its Inbox01 apparently is empty, even after I checked the active profile and found ext-based emails there with sudo cat Inbox01.

The situation with the second account did not improve when I changed the names, Inbox01 and Inbox02, to Inbox and Inbox01, respectively.

My /dev/sda6 partition is formatted xfs and is mounted during startup at /home, which is where these files are.

Apparently, I did something right with the first account that isn't working with the other two accounts.

Hors ligne
A rejoint: 01/03/2015

Upon looking at the .icedove folder with File Manager, I discovered that the account that was working OK was under my ownership, but the others were open only to root (in Trisquel ?) so I did this:

> sudo chown -R george.users ~/.icedove/*

Which gave me the needed ownership ... alas, still to no avail. I 'spose that root owned them because I used sudo with the mv command ... Shouldn't Trisquel automatically make ownership of files under ~.icedove/* be consistent with the ownership of the Icedove application ? I'm not asked for my password to open Icedove.

Please also tell me why, when I navigate to an Inbox file, that I cannot right click and select, "open with icedove" ? Not even on the ones that Icedove opens in its normal course of business.

Hors ligne
A rejoint: 05/13/2010

Did you get the syntax right when you issued the command? See the manual page for the correct syntax. And should not the group be "george" instead of "users"?

The permissions won't get automatically changed. There's no such logic at work. I don't think this should (or will) change.

Also, the files have not been associated with Icedove. Whether this should be so is another thing. That's probably not a common thing to do. Can you find Icedove in the list under right click > open with other app?

Hors ligne
A rejoint: 01/03/2015

Regarding syntax:

> chown --help reveals:
> Usage: chown [OPTION]... [OWNER][:[GROUP]] FILE...

Which to me means OWNER comes before GROUP in:

>> sudo chown -R george.users ~/.icedove/*

Besides ... it worked, and the "locked" symbols instantly went away on all the root-owned accounts under Icedove.

Automatic changes in ownership could lead to security issues, so I accept their absence.

Regarding associations: Right clicking on an Inbox file that is OK in Icedove and selecting applications, Icedove is at the top of the list, but fails to even try to open the file. Gedit is there, too, and tries mightily to open the Inbox file, but it's too big to finish loading.