¿Se puede instalar ClipGrab en Trisquel 8.0?

3 respostas [Última entrada]
miangg
Desconectado
Joined: 03/02/2020

Buenas tardes.

Estoy interesado en instalar en Trisquel 8.0 una aplicación llamada "ClipGrab" que permite grabar vídeos de Youtube y otras webs, pero me encuentro con problemas que no sé si son debidos a la naturaleza de Trisquel (100% Software Libre) o por mi falta de conocimientos sobre GNU/Linux.

Tras ingresar en la web de la aplicación (https://clipgrab.org/), me encuentro con un enlace que permite descargar un instalador del tipo AppImage. Según el vídeo de Youtube en el que descubrí esta aplicación, hay que dar permisos de ejecución a ese archivo para poder abrirlo y que se instale la aplicación. Así me funcionó sin problemas en otra distro llamada MX Linux, pero en Trisquel lo único que ocurre es que se crea un archivo de texto sencillo de 0 bytes con un nombre lleno de símbolos seguidos de "(codificación no válida)".

La otra posibilidad que da la página web es descargar el código fuente en un archivo comprimido del tipo tar.gz. Tras descargarlo y descomprimirlo, me encuentro con un archivo README en el que se dan unas instrucciones para la compilación (según ellos, muy sencillas):

> You need to install the Qt5 developer libraries in order to compile the program.

> On Ubuntu and Debian-based system, you can install the necessary libraries like this:

sudo apt install qtbase5-dev qtwebengine5-dev

Pues bien, soy incapaz de encontrar la librería "qtwebengine5-dev" para poderla instalar, porque no se encuentra en APT ni en Synaptic.

Así pues, estoy atascado en este punto. Por ello les pido un poco de ayuda o asesoría sobre qué camino tomar para poder instalar "qtwebengine5-dev", a no ser que el problema tenga su origen en que la librería no es 100% software libre y, por lo tanto, no tiene cabida en Trisquel.

Debo decir que también he intentado la aplicación "youtube-dl", pero no me funciona, o bien no es posible disponer de la última versión.

Les doy las gracias de antemano y espero que alguien me pueda dar alguna pista o información valiosa.

Muchas gracias y saludos.

Ark74

I am a member!

Desconectado
Joined: 07/15/2009

Disculpa, desconozco ClipGrab absolutamente.

De igual manera los AppImage, son formatos poco recomendables, ya tienden a convertirse en un binario que no sabes como se compiló. Dicho hecho, no tengo nada en contra de ellos solo que si puedes evitarlos, sería preferible.

Regresando al tema de las librerías el tema que encuentras es que necesitas ejecutar T9 en adelante para tener compatibilidad con dicho software.

qtwebengine5-dev

Pertenece a T9/U18.04 en adelante.

Saludos

miangg
Desconectado
Joined: 03/02/2020

Muchas gracias por la información, Ark74.

Veremos si con la llegada de Trisquel 9.0 podré emplear ClipGrab.

De todos modos, me gustaría saber si alguien por aquí emplea alguna aplicación para descargar vídeos de Youtube, ya sea a través del terminal o del escritorio. Conozco «youtube-dl», pero aún no me he familiarizado con ella. A mí en realidad me interesa descargar esos vídeos para poder extraer de ellos el audio.

Saludos.

S-PJJ
Desconectado
Joined: 12/27/2019

¡Buenas!

Como alternativa te puedo escribir lo que yo hago si quiero extraer el audio de algún vídeo. Lo que hago es descargarme el vídeo desde "youtube-dl" (en el foro puedes encontrar la forma de como usarlo, es muy fácil realmente), después con el editor de vídeos "Kdenlive" extraigo el audio del vídeo (lo malo es que está en formato .wav), por último con "Audacity" le cambio la extensión a .ogg a ese audio que he extraído y listo. Así es como lo hago, posiblemente haya otra forma más rápida de hacerlo, posiblemente la puedas encontrar indagando por la web.

¡Un abrazo!.