[Fallo] - Error de Pitivi en Trisquel 8

12 respostas [Última entrada]
S-PJJ
Desconectado
Joined: 12/27/2019

¡Buenas!

En mi distribución de Trisquel 8 existe la versión 0.95 del editor de vídeo Pitivi, el problema es que me sale el siguiente error que verás adjunto en una captura de pantalla. He intentado instalar algunas librerías de Gstreamer, porque me suena de que es por eso, pero no doy con la solución. Pregunto por aquí por si suena la flauta y alguien sabe cuál puede ser la posible solución a ese problema, espero que sea así, si no, pues nada, gracias de todas formas comunidad, espero vuestras respuestas con paciencia, gracias de nuevo.

¡Un abrazo!.

AnexoTamaño
Pitivi-Error.png58.76 KB
S-PJJ
Desconectado
Joined: 12/27/2019

Vale, me respondo y soluciono yo el problema.... Era la librería llamada "gstreamer-1.0-libav", sólo hay que instalarla en el sistema y ya funcionaría, el problema es que no está en los repositorios de Trisquel. He buscado información al respecto y no sé porqué no está disponible esa librería si Pitivi la necesita para funcionar.... Si alguien me puede aclarar el tipo de licencia que tiene esa librería, si es libre o no, para poder instalarla desde otro sitio, se lo agradecería, ya que no me quiero arriesgar a instalar algo privativo en mi Trisquel. Por mi parte seguiré buscando, pero si alguien lo sabe, le agradecería que lo escribiera y así ahorrar tiempo que cada vez tengo menos....

Gracias y otro abrazo.

Rafa Poverello
Desconectado
Joined: 08/09/2016

Supuestamente gstreamer tiene licencia libre: GNU LGPL

https://es.wikipedia.org/wiki/GStreamer

No sé por qué no está en los repositorios. Es probable que, como Trisquel todavía va con Ubuntu 16.04, el paquete existente sea una versión anterior, que lo mismo no va con Pitivi.

S-PJJ
Desconectado
Joined: 12/27/2019

¡Buenas Rafa!

Gracias por tu respuesta. Hasta hace poco he caído en mi propio error y era la librería "gstreamer1.0-libav" que si está en el sistema de Trisquel 8. Pero aún así no sé a que se debe ese error... Que yo sepa, la versión de Pitivi 0.95 ya tenía soporte para vídeos con extensión libre .webm (a no ser que esté equivocado), sólo sé que es una librería de GStreamer la que falta, pero no sé cuál es y he probado ya con bastantes, en fin, seguiré probando, de nuevo gracias Rafa.

Un abrazo.

Pablo G

I am a member!

Desconectado
Joined: 05/16/2012

Hola S-PJJ

Yo he instalado Pitivi y no me da este error. He probado a importar un vídeo y parece que lo admite para editar...
He visto lo que tengo instalado de gstreamer en Synaptic y son bastantes paquetes. A ver cuál te falta:

libreoffice-avmedia-backend-g
gstreamer1.0-libav
gstreamer1.0-vaapi
gstreamer1.0-nice
gstreamer0.10-alsa
gstreamer1.0alsa
gstreamer0.10-tools
gstreamer1.0-clutter-3.0
gstreamer1.0fluendo-mp3
gstreamer1.0-x
gstreamer0.10-plugins-base-apps
gstreamer0.10-plugins-base
gstreamer1.0-plugins-base
gnome-video-effects
girl1.2-gstreamer-1.0
libstreamer0.10-0
gstreamer0.10-pulseaudio
libges-1.0-0
libstreamer-plugins-base1.0-0
python3-gst-1.0
girl1.2-gst-plugins-base-1.0
libstreamer-plugins-good1.0-0
gstreamer1.0-plugins-good
libstreamer-plugin-base0.10-0
libgstreamer-plugins-bad1.0-0
trisquel-codecs
gstreamer1.0-plugins-bad-faad

S-PJJ
Desconectado
Joined: 12/27/2019

¡Buenas Pablo!

He instalado los paquetes que me faltaban y eran estos:

gstreamer0.10-alsa
gstreamer0.10-tools
gstreamer1.0-clutter-3.0
gstreamer0.10-plugins-base-apps
gstreamer0.10-plugins-base
gnome-video-effects
gstreamer0.10-pulseaudio

Pero aún así sigue sin funcionarme, es algo de una librería "gst" que da el problema de "Biblioteca (3)", bueno, el error lo tienes en la imagen adjunta. No sé que será, llevo desde ayer buscando pero no hay forma de hacerlo andar, pero en fin, gracias por tu respuesta.

Un abrazo.

Pablo G

I am a member!

Desconectado
Joined: 05/16/2012

Hola,

Una solución sencilla es en Sypnactic ir al menú Editar y elegir Reparar paquetes rotos para que arregle los problemas de dependencias.
Por si no lo has probado...

S-PJJ
Desconectado
Joined: 12/27/2019

Lo he probado, pero no tiene ningún tipo de problemas de dependencias. También me he leído el manual de Pitivi (esto ya por desesperación) y ni tampoco especifica nada sobre que puede ser, parece que está todo en orden, pero al añadir clips o vídeos en Webm me salta ese error y ahí se queda, no me deja hacer nada.

Por curiosidad Pablo, ¿tu usas Trisquel 8 u otra distro?, porque he estado buscando en anteriores posts del foro y parece ser que falla bastante en Trisquel, desconozco el motivo del que será....

Pablo G

I am a member!

Desconectado
Joined: 05/16/2012

Sí, uso Trisquel 8 en un portátil X200.
He "importado" un vídeo WebM, pero no he empezado a editarlo.

S-PJJ
Desconectado
Joined: 12/27/2019

Bueno, he estado probando Trisquel 8 en una máquina virtual y surge el mismo problema, lo he actualizado a Trisquel 9 y el problema en esa versión es inexistente, ahí funciona bien y aparte es la última versión del programa. Desde hace tiempo tengo ganas de actualizar a Trisquel 9 para colaborar con la versión beta e informar de los fallos para que sean corregidos y también para tener algo más actualizado el sistema y algunos programas que también me interesan, mañana actualizaré a Trisquel 9, esa es la solución que se me ocurre y la que voy a efectuar, gracias a los 2 por la ayuda.

Otro abrazo.

Pablo G

I am a member!

Desconectado
Joined: 05/16/2012

Hola

Perdona, he visto que tenía mas paquetes de gstreamer apuntados que no te informé :

gstreamer1.0-plugins-bad-videoparsers
gstreamer1.0-plugins-ugly-amr
gstreamer1.0-plugins-ugly
libgstreamer1.0-0
genome-app-install
gstreamer1.0-plugins.bad

Si aún tienes Trisquel 8 y te falta alguno podrías probar de nuevo.
Lo siento no haberte informado...

S-PJJ
Desconectado
Joined: 12/27/2019

No te preocupes ya está todo solucionado, gracias por el interés (Y)

Pablo G

I am a member!

Desconectado
Joined: 05/16/2012

Me alegro de que lo consiguieras. :D