Workspace Switcher Trisquel 5.0 Dagda

12 respostas [Última entrada]
gethhtc
Desconectado
Joined: 01/18/2012

Hello. I'm having problems with the workspace switcher applet on the bottom panel, there is no option for how many workspaces that one can choose, is there any other way to increase or decrease the amount of workspaces that someone requires?

SirGrant

I am a member!

I am a translator!

Desconectado
Joined: 07/27/2010

You right-click on the applet and select preferences. From the option menu that pops up you can change how many workspaces are available.

Magic Banana

I am a member!

Desconectado
Joined: 07/24/2010

It used to be possible to choose the number of workspaces from a right click and preferences. Unfortunately it does not seem to be the case anymore (but, fortunately for me, the 6 workspaces I chose to have some versions ago are still there). There is in gconf-editor (that you can execute from the pop-up that appears when pressing Al+F2) a parameter called num_workspaces in the /apps/metacity/general directory. Strangely enough, the reported value is, in my case, 2! That is why I will not experiment for you but you can try to change this 2.

SirGrant

I am a member!

I am a translator!

Desconectado
Joined: 07/27/2010

I'm not sure what you mean it isn't possible. I am running Trisquel 5 and I can do it.

Here is a screenshot:

ws_pref_0.png

Magic Banana

I am a member!

Desconectado
Joined: 07/24/2010

That is weird! I used to have that but now (on Trisquel 5 as well), this window does not show the "workspaces" section (the buttons at the bottom are directly beneath the "swticher" section).

gethhtc
Desconectado
Joined: 01/18/2012

Yes I got that screen in version 4.5 Slaine, but for some reason it does not appear in my Dagda installation! From your screenshot the only options I get are the two top options without the Workspaces option.

gethhtc
Desconectado
Joined: 01/18/2012

Thanks magic banana

Cyberhawk

I am a translator!

Desconectado
Joined: 07/27/2010

it's not possible to change the number of workspaces when using compositing effects. If you switch the desktop effects off, you can select the number of workspaces again. With effects on, you will have 2 workspaces forced on you.

gethhtc
Desconectado
Joined: 01/18/2012

Brilliant thank you very much, problem solved!

Magic Banana

I am a member!

Desconectado
Joined: 07/24/2010

It works with Compiz as grvrulz explained later. I should have realized it when giving the path, in gconf-editor, to the num_workspaces parameter since it includes "metacity".

grvrulz
Desconectado
Joined: 09/23/2010

Number of workspaces can be changed in Compiz config settings manager when cmpositing is enabled.

gethhtc
Desconectado
Joined: 01/18/2012

And another solution with ccsm, thank you very much.

gethhtc
Desconectado
Joined: 01/18/2012

As always with GNU/Linux, there's more than one way to skin a cat, thank you all.