X server error when I send an email

1 reply [Última entrada]
pascal@diogoantunes.org
Desconectado
Joined: 09/03/2012

Hi,
My WM is stumpWM, and I use for the moment sylpheed as client email.
So on log boot (on tty1), I put my login and my pass, followed by a "startx" launch.

So I run sylpheed program, and send my email...

Pouf*

No more X session:

---------------------
X.Org X Server 1.10.4
Release Date: 2011-08-19
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.24-31-server i686 Ubuntu
Current Operating System: Linux diogoantunes 3.0.0-31-generic-pae #5trisquel1 SMP Tue Feb 12 18:11:16 UTC 2013 i686
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.0.0-31-generic-pae root=UUID=c8dd1c9f-f631-4a1a-ad0b-0fbc91df27e8 ro quiet splash vt.handoff=7
Build Date: 23 May 2012 07:40:55AM
xorg-server 2:1.10.4-1ubuntu4.3 (For technical support please see http://www.ubuntu.com/support)
Current version of pixman: 0.22.2
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Mon Mar 18 07:28:53 2013
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
grep: /home/pascal/.stumpwmrc: No such file or directory
WARNING: Invalid version "CVS" for component "stumpwm"
WARNING: DEFUN/DEFMACRO(GET-WM-CLASS): # is locked
Ignore the lock and proceed
WARNING: DEFUN/DEFMACRO: redefining function GET-WM-CLASS in /home/pascal/.cache/common-lisp/clisp-2.49-unix/usr/share/common-lisp/source/stumpwm/workarounds.fas, was
defined in /usr/lib/clisp-2.49/clx/new-clx/clx.fas
WARNING: DEFUN/DEFMACRO(WITH-GCONTEXT): # is locked
Ignore the lock and proceed
WARNING: DEFUN/DEFMACRO: redefining macro WITH-GCONTEXT in /home/pascal/.cache/common-lisp/clisp-2.49-unix/usr/share/common-lisp/source/stumpwm/workarounds.fas, was
defined in /usr/lib/clisp-2.49/clx/new-clx/clx.fas
*** - handle_fault error2 ! address = 0xa3f2cbfc not in [0x684d5880,0x6862f000) !
SIGSEGV cannot be cured. Fault address = 0xa3f2cbfc.
GC count: 48
Space collected by GC: 0 31908000
Run time: 1 512094
Real time: 20 465553
GC time: 0 344019
Permanently allocated: 107136 bytes.
Currently in use: 5664960 bytes.
Free space: 12916 bytes.
Segmentation fault
xinit: connection to X server lost

waiting for X server to shut down ddxSigGiveUp: Closing log
---------------------

It's not my first time. But I had another X error, failure of X server, with another program or launch program.

Ex: when I left GIMP, same error.

It's the fault of its programs, or by a bad manipulation or configuration of starting X server?

Thanks in advance.

pascal@diogoantunes.org
Desconectado
Joined: 09/03/2012

I installed the last stumpwm version, and for the moment it's fine.