Abrowser version on Trisquel 6

17 risposte [Ultimo contenuto]
martinh
Offline
Iscritto: 02/21/2014

Hi all !
Just installed and fully updated Trisquel-mini 6.0.1
I've noticed that Abrowser is at version 41.0.2 ?
Does anyone know why this is ?
I thought Trisquel 6 was supported until 2017 ?
Thanks

Megver83
Offline
Iscritto: 12/21/2015

But that´s not a big deal. If you want to upgrade it, do it. & yes, Tisquel 6 LTS is supported until 2017
https://trisquel.info/en/trisquel-60-lts-toutatis-has-arrived
https://trisquel.info/en/trisquel-gnulinux-601-lts-upgrade-release

Legimet
Offline
Iscritto: 12/10/2013

Yes it is a big deal. Trisquel 6 is supported so security updates are expected.

lembas
Offline
Iscritto: 05/13/2010

Looks like abrowser 41 has no less than 16 critical vulnerabilities when compared with the current firefox 45. And then there are the high, moderate and low impact vulnerabilities... (probably not all of them on GNU/Linux though)

https://www.mozilla.org/en-US/security/known-vulnerabilities/firefox/

This is pretty disappointing, after all many of us use the browser all day every day. If the maintenance is too much work, perhaps Trisquel should be tracking Firefox ESR instead, which would also be a bad solution.

0d54770d

I am a member!

Offline
Iscritto: 04/09/2016

This is a regrettable situation indeed; however, I recommend running abrowser in a jail (using firejail), which will hopefully mitigate at least some of the potential issues.

lembas
Offline
Iscritto: 05/13/2010

This really needs some attention ASAP.

oysterboy

I am a member!

I am a translator!

Offline
Iscritto: 02/01/2011

And what about Abrowser on Trisquel 7 (current Firefox version: 45 / current version of Abrowser in Trisquel 7: 44)?

Alij
Offline
Iscritto: 05/07/2012

I use Abrowser v36 ...XD

root_vegetable
Offline
Iscritto: 10/26/2015

I found an old computer with Firefox 9. Back when Firefox was less of a monster.

Alij
Offline
Iscritto: 05/07/2012

I would love install FF9 again ;D

https://ftp.mozilla.org/pub/firefox/releases/

EDIT: DONE>

Unistalled v45 and back to 9.0 XD kinda fast and lightweight

ff9.png
mixalis_t
Offline
Iscritto: 02/21/2014

What are the steps required to update abrowser 44 in order to be available from apt-get as an update for Trisquel 6?

Magic Banana

I am a member!

Offline
Iscritto: 07/24/2010

Is "updating to Trisquel 7" an acceptable reply? In less than a year, Trisquel 6 will not be receiving any update, including security update...

Legimet
Offline
Iscritto: 12/10/2013

The Abrowser in Trisquel 7 isn't up-to-date either. And Trisquel 6 should still be receiving security updates *for now*.

Magic Banana

I am a member!

Offline
Iscritto: 07/24/2010

mixalis_t wants version 44. That is the version Trisquel 7 currently has.

Legimet
Offline
Iscritto: 12/10/2013

But 44 is still outdated. Abrowser is not receiving security updates in any version of Trisquel.

mixalis_t
Offline
Iscritto: 02/21/2014

Unfortunately it isn't. I have an older laptop that I can't install trisquel 7 because of screen resolution problems. I think I'm not the only one in this situation. So, I Would like a newer version of abrowser (not necessarily 44). I am eager to help but don't know where to start.

I mentioned version 44 since it's already availabe for trisquel 7, so I thought that it's easier to start with this.

Magic Banana

I am a member!

Offline
Iscritto: 07/24/2010

You can install an older kernel (what matters for hardware support) on Trisquel 7. https://jxself.org/linux-libre/ has Linux-libre 3.4.

mixalis_t
Offline
Iscritto: 02/21/2014

Yes, trisquel 6 is supported until 2017 so I guess then I will have to compile the packages myself if it isn't a very laborious effort or switch to another libre distribution.