Flidas reluctant to start after software update

1 risposta [Ultimo contenuto]
Iscritto: 01/03/2015

On a secondary Thinkpad T420, after I ran Software Updater a few months ago,
the system would stall on booting. I put it aside.

Today I decided to face the issue. I found that the only version of the kernel
that would boot up (the name ending in... 141) put me in a place where I could
not see any of the data on the HDD. After running Software Updater, I found
that I could start a later version, but not the latest (name ending in ... 193).

This later version lets me see my data, but it's not the version that grub
puts at the start of the boot list.

Along the way, some text appeared on the otherwise blank black screen:
TPM error (6) occurred attempting to read a pcr value

A Google search revealed several issues, but none related to trisquel flidas.

One suggestion was to activate the security chip in the BIOS. My T420 has such
a chip, but it's permanently inactive, but not disabled. So much for that approach.

An earlier version of this problem cropped up quite some time ago, and Magic
Banana suggested a fix that worked great. I would have thought by now that the
most recent Software Upgrades would have corrected the bug.

George Langford

Iscritto: 01/03/2015

Updating: The semi-functional O/S version is Linux-Libre 4.4.0-141-generic.

The nearly fully functional version is Linux-Libre 4.4.0-193-generic.

On further probing:

The top-most grub choice will start OK, but as soon as a WiFi dongle is
plugged into a USB port, the mouse and the rest of the USB ports go silent.

On my primary T420, the O/S is labeled Kernel Linux 4.15.0-112.generic x86_64.
With this setup, occasionally one of my two WiFi dongles will fall silent,
but switching to the other one revives the connection. Otherwise, all is OK.

My Internet access with the 2ndary T420 is now kaput, even though it worked
OK while I was preparing the first page of this topic.