Actualizar GPG

5 respuestas [Último envío]
yawin
Desconectado/a
se unió: 02/11/2016

Hace ya un tiempecito que se encontraron algunas vulnerabilidades gordas a GPG, pero a día de hoy mi trisquel sigue sin actualizarlo.

El comando concreto que uso para actualizar todo lo actualizable es el siguiente:
sudo apt-get update ; sudo apt-get upgrade -y ; sudo apt-get dist-upgrade ; sudo apt-get autoremove -y

Aun así, y a pesar de que la última versión de GPG es 2.2.27, la versión de mi distro es la 1.4.20

¿Cómo puedo actualizarlo? No se trata del último videojuego o de un reproductor de música; se trata de la principal herramienta para la seguridad en mis comunicaciones; necesito tenerla actualizada.

S-PJJ
Desconectado/a
se unió: 12/27/2019

¡Buenas Yawin!

Un gusto tenerte por aquí de nuevo.

He estado realizando pruebas en una máquina virtual con KVM con una iso de Trisquel 9.0 escritorio Mate y he logrado actualizar GNUPG. Adjunto a la comunidad de este foro un tutorial que he escrito con LibreOffice siguiendo los pasos que he realizado pero de una forma que se entienda bien, o eso espero, hehe, para todos aquellos que usen Trisquel 9.0 y tengan este problema.

Prueba con el tutorial y nos escribes de nuevo haber que tal te ha ido, espero que te funcione a la primera y puedas disfrutar de la nueva versión de GNUPG.

¡Un abrazo y suerte!.

AdjuntoTamaño
Trisquel 9.0 - Actualizar Versión GNUPG.pdf 36.27 KB
Pablo G

I am a member!

Desconectado/a
se unió: 05/16/2012

Hola,

Interesante el tema de GNUPG. Muchas gracias por este tutorial S-PJJ.
Yo tengo actualizado Trisquel 9.0 y la versión de gnupg es 2.2.4, por lo menos no tan antigua como la de yawin.
Veo en los enlaces de la solución que se refieren a Ubuntu 16.04, mientras que el actual Trisquel 9.0 es derivado de Ubuntu 18.04, creo.
No se si esto influirá en que funcione la actualización, pero si en una máquina virtual con Trisquel 9.0 ha funcionado, debe ser que gnupg no depende de la versión de la distribución que utilices...aunque la de yawin debería ser derivada al menos de Debian, supongo.

S-PJJ
Desconectado/a
se unió: 12/27/2019

Cuando estaba testeando Trisquel 9.0 también salía GNUPG 2.2.4, posiblemente Yawin estará usando Trisquel 8.0 que al basarse en Ubuntu 16.04 pues es posible que tenga todavía esa versión ya anticuada. Creo que los pasos a seguir en el tutorial son validos tanto para la versión 8.0 como la 9.0; a no ser que cambie alguna que otra librería, pero no lo creo, aunque tampoco lo doy por hecho, hehe.

yawin
Desconectado/a
se unió: 02/11/2016

En su día instalé Trisquel 8, sí. Pero al hacer dist-upgrade debería haberme actualizado, ¿no?

En fin. Muchas gracias por la respuesta. En cuanto la uni me deje un poco de tiempo para respirar veré si me funciona xD

S-PJJ
Desconectado/a
se unió: 12/27/2019

Sí, debería de haber actualizado GNUPG y muchas otras cosas más. Pero hay muchos fallos aún sin corregir en Trisquel; ya sea en la versión 8.0 o 9.0. También hay que tener en cuenta que tienen que mantener 2 versiones y acaban de anunciar que van a estar trabajando en Trisquel 10, entonces ya os podéis imaginar todo lo que tienen que hacer.

Pero activando los backports para intentar obtener algunas mejorías en algunos programas (a veces funciona, a veces), compilando versiones nuevas desde las páginas oficiales, y demás, al final sale más rentable actualizar el sistema por tu cuenta sin esperar mucho, porque como ya ves, te puedes quedar atrás en cero coma y eso ya lo has experimentado; al igual que yo en su día, lamentablemente.

Pero considero que las cosas importantes como: GNUPG, los navegadores (al menos los más usados), Pidgin, etc... sí deberían de estar actualizados; pero no lo están ¿por qué?, uhm, eso mejor que sea Rubén o algún desarrollador que esté dentro de Trisquel que diga algo al respecto ya que ellos sabrán a ciencia cierta el porqué. Yo ahí ya ni pincho ni corto; como mucho puedo conjeturar, pero al fin de cuentas lo que yo diga se queda en eso, en conjeturas.

Espero que el tutorial te funcione. Ya nos contarás, hehe. Suerte con la UNI.