Can't boot into Trisquel on Lenovo

4 respuestas [Último envío]
se unió: 04/05/2024

Hello, friends!
I'm just getting started with Linux. And I decided to try Trisquel, as it is the most understandable among the GNU distros for average user.
The goal is to use it on a laptop (Lenovo Ideapad 5 15ALC05) with an external SSD.
But I cann't boot into Live.
In normal mode - black screen.
In grub2 mode - the splash screen appears. But it still ends with error.
Many lines of stdin: Invalid argument

It seems I disabled everything that was possible In UEFI. Also Fast boot in Windows.

Then I tried booting on the old PC with BIOS. Live has started. I installed Trisquel on a USB stick. Everything works on PC.
But it doesn’t start on the laptop, it just loads the installed system. Moreover, while putting in UEFI the next order:
1. USB with Trisquel
2. USB with installation image
3. HDD
the USB stick with the installation image starts first.

I also tried this USB stick on a Windows tablet. There can be set Legacy Boot in UEFI and Trisquel will load completely.

What else I've tried
- Switching USB sockets
- Using a USB hub 2.0
- Using a different USB stick

Please give me an advice what can I do to get Trisquel working on my laptop?

se unió: 09/13/2010

Seeing that AMD Ryzen doesn't make me hopeful; my instinct is saying it probably needs non-free software in order to operate. Something you could try: Move the drive to a different computer, do the install there. Install the latest kernel version: which is currently 6.8.4. Then move the drive back and see if the newer kernel makes a difference. It probably won't but there's no harm in trying.


I am a member!

I am a translator!

se unió: 07/15/2009

Make sure to test the latest ISO set[1], maybe you could try install using the netinstall as (AFAICT) that will use nomodeset by default and you could complete the installation, then test the latest kernel either on Trisquel hwe-6.5 (currently) or the linux-libre[2] by the FSFLA, which tracks the latest releases by



se unió: 04/05/2024

Hello, my dear friends!
Thank you for your answers.
Before I read the answers, I decided to try Live in GNU distributions Dynebolic and PureOS. They have launched, but some functions did not work, but more on that below.
So now I have some success, if I may say so.
First of all I've updated the kernel on USB stick. But that doesn't help. The laptop kept skipping booting it.
Then I noticed, that my iso version was 11.0.
So I downloaded 11.0.1 on your recommendation.
It has some other errors while booting in Live.
But unlike 11.0 I was able to launch Install Trisquel in grub2 mode.
Next I installed it on external SSD.
After reboot a menu in grub mode appeared. Selecting Trisquel GNU/Linux it gave the same errors as they were in Live boot.
Then I chose Advanced options for Trisquel.
The first line of Trisquel GNU/Linux with Linux Libre 5.15.0-101 generic ended as usual.
But the second line has issued the execution of commands with green OKs. Recovery menu has started. I've chosen Resume normal boot. And voila - Trisquel was launched.

As I understand booting in Live and standard boot differ from Normal boot in Recovery menu. May be it loads something in another order? Is it possible for me to fix it so I could launch standard boot without Recovery menu?

One more question about some functions performance. They also did not work in the distros listed above.
It is not possible to change the screen brightness. It stays maximum all the time. At the same time, when I move brightness slider, the Switch to external screen menu pops up.
Bluetooth and WiFi also does not work.
Can it be fixed? Or will I have to use their non-free drivers for this device?

Magic Banana

I am a member!

I am a translator!

se unió: 07/24/2010

Is it possible for me to fix it so I could launch standard boot without Recovery menu?

What actually happens when you try to normally boot Trisquel? What are the errors you mentioned? Do you reach the graphical login screen? Can you at least log into in a text session after typing Ctrl+Alt+F3?

Can it be fixed?

You can acquire a Wi-Fi adapter and/or a Bluetooth that respects your freedom. For instance from