Computer will not shut down

10 respuestas [Último envío]
se unió: 08/09/2013

I recently purchased a Librem 13 laptop and installed Trisquel 8 on it.

Everything works great except:

The computer will not shut down. It hangs indefinitely on the screen with the pulsing Trisquel logo.

This happens the same using the shut down button in the desktop GUI or using the poweroff command in the terminal.

This is very frustrating as I basically can't use the computer until this is fixed.

Does anyone have any ideas or suggestions?

Much appreciated!

se unió: 10/27/2018

Did you already contacted about it?

Did you tried this command?

# sudo poweroff -f

Maybe this[1] can help?


se unió: 07/05/2014

If it is like my T400, it has to do with the Wifi driver. When I am running with the Wifi on it will not shut down until I use the physical Wifi switch to isolate it.

Might not be a solution for you but that is what works for me.

dctrud (no verificado)

If you are on the stock Trisquel kernel, you might like to try jxself's packaging of linux-libre:

On my desktop machine power-off does not complete reliably with the stock Trisquel 8.0 kernel, but works with 4.19 or 5.2 linux-libre.

se unió: 08/09/2013

Libreshop, thank you for your suggestions and link to the article about different commands for shutting down.

Yes I did contact and they suggested that it could be an issue with systemd, or the swap partition, and suggested I run the poweroff command and see if I get any error messages. Upon running the poweroff command, I got the same result as before: I don't get any error messages that I can see, there is some text that comes up but it flashes by so quickly I can't read it, and goes to the screen with the pulsing logo, where it hangs forever. When I told them this, they said: "As this seems to be related with the operating system you are using now. I would recommend you to visit the Trisquel support forums for it's users:".

After reading your post and the article you linked, I tried "sudo shutdown -P now" but got the same result as before. I tried sudo poweroff -f and it did something different: it said, in the terminal, "Powering off.", but then sat there forever doing nothing.

CalmStorm, did you have this same problem with Trisquel 8? Did you ever fix it? Or switch to a different distribution? Do you have the same problem with another distribution? What model laptop do you have?

Jabjabs, thank you for the suggestion about the wifi switch. Unfortunately, this did not fix my problem.

dctrud, thank you for your suggestion about using a different kernel. This looks very involved and I would hope to find a simpler solution if one is available.

Does anyone have any further ideas? Much appreciated!


se unió: 02/17/2016

Press esc to remove the pulsating screen curtain and reveal the cli interface. You should be able to see the line where the shutdown stops moving ahead.

se unió: 10/27/2018

Can you reboot or logout of your session? And lock screen, does those options work?

se unió: 02/12/2015

> Does anyone have any further ideas? Much appreciated!

As dctrud said, I would try a newer Linux-libre kernel from jxself's repository:

Otherwise you are using extremely new hardware with a 2 1/2 year old kernel that hasn't received anything but security updates since sometime in early 2017.

se unió: 08/09/2013

Libreshop: Lock screen and logout both work normally. Reboot causes the same problem as shut down.

loldier: Pressing esc did exactly what you said it would!

I did this several times and each time this is what I got each time (except once, see below).

[ OK ] Started Show Plymouth Reboot Screen.
[ OK ] Stopped Cryptography Setup for nvme01p5_crypt.
[ OK ] Reached target Unmount All Filesystems.
[ OK ] Removed slice system-systemd\x2dcryptsetup.slice.
[ OK ] Reached target Shutdown.

And then on the line below that is a flashing cursor (like a flashing underscore character). It stays there forever.

But one time I got this instead:

[ OK ] Started Show Plymouth Reboot Screen.
[ OK ] Stopped Cryptography Setup for nvme01p5_crypt.
[ OK ] Reached target Unmount All Filesystems.
[ OK ] Removed slice system-systemd\x2dcryptsetup.slice.
[ OK ] Reached target Shutdown.
[ 112.115472] systemd-shutdown[1]: Sending SIGTERM to remaining processes...
[ 112.117560] systemd-journald[473]: Received SIGTERM from PID 1 (systemd-shutdow).
[ 112.117963] systemd-shutdown[1]: Sending SIGKILL to remaining processes...
[ 112.119606 systemd-shutdown[1]: Process 1751 (plymouthd) has been been marked to be excluded from killing. It is running from the root file system, and thus likely to block re-mounting of the root file system to read-only. Please consider moving it to an initrd file system instead.
[ 112.119855] systemd-shutdown[1]: Unmounting file systems.
[ 112.119960] Remounting '/' read-only with options 'errors=remount-ro,data=ordered'.
[ 112.128418] EXT4-fs (nvme0n1p1): re-mounted. Opts: errors=remount-ro,data=ordered
[ 112.131177] systemd-shutdown[1]: Remounting '/' read-only with options 'errors=remount-ro,data=ordered'.
[ 112.131266] EXT4-fs (nvme0n1p1): re-mounted. Opts: errors=remount-ro,data=ordered
[ 112.131284] systemd-shutdown[1]: All filesystems unmounted.
[ 112.131298] systemd-shutdown[1]: Deactivating swaps.
[ 112.131336] systemd-shutdown[1]: All swaps deactivated.
[ 112.131349] systemd-shutdown[1]: Detaching loop devices.
[ 112.131984] systemd-shutdown[1]: All loop devices detached.
[ 112.131999] systemd-shutdown[1]: Detaching DM Devices.
[ 112.132269] systemd-shutdown[1]: Detaching DM 252:2
[ 112.157600] systemd-shutdown[1]: Detaching DM 252:1
[ 112.185505] systemd-shutdown[1]: Detaching DM 252:0
[ 112.217557] systemd-shutdown[1]: All DM devices detached.
[ 112.222777] systemd-shutdown[1]: Powering off.
[ 112.222821] kvm: exiting hardware virtualization

And it stays there forever.

I haven't been able to figure out why I got a different result just one time.

I feel a little closer to a solution, now that I can at least see something of what's happening. Perhaps this text means more to someone than it does to me?

Thank you so much everyone who has posted suggestions.

Magic Banana

I am a member!

se unió: 07/24/2010

It looks all normal: the target "Shutdown" is reached. The problem must be in the kernel. suggests adding options (apm=power_off, acpi=force, etc.) to it (in the GRUB_CMDLINE_LINUX_DEFAULT variable of /etc/default/grub, unless you do not use the default bootloader) or disabling things in the BIOS (USB 3.0 legacy mode, EuP-setting, etc.).

I would first try a newer kernel. Installing the package "linux-image-generic-hwe-8.0" (in Trisquel's repository) will give you version 4.15. seems down at the moment. When back online, it will provide instructions to get an even newer kernel. After installing the kernel you need to reboot (on the newer kernel) and try to shutdown to see if the newer kernel does not suffer from the same problem.

se unió: 08/09/2013

I am happy to report that after installing the package linux-image-generic-hwe-8.0 this problem is solved.

Thank you so much to Magic Banana and to all who commented. It's hard to express how helpful this has been. Thank you so much.