dpkg errors installing firejail

6 respuestas [Último envío]
Geshmy
Desconectado/a
se unió: 04/23/2015

These are the only repositories I have enabled:
deb mirror://linux-libre.fsfla.org/pub/linux-libre/freesh/mirrors.txt freesh main
deb https://archive.trisquel.info/trisquel/ etiona main

I am using Synaptic or commandline to install. Some emacs programs fail to install though they are listed as available. Today I tried to install firejail via sudo apt install firejail and looked like it downloaded everything fine but erred much trying to configure.

Here is a typical output
dpkg: error processing package elpa-epl (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of edb:
edb depends on emacs | emacs24 | emacs-snapshot; however:
Package emacs is not configured yet.
Package emacs24 is not installed.
Package emacs-snapshot is not installed.

Firejail is installed and can bring up Abrowser but Abrowser doesn't function, can not load pages, but I am hoping to get my emacs environment working better first. I attached the complete list of dpkg errors.

Help?

AdjuntoTamaño
firejailInstallErrors.txt5.26 KB
Magic Banana

I am a member!

Desconectado/a
se unió: 07/24/2010

I would try to execute in a terminal:
$ sudo dpkg --configure -a

Geshmy
Desconectado/a
se unió: 04/23/2015

Thanks MB,
Ended up getting pretty much the same errors.
Attached complete output.

AdjuntoTamaño
dpkg--configure_errors.txt 5.19 KB
Geshmy
Desconectado/a
se unió: 04/23/2015

I was able to do:
sudo dpkg --clear-selections
sudo dpkg --configure -a
(Neither complained and quickly returned to prompt)
but
sudo apt remove firejail
tripped the error reporting all over again.
Also, again:
sudo dpkg --clear-selections
sudo dpkg --configure -a
but
sudo apt autoremove
tripped the error reporting all over again.

It's possible I have a conflict resulting from having install some emacs packages using guix and some using apt. I don't remember.

Geshmy
Desconectado/a
se unió: 04/23/2015

I also tried to install everything it complained wasn't installed:
sudo apt install emacs23 emacs24 emacs25 emacs25-nox emacsen emacs25-lucid
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package emacsen is a virtual package provided by:
xemacs21-nomule 21.4.24-5ubuntu1
xemacs21-mule-canna-wnn 21.4.24-5ubuntu1
xemacs21-mule 21.4.24-5ubuntu1
emacs25-nox 25.2+1-6
emacs25-lucid 25.2+1-6
emacs25 25.2+1-6
You should explicitly select one to install.

Package emacs24 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package emacs23 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'emacs23' has no installation candidate
E: Package 'emacs24' has no installation candidate
E: Package 'emacsen' has no installation candidate

Geshmy
Desconectado/a
se unió: 04/23/2015

Well I made some progress:
sudo dpkg --configure -a
Setting up emacs25 (25.2+1-6) ...
Install bbdb for emacs25
install/bbdb: Byte-compiling for emacs25 ...
Generating bbdb-autoloads...
Byte-compiling bbdb...
done.
Install crypt++el for emacs25
install/crypt++el: Handling install of emacsen flavor emacs25
install/crypt++el: byte-compiling for emacs25
Install edb for emacs25
install/edb: Handling install of emacsen flavor emacs25
install/edb: Byte-Compiling in dir /usr/share/emacs/site-lisp/edb/ ...
No such keyword: :indent
ERROR: install script from edb package failed
dpkg: error processing package emacs25 (--configure):
installed emacs25 package post-installation script subprocess returned error exit status 1
Errors were encountered while processing:
emacs25

Looks like maybe edb is the only hold out right now.

Tried some tip I found here:
https://forums.linuxmint.com/viewtopic.php?t=262934

Magic Banana

I am a member!

Desconectado/a
se unió: 07/24/2010

I would try to remove emacs25 (and other Emacs-related packages). Once your system is back to a coherent state, you should be able to reinstall it. The packages emacs23, emacs24 and emacsen are not in Trisquel 9. They should not be installed.