Dudas Trisquel

15 respuestas [Último envío]
deMolay
Desconectado/a
se unió: 06/01/2013

Hola a toda la comunidad,

Soy nuevo así que pido perdon si esto no va aquí.

Soy estudiante de DAM (Desarrollo de Aplicaciones Multiplataforma) y fiel a la filosofía del software libre. He visto que Trisquel es de las pocas distros 100% libre y eso me gusta puesto que llevaba tiempo buscando una así...

Despues de un tiempo con ubuntu y probar gNewSense, Canaima y tener que volver a windows por ciertos problemillas, me he dado cuenta de que no soy nadie sin Linux (a pesar de no ser un experto).

Mis dudas son las siguientes, actualmente programo bajo Eclipse y utilizo programas como Geany, VirtualBox, LibreOffice, Skype... y me preguntaba si vuestra distro tiene todo lo que uso o tendría que buscar uno parecido.

Otra duda, cuando estaba en Ubuntu tube problemas con la version 12.04, así que estuve con la 11.10 todo el tiempo que pude. No se si deberia poner las características de mi portátil para que los expertos opinen.

Pido disculpas si esto no va aquí, espero acostumbrarme pronto.

Seguid así porque vuestro trabajo es increible.

Un saludo.

Lailah
Desconectado/a
se unió: 08/30/2012

Hola, bienvenido!

Sí, siempre es útil señalar las características del hardware. No
precisa que sea un compendio, alcanza con los puntos más importantes
;-)

Y por cierto, todos somos ALGUIEN. El Sistema Operativo va en la
computadora no en la persona ;-)
Espero que se entienda lo que dije y no se tome a mal.

Abrazo
LAILAH

--
*Netbook rota, internet inestable... No se enojen si entro en Modo Mute*

deMolay
Desconectado/a
se unió: 06/01/2013

Bueno bueno, no llevo ni 5 minutos y ya han respondido dos personas. Así da gusto formar parte de una Comunidad.

Veamos, mi portátil es:
- Packard Bell EasyNote TS-HR44
- Intel Core i5
- NVIDIA GeForce GT 520M 1GB
- 500GB de disco duro
- 6GB de RAM

Lo de Skype no es importante, los otros sí porque son con los que trabajo.

Una ultima duda, me haría ilusion colaborar con este proyecto. Sé que hay muchas formas de hacerlo (o eso he leido) pero para alguien nuevo como yo, que está estudiando y tal... es mejor que acabe mi formación? O eso es independiente?

Un abrazo a todos!!

deMolay
Desconectado/a
se unió: 06/01/2013

Buenas Ren-Canteros, cuando usaba Ubuntu ya tuve problemas para actualizar a su version actual 12.04 por la tarjeta gráfica...

Yo he tenido Trisquel instalado en Virtual Box, pero claro eso no tiene nada que ver no? jajaja (pregunta de ignorante total)

Un abrazo y ya os contare!!

rodrigocorozo
Desconectado/a
se unió: 05/06/2013

El ordenador portátil que utilizo tiene una tarjeta gráfica NVIDIA GeForce GT 540M, que sino me equivoco es un poco más nueva que la tuya. Y la estoy usando correctamente con Trisquel 6.0, con Gnome Classic como entorno de escritorio. Los paquetes que tuve que instalar para hacerla funcionar fueron los siguientes:

·Para añadir los repositorios y actualizarlos:

sudo add-apt-repository ppa:bumblebee/stable && sudo apt-get update

·Para instalar los controladores libres:

sudo apt-get install --no-install-recommends bumblebee && sudo apt-get install primus

Un dato bastante importante, es que has de tener instaladas las cabeceras de Linux antes de instalar los controladores.

Para saber que versión de Kernel tienes usa esto:

uname -r

Y una vez sepas la versión usa este comando:

sudo apt-get install linux-headers-X.X.X-XX-generic (sustituye las X por la versión que tienes).

Espero haberte sido de ayuda.

Por cierto cuando quieras usar tu tarjeta gráfica, pon delante del programa que quieras ejecutar "optirun". Por ejemplo de querer iniciar GIMP usarías:

optirun gimp-2.8

quiliro@congresolibre.org
Desconectado/a
se unió: 10/28/2010

El 03/06/13 13:38, name at domain escribió:
> El ordenador portátil que utilizo tiene una tarjeta gráfica NVIDIA
> GeForce GT 540M, que sino me equivoco es un poco más nueva que la
> tuya. Y la estoy usando correctamente con Trisquel 6.0, con Gnome
> Classic como entorno de escritorio. Los paquetes que tuve que instalar
> para hacerla funcionar fueron los siguientes:
>
> ·Para añadir los repositorios y actualizarlos:
>
> sudo add-apt-repository ppa:bumblebee/stable && sudo apt-get update

Estimado Rodrigo:
¿Verificaste el código fuente de esos repos para certificar que son
libres? Recuerda que muchos lo dicen pero pocos, como Trisquel lo son.

Estimado Kike:
Hay dos formas de ser libre: usar repos certificados por la FSF o
revisas tu mismo. Si no haces una de esas dos, caes en la dependencia.
Suele ser una espiral que va creciendo. Es mejor no empezar a menos que
lo hagas para desarrollar una opción libre.

--
Saludos libres,

Quiliro Ordóñez
Presidente (en conjunto con el resto de socios)
Asociación de Software Libre del Ecuador - ASLE
Av de la Prensa N58-219 y Cristóbal Vaca de Castro
Quito, Ecuador
(02)-600 8579
IRC: http://webchat.freenode.net?channels=asle&uio=OT10cnVlJjEwPXRydWU3a

Todo correo que reciba será tratado como información pública, de libre copia y modificación, sin importar cualquier nota de confidencialidad.

rodrigocorozo
Desconectado/a
se unió: 05/06/2013

Supongo que lo han de ser, ya que el proyecto Bumblebee es libre. No creo que el proyecto sea libre y sus repositorios no. Además si vas a su página, te marcan los pasos que he marcado antes.

ovruni

I am a translator!

Desconectado/a
se unió: 12/04/2010

Hola

No se de donde se deduce que el proyecto sea libre, incluso ese
repositorio tiene un paquete que recomienda software no libre
"bumblebee-nvidia". Ademas este mismo paquete en la distribución Parabola
GNU/Linux esta en blacklist (
https://projects.parabolagnulinux.org/blacklist.git/tree/blacklist.txt ),
teniendo su reemplazo bumblebee-libre .

Si valoran su libertad y la de los demás por favor mas cuidado antes de
recomendar repositorios externos que contengan software no libre.

Saludos

> Supongo que lo han de ser, ya que el proyecto Bumblebee es libre. No creo
> que
> el proyecto sea libre y sus repositorios no. Además si vas a su página,
> te
> marcan los pasos que he marcado antes.
>

--
Omar Vega

rodrigocorozo
Desconectado/a
se unió: 05/06/2013

Muchas gracias por la aclaración y perdón por mi metedura de pata. Tenía entendido que no instalando el paquete "bumblebee-nvidia" y usando "bumblebee" ya era el controlador libre. Seguramente tú estés en todo lo correcto, de nuevo disculpas por mi metedura de pata.

deMolay
Desconectado/a
se unió: 06/01/2013

Buenas rodrigocorozo,

Si no te he entendido mal siguiendo tus pasos haria la instalacion de los controladores libres, cierto?

Si es así, gracias por tu ayuda.

Una duda, no entiendo muy eso de que para usar mi gráfica tenga que ejecutar optirun.

Gracias a todos ^^

rodrigocorozo
Desconectado/a
se unió: 05/06/2013

Exactamente. Es decir con los pasos que antes te he marcado estás instalando solo los controladores libres para tu tarjeta gráfica. Y con lo de "optirun" haces que en vez de ejecutar el programa con la tarjeta integrada lo ejecutes con la tarjeta dedicada. Por lo tanto te pongo otro ejemplo: optirun shutter. Shutter por si no lo conoces es un programa para capturar tu pantalla en imágenes. Y por lo tanto dices que quieres abrir dicho programa con tu tarjeta de vídeo dedicada. De no quedarte claro dímelo que intentaré buscar algún otro ejemplo.

quiliro@congresolibre.org
Desconectado/a
se unió: 10/28/2010

El 11/06/13 11:06, name at domain escribió:
> Exactamente. Es decir con los pasos que antes te he marcado estás
> instalando solo los controladores libres para tu tarjeta gráfica. Y
> con lo de "optirun" haces que en vez de ejecutar el programa con la
> tarjeta integrada lo ejecutes con la tarjeta dedicada. Por lo tanto te
> pongo otro ejemplo: optirun shutter. Shutter por si no lo conoces es
> un programa para capturar tu pantalla en imágenes. Y por lo tanto
> dices que quieres abrir dicho programa con tu tarjeta de vídeo
> dedicada. De no quedarte claro dímelo que intentaré buscar algún otro
> ejemplo.

¿Verificaste? Recuerda que no es tan fácil.

--
Saludos libres,

Quiliro Ordóñez
Presidente (en conjunto con el resto de socios)
Asociación de Software Libre del Ecuador - ASLE
Av de la Prensa N58-219 y Cristóbal Vaca de Castro
Quito, Ecuador
(02)-600 8579
IRC: http://webchat.freenode.net?channels=asle&uio=OT10cnVlJjEwPXRydWU3a

Todo correo que reciba será tratado como información pública, de libre copia y modificación, sin importar cualquier nota de confidencialidad.

deMolay
Desconectado/a
se unió: 06/01/2013

Buenas a la comunidad,

Esta tarde me dispuse a dar el paso. Particioné mi disco duro, grabe Trisquel en un DVD, etc...

Pero como todo no iba a ser bonito pues llegó lo peor...

Cuando meto el DVD y me salen las opciones tipo (Probar sin instalar, Instalar Trisquel, etc...) he probado con cualquiera de las dos y mi portatil se queda ahi pensando

Empiezo a pensar que mi ordenador no está hecho para Trisquel o soy yo el que ha metido la pata en algo?

Saludos! ^^

Ark74

I am a member!

Desconectado/a
se unió: 07/15/2009

Es importante que revises que la imagen DVD que grabaste no vaya a estar corrupta, eso lo puedes revisar con la suma md5.

Puedes intentar con el netinstall (usa mesa, si no mal recuerdo)

Además es una buena idea que revises la compatibilidad de tu equipo en h-node.org (http://h-node.org/search/form/es) puede que ya exista algo en la base, de otra forma puedes documentar ahí la compatibilidad de tu equipo y te agradecería que de ser posible agregues cualquier dispositivo que no este en la base actualmente.

Saludos.

deMolay
Desconectado/a
se unió: 06/01/2013

Buenos días,

La imagen es correcta, puesto que desde VirtualBox puedo instalarla perfectamente.

Grabe el dvd desde InfraRecorder y todo perfecto, pero no pasa de la pantalla de seleccion (Instalar, etc...)

Alguna posible solución?

Un fuerte abrazo!!

-- Edit --

En esta misma web he leido que una posible solución es cambiar los parámetros de arranque...

- noapic nolapic
- acpi=off
- irqpoll
- lapic pci=routeirq

pr0t0type
Desconectado/a
se unió: 06/24/2013

Yo probaria con otro lector DVD externo por USB, a mi a veces se me quedaba trabada la instalacion cuando usaba el lector DVD interno.