How to make to able wifi?

13 respuestas [Último envío]
se unió: 08/15/2015

I have a problem with my wifi. I have disabled my wifi, don't recognize the signal, don't appear configured like device.

With the following command iwconfig show:

virbr0-nic no wireless extensions.

lo no wireless extensions.

enp1s0 no wireless extensions.

virbr0 no wireless extensions.

se unió: 09/13/2010

What is the make and model of your WiFi please? lspci or lsusb should say.

se unió: 08/15/2015

01:00.0 Ethernet controller: Qualcomm Atheros AR8152 v1.1 Fast Ethernet (rev c1)
02:00.0 Network controller: Intel Corporation Centrino Wireless-N 1000 [Condor Peak]

Magic Banana

I am a member!

se unió: 07/24/2010

Intel Wifi chipset, such as yours, require proprietary firmware, that denies your essential freedoms. Acquire another Wifi card or a Wifi adapter that Linux-libre supports. For instance one sold on or on (both ship worldwide).

se unió: 05/01/2018

You said that you have disabled the WLAN card. Does it mean that said WLAN card once worked before you disabled it?

If you disabled it in firmware (BIOS/UEFI), re-enable it. If you turned off its hardware switch, re-open it.

Then use lspci or lsusb to detect its model. Only Atheros ones (ath5k/9k/9k-htc, but not ath10k) work with Trisquel or other free/libre distribution.

Stallman rules
se unió: 08/10/2019

it seems that this is a problem growing over time.. (FUCK)

sorry...for my bad french.. but fuck fuck..

the man, mr robot cant connect to the net..

here is another..

and another...

and maybe many more..

i just made an normal update in trisquel.. aka controlcenter.. software updater.. and low and behold...
surfuckingprise there was an wpa update.. and it fucked my connection up.. fuck..

YES... im fucking angry on this constant non working the network/wifi connection and i am allowed to say fuck..fuck ...


the free as in freedom community want to spread freedom software/hardware .. but it seems that there is a taste for bell and whistles .. shiney mac/windows shitty solutions..

but as a newbee... and we are many.. we fucking just want to
acces the internet, mail and so on.. nothing fancy..
just normal every day stuff..

but... no way... we have to upgrade to trisquel 8 and 9 and forever.. and it seems that the shiny part of trisquel is the most updated and valued..

why not keep it kiss ... fucking simple..

and again.. sorry for my rant.. but i am so tired of shiny shit..

maybe i should drop trisquel and go to macshit ore winslow..

im tired..

the old trisquel 7 just worked fine and good.

best regards from some one who will go out and chop a hell load of wood... fuck 8O)

keep it simpel stupid..



I am a member!

se unió: 06/19/2015

Ethernet is simple and efficient and always works on Trisquel.

I always keep a Wi-Fi dongle stashed somewhere that I know works with
free operating systems. It works.

se unió: 01/10/2020

Okay hey so I have the same problem, so what I understand is there was been a update and has made trisquel unable to connect and find wifi options, is there any solutions to this. What exactly is a wifi dongle and how does this fix the problem?

Stallman rules
se unió: 08/10/2019

Problem.. with controling..

A wifi-dongle is a usb-stick with 4G mobilerouter, that you plug in a usb port.
the problem is, that the usb-dongle want's to install client software..
and then you have the problem... no internet access..
this dident acour in TrisQuel 7..

I do not, have a usb-dongle.. but a wifi router: huawei 4G
and after updating TrisQuel.. the 4G mobilerouter only allows
access to the internet.. if i configure it
to force TrisQuel to be a client.

I dont want to be a client to my isp.

I want to use, my 4G wifi router as a hotspot..
and nothing else.

free as in freedom.. and the power to control all
the proprietery isp client-(shit)

my friend have a usb-dongle.. see this:

Where are we ending with the free as in freedom, TrisQuel.. ?

and sorry for shit and fuck.. im' angry and frustraited..

also sorry for my bad english 8O)

Stallman rules
se unió: 08/10/2019

and by the way...

my machine is Libre x200 with Libre wifi-card..


and yes... you can buy wifi dongles with only wifi..

se unió: 08/15/2015

I try bring up wlan0 but show the following message:

wpa_supplicant: /sbin/wpa_supplicant daemon failed to start
run-parts: /etc/network/if-pre-up.d/wpasupplicant exited with return code 1
Failed to bring up wlan0.

se unió: 05/01/2018

Since you have an Intel WLAN card (according to another reply), it's impossible to use it without non-free firmware.

se unió: 03/19/2017

Hi Mr_Robot,
I use wifi from time to time, once I couldn't connect to a wifi device, and seemed to me that the wifi adapter was disabled. After trying too many things, I found that it was disabled in the hardware. So I press-ed FN+F8 (Function key + the key that has Wifi Antenna that posting signal symbol in it, in my laptop(Toshiba) is the F8 key) and the wifi worked.

se unió: 03/19/2017

Stallman rules;

Please read my posts in: