Message d'erreur Synaptic

4 respuestas [Último envío]
Sems
Desconectado/a
se unió: 07/10/2018

Bonjour,

Depuis quelques temps, un message d'erreur m'est systématiquement retourné lorsque je recharge le gestionnaire de paquets Synaptic:
W: http://download.ebz.epson.net/dsc/op/stable/debian/dists/lsb3.2/Release.gpg: la signature par la clé E5220FB7014D0FBDA50DFC2BE5E86C008AA65D56 utilise des algorithmes « digest » faibles (SHA1)

Que signifie ce message et comment puis-je faire pour résoudre cette erreur?

Merci d'avance

Cordialement

Magic Banana

I am a member!

Desconectado/a
se unió: 07/24/2010

L’authentification consiste à s’assurer que l’interlocuteur est bien qui il prétend être. En l’occurrence, ton interlocuteur est un dépôt de paquets et tu voudrais en effet t’assurer que c’est bien ce dépôt qui t’envoie des paquets et non un attaquant (le fameux « homme du milieu », « man in the middle » en anglais) qui t’enverrait du malware.

Techniquement l’authentification repose ici sur GPG (GNU Privacy Guard), qui lui-même repose sur une fonction de hachage : une fonction qui prend des données en entrées (partie du message envoyé par l’interlocuteur) et renvoie une courte chaîne de caractère censée être imprévisible. De sorte que l’on ne parvienne pas à envoyer un message différent tout en se faisant passer pour le véritable interlocuteur.

La fonction de hachage, SHA-1, utilisée par le dépôt Epson, est faible. Du coup, il n’est pas impossible qu’un attaquant puisse se faire passer pour ce dépôt et te fasse installer du malware sur ton système. Ce n’est pas non plus facile, hein.

Ce dépôt Epson contient du logiciel privateur, n’est-ce pas ? Voilà une raison plus sérieuse pour le supprimer : tes libertés.

Sems
Desconectado/a
se unió: 07/10/2018

Bonjour Magic Banana et merci pour ton retour.
Etant novice sur Linux et encore plus sur Triquel puisque je ne l'ai installé que depuis 3 mois environ, je suis loin de tout maîtriser et il est clair que j'ai dû faire une erreur à un moment donné et j'en refait malheureusement certainement d'autres le temps que je comprenne les rouages de Linux. Si j'ai basculé sur Trisquel, c'est effectivement pour conserver mes libertés. Je n'avais pas identifié que le lien concernait Epson, alors que je ne cherche pas à installer un driver, celui en place me convient. Du coup, j'ai suivi ton conseil, je l'ai supprimer et par bonheur, il semble que mes mises à jour se réalisent de nouveau avec succès.
Encore merci pour tes infos sur ce sujet.

azafranero
Desconectado/a
se unió: 05/21/2015

Pour installer ton imprimante Epson tu n'as pas besoin de charger le pilote propriétaire

cette ligne suffira si elle a un driver lbre

sudo apt install printer-driver-escpr

Sems
Desconectado/a
se unió: 07/10/2018

Oui, je l'ai déjà installé depuis un bon moment, je n'avais par contre pas détecté que le lien concernait des pilotes Epson.
Merci pour ton retour