'Open in terminal' does not work

8 respuestas [Último envío]
GNUbahn
Desconectado/a
se unió: 02/19/2016

Right clicking within a folder and click 'Open in terminal' suddenly does not work.

Any suggestions on why and how to solve this?

Magic Banana

I am a member!

Desconectado/a
se unió: 07/24/2010

If you are using Trisquel's default file manager (Caja), look into Caja-Actions, in MATE's "Control Center". The "Item lists" should include "Open in terminal".

GNUbahn
Desconectado/a
se unió: 02/19/2016

I actually do use Caja but under xfce. I prefer Caja over Thunar.

Hence, I don't have MATE's control center. In xfce's control center there is a menu point called 'File manager' but it refers to Thunar.

But 'Open in terminal' usually works and still does at my other machine, also running xfce and with Caja as the default file manager.

Maybe I should point out, that when right clicking in a folder, the menu point of 'Open in terminal' is there. It just does not work.

Magic Banana

I am a member!

Desconectado/a
se unió: 07/24/2010

You can launch MATE's "Control Center" from a terminal emulator:
$ mate-control-center

GNUbahn
Desconectado/a
se unió: 02/19/2016

MATE's control center wasn't installed but it is now.

The 'items list' is empty but actions can be added. However, I cannot find suggestions as to how to configure such an action.

I checked that I do have the caja-open-terminal package installed and suppose I need a command to activate it.

Can you help with e.g. a screenshot of how the open caja action is configured on your computer?

Magic Banana

I am a member!

Desconectado/a
se unió: 07/24/2010

Sure (and sorry for the delay). The screenshots of the first three tabs are attached. I believe the rest is default.

Open in terminal - Action.png Open in terminal - Command.png Open in terminal - Execution.png
GNUbahn
Desconectado/a
se unió: 02/19/2016

Thanks.

I have done the settings like yours except with 'xfce4-terminal' instead of 'mate-terminal'. But 'open in terminal' still doesn't work. When I manually enter 'xfce4-terminal' in a terminal a new terminal window opens. Hence, I believe the command is correct.

I wonder what may be the problem...?

Magic Banana

I am a member!

Desconectado/a
se unió: 07/24/2010

Again: sorry for the delay. First of all, I would like to point that I use Nautilus (not Caja) and GNOME Terminal: somebody else here may be more appropriate to help you!

I notice that the file management preferences ("Preferences" in the "Edit" menu of any Caja window) include an "Extensions" tab. Is "Open in terminal" listed there? If not, then I believe you should install the "caja-open-terminal" package (in Trisquel's repository). Is the related box checked on your system (it is on mine)? Can you "Configure Extension" (I cannot but that may be due to the fact that I does not actually run a MATE desktop environment)?

avrtm
Desconectado/a
se unió: 11/22/2019

..

Screenshot at 2019-11-22 15:51:10.png