PB installation de Kompozer.

12 respuestas [Último envío]
thierra
Desconectado/a
se unió: 02/19/2015

Bonjour,

Bonjour,

J'ai fait des recherches d'aide mais n'ai rien trouvé sauf "on télécharge, on extrait et c'est prêt". J'ai posté sur GeckoZone mais pas de réponse pour l'instant.

J'ai téléchargé kompozer-0.8b3.fr.gcc4.2-i686.tar.gz
J'ai extrait le paquet.
J'ai bien un fichier Kompozer dans le dossier mais impossible de lancer le programme. Quand je clique le fichier s'ouvre dans Gedit (éditeur de texte), c'est vrai pour toutes les autres applications du dossier. J'ai essayé aussi sh en ligne de commande. Ceci sous Trisquel et sous LinuxMint.
Voici les fichier du dossier en document joint et le code du fichier Kompozer.

Pas de problème sous Windows, c'est rageant.

Il doit manquer un logiciel ou une dépendance.

Si vous avez une idée, merci d'avance
Librement
Thierry Vedel

AdjuntoTamaño
Capture du 2015-11-19 16:39:05.png33.37 KB
kompozer.txt2.87 KB
3x4n (no verificado)
3x4n

A mon avis, tu devrais essayer de faire un chmod +x sur kompozer-bin et ensuite dans un terminal tu le lances ./kompozer-bin ou alors lancer le fichier run-mozilla.sh

En console, sa te permet de voir si une dépendance est absente.

A toi de voir!

Après comme dans chaque archives, il y a le bon vieux README ou autres qui t'explique comment faire. Il suffit juste de prendre son temps et de le lire.

thierra
Desconectado/a
se unió: 02/19/2015

Bonjour 3x4n,

Voilà le résultat après le lancement de kompozer-bin :
er$ ./kompozer-bin
./kompozer-bin: error while loading shared libraries: libmozjs.so: cannot open shared object file: No such file or directory

Ca ne m'avance pas.

Pour run-mozilla, je ne sais pas si j'emploie la bonne commande. Voilà mes essais et les résultats.

zer$ ./run-mozilla.sh

run-mozilla.sh: Cannot execute .

thierry@gpasdidee:~/logiciels/kompozer$ sh ./run-mozilla.sh

run-mozilla.sh: Cannot execute .

Il est en mode exécutable.

Merci
Thierry Vedel

Substance2004
Desconectado/a
se unió: 11/05/2013

Thierry,

En matière d'édition de page web, il existe aussi amaya qui est pas trop moche niveau interface.
http://www.w3.org/Amaya/

Je ne sais pas s'il te conviendra, c'est juste pour info.

thierra
Desconectado/a
se unió: 02/19/2015

Merci,

Je vais tester

Thierry Vedel

3x4n (no verificado)
3x4n

thierra, le message "error while loading shared libraries: libmozjs.so" signifie que la librairie libmozjs est absente dans le système. Il suffit de l'installer. Par exemple cherche la dans les dépôts en utilisant la commande:

apt-cache search libmozjs

ou

apt-cache search mozjs

Sinon cherche sur le net en marquant libmozjs, j'ai trouvé un paquet dans Trisquel qui se nomme libmozjs-17.0-0.

Une fois trouvé tape juste: sudo apt-get install libmozjs-17.0-0 ou le nom que te renvoie la première commande.

thierra
Desconectado/a
se unió: 02/19/2015

Voici le résultat :

thierry@gpasdidee:~$ apt-cache search libmozjs
libgjs0d - Mozilla-based javascript bindings for the GNOME platform
libmozjs-24-0 - Spidermonkey JavaScript engine
libmozjs-24-bin - Spidermonkey JavaScript shell
libmozjs-24-bin-dbg - Spidermonkey JavaScript shell (debug symbols)
libmozjs-24-dev - Spidermonkey JavaScript library - development headers
libgjs0e - Liaisons javascript basées sur Mozilla pour la plate-forme GNOME
libmozjs-17.0-0 - moteur javascript Spidermonkey
libmozjs-17.0-0-dbg - Spidermonkey javascript engine (debug symbols)
libmozjs-17.0-bin - Spidermonkey javascript shell
libmozjs-17.0-bin-dbg - Spidermonkey javascript shell (debug symbols)
libmozjs-17.0-dev - Spidermonkey javascript library - development headers
libmozjs-24-0-dbg - Spidermonkey JavaScript engine (debug symbols)
libmozjs185-1.0 - moteur javascript Spidermonkey
libmozjs185-dev - Spidermonkey javascript library - development headers

J'ai bien le fichier libmozjs.so dans dossier Kompozer.

Une idée. Je n'ai peut être pas extrait au bon emplacement. Le dossier Kompozer est dans le dossier logiciels de mon home. Faut peut-être le mettre dans etc ou un autre.

Pour Amaya, installation sans pb. Sauf un bug, je pense, le programme se ferme si on fait défiler rapidement les fichiers quand on veut en ouvrir un. J'ai fini par comprendre et c'est OK.

Merci
Thierry

Magic Banana

I am a member!

Desconectado/a
se unió: 07/24/2010

Essaie d'installer depuis le gestionnaire de paquets (par exemple en passant par "Synaptic" dans les "Paramètres système") les dépendances indiquées sur http://packages.trisquel.info/toutatis/kompozer

x7
x7
Desconectado/a
se unió: 11/20/2015

Installez BlueGriffon, beaucoup mieux que Kompozer, il a HTML5 Elements
(video, etc.).

$ wget -q -O - http://archive.getdeb.net/getdeb-archive.key | sudo
apt-key add -

$ sudo sh -c 'echo "deb http://archive.getdeb.net/ubuntu trusty-getdeb
apps" >> /etc/apt/sources.list.d/getdeb.list'

$ sudo apt-get update

$ sudo apt-get install bluegriffon

Aussi vous avez Seamonkey, il a Composer (Kompozer reloaded).

$ echo -e "deb
http://downloads.sourceforge.net/project/ubuntuzilla/mozilla/apt all
main" | sudo tee -a /etc/apt/sources.list > /dev/null

$ sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com C1289A29

$ sudo apt-get update

$ sudo apt-get install seamonkey-mozilla-build

Substance2004
Desconectado/a
se unió: 11/05/2013

[Edit] ATTENTION !

BlueGriffon contient des licences non libre (Mozilla Public License Version 1.1)

thierra
Desconectado/a
se unió: 02/19/2015

Bonjour,

J'ai ajouté le dépôt : deb http://fr.archive.trisquel.info/trisquel toutatis main
J'ai rechargé.
J'ai trouvé les paquets kompozer et kompozer-data dans Synaptic.
J'ai installé.
Ca marche. C'est " Magic Banana "

J'ai installé BlueGriffon sous Windows car je travaille avec des Windoziens. Il faut acheter le module Editeur CSS !! D'autre part, je ne pense pas qu'il soit Libre. Je n'ai pas trouvé SeaMonkey dans les paquets donc je vais essayer tes manips.

Merci à tous.
Thierry

Magic Banana

I am a member!

Desconectado/a
se unió: 07/24/2010

Je pense que garder le dépôt d'une ancienne version de Trisquel doit être une recette à problème. Retire donc ce dépôt. Par exemple depuis "Logiciels & Mises à jour" dans les "Paramètres système". Les paquets que tu as installés depuis le dépôt supprimé resteront installés.

thierra
Desconectado/a
se unió: 02/19/2015

Bonjour Magic Banana,

Merci du conseil.

J'ai désactivé le dépôt Toutatis dans Synaptic. Un autre dépôt pose problème.
Voici le message :
W: Erreur de GPG : http://linux-libre.fsfla.org freesh InRelease : Les signatures suivantes ne sont pas valables : KEYEXPIRED 1445486430 KEYEXPIRED 1445486430 KEYEXPIRED 1445486430

Je le désactive aussi.

Librement
Thierry