System freezes while idle and screensaver is active

2 respuestas [Último envío]
amenex
Desconectado/a
se unió: 01/04/2015

The computer is a Lenovo/ThinkPad T420 with 3.7 GB of RAM, running Trisquel_9 installed in /dev/sda3.
The hard drive adds up to around 500 GB when viewed with GParted, but on the other hand, same GParted
reports that it (/dev/sda) has a capacity of 398 GB.

dmesg | more finds:
[ 0.032000] MDS CPU bug present and SMT on, data leak possible. See https://w
ww.kernel.org/doc/html/latest/admin-guide/hw-vuln/mds.html for more details.

In another place:
[ 0.041127] ACPI: EC: interrupt blocked
[ 0.041127] ACPI: \: Used as first EC
[ 0.041127] ACPI: \: GPE=0x11, EC_CMD/EC_SC=0x66, EC_DATA=0x62
[ 0.041127] ACPI: \: Used as boot ECDT EC to handle transactions
[ 0.048031] ACPI: [Firmware Bug]: BIOS _OSI(Linux) query ignored

I had to press & hold the power button to shut the system down, as it would not respond to keypresses:
[ 16.392354] systemd-journald[398]: File /var/log/journal/9f6f73482fe44c8daf31
eef4a1f1259a/system.journal corrupted or uncleanly shut down, renaming and replacing.

.bash_history has not recorded the final five scripts that were running; and the CPU fan was blowing
hot air when the system was shut down.

The five nmap scripts were mostly finished, just past 1/2 way through the last of the 5,000 CIDR/24
blocks. and 99 MB of PTR & IVp4 data saved to a USB-attached flash drive when the system froze, about
15 minutes before I turned it off.

My power management settings were _never_ hibernate, etc. during idle periods; and this computer was
still running one of those five scripts when I forced the shutdown with the CPU fully active.

I had installed xscreensaver software from the Trisquel repository four days ago with:
sudo apt-get install xscreensaver
My overworked memory suggests that another freeze like one occurred some time ago, before installation
of xscreensaver.

The rest of the fifth script and five more waiting in the wings will be run on a different T420
starting the morning of December 19th.

George Langford

Magic Banana

I am a member!

Desconectado/a
se unió: 07/24/2010

Is the problem reproducible not running your homemade scripts? They may have filled up the whole main memory, leading the kernel to kill some potentially essential service.

amenex
Desconectado/a
se unió: 01/04/2015

Running in another T420, with freshly installed Trisquel_9, the final three scripts are busy appending
to an output file of ~300 MB created by the first seven scripts. A previous group of three scripts ran
until the wee hours of the morning with the power management settings set to "never" hibernate, and
everything was stable at the start of the day today.

The System Monitor shows only ~120 MB of temporary file system usage; the main memory of 7.7 GB is at 25% usage.
The T420 whose Trisquel_9 froze has half as much RAM, so it would have been at ~50 % usage ...

Each script is looking up (with nmap) 256 addresses for each of five thousand CIDR/24 blocks, which encompass
all the Current Visitors' IPv4 addresses for a 35-month period (before my ISP initiated adobe's hostname-lookup
"feature.") so the data show what other hosts reside "next to" the actual visitor addresses in those address blocks.