Transmission won't connect to trackers in Trisquel 8

15 respuestas [Último envío]
strypey
Desconectado/a
se unió: 05/14/2015

I've been making a lot of use of BitTorrent since I moved to China, since a lot of streaming services either aren't available here, or their performance is poor on the weaker net connections we tend to use here. A couple of days ago Transmission stopped working. It won't seed finished torrents and stopped downloading a half-finished torrent. When I add new torrent, it won't even fetch metadata. I've tried both with and without the VPN connected, same result.

After a bit of web searching and poking around, I found two things that seem to be part of the problem. The torrents won't connect to trackers. Also, when I click 'test port' under the 'port for incoming connections', it says that the port is closed. AFAIK I haven't changed anything that would have closed any ports, other than downloading the usual system updates. My system is 100% up-to-date as of today.

Does anybody have any advice about how I can get Transmission working again?

chaosmonk

I am a member!

I am a translator!

Desconectado/a
se unió: 07/07/2017

> A couple of days ago Transmission stopped working. It won't seed
> finished torrents and stopped downloading a half-finished torrent.
> When I add new torrent, it won't even fetch metadata. I've tried both
> with and without the VPN connected, same result.

My torrents are still seeding in Transmission. Have you tried using
another BitTorrent client to verify that the problem is specific to
Transmisison?

strypey
Desconectado/a
se unió: 05/14/2015

FYI my wife is using Transmission on her MacBook and it's still working fine, on the same internet connection. I installed qBitTorrent on my T8 system. It has at least managed to download the metadata from the magnet link, but it's not downloading any of the actual files so far.

strypey
Desconectado/a
se unió: 05/14/2015

Update: qBitTorrent is now downloading files, on two separate torrents. So it does seem to be a problem specific with Transmission on Trisquel 8, not torrents on Trisquel 8 in general, nor Transmission in general (working fine on MacBook on the same net connection). I really like using Transmission and it would great to get it working again. Would it help to file a bug on the Trisquel bug tracker?

chaosmonk

I am a member!

I am a translator!

Desconectado/a
se unió: 07/07/2017

> Update: qBitTorrent is now downloading files, on two separate torrents. So
> it does seem to be a problem specific with Transmission on Trisquel 8, not
> torrents on Trisquel 8 in general, nor Transmission in general (working fine
> on MacBook on the same net connection).

Transmission is working fine for me on Trisquel 8, so there must be some
difference between our systems which accounts for the problem. Some
things to try off the top of my head.

$ sudo apt purge transmission && sudo apt install transmission

Boot into a live Trisquel 8 session, update/upgrade, and see if
Transmission works.

> I really like using Transmission
> and it would great to get it working again. Would it help to file a bug on
> the Trisquel bug tracker?

Probably not. Better to troubleshoot here where there's better
visibility and submit a bug report when we have more information.

strypey
Desconectado/a
se unió: 05/14/2015

> $ sudo apt purge transmission && sudo apt install transmission

Hmm, that seems to have worked. No idea why, but thanks for the tip. I would have tried that before posting here, but for some reason I thought Transmission was part of the default desktop package, and that if I tried to uninstall it, apt would want to uninstall all the default DE packages with it.

Thanks too to Mistah Darcy for the suggestion to try qBitTorrent. There are certainly some things I like about it, the UI makes more detailed information more easily available about what's happening with each torrent, tracker etc. But overall I like the Transmission UI better, it just feels better integrated with the Mate desktop. The only time it lets me down on that front is when it refuses, to snap to half the screen when dragged against one side, as other windows usually do.

chaosmonk

I am a member!

I am a translator!

Desconectado/a
se unió: 07/07/2017

> > $ sudo apt purge transmission && sudo apt install transmission
>
> Hmm, that seems to have worked. No idea why, but thanks for the tip. I
> would have tried that before posting here, but for some reason I thought
> Transmission was part of the default desktop package, and that if I tried
> to uninstall it, apt would want to uninstall all the default DE packages
> with it.

$ apt depends trisquel | grep transmission
Recommends: transmission-gtk

It looks like the trisquel metapackage recommends, rather than depends
on, transmission-gtk. "transmission" actually appears to be a
metapackage.

$ apt depends transmission
transmission
Depends: transmission-common (>= 2.84-3ubuntu3.1)
|Depends: transmission-gtk (>= 2.84-3ubuntu3.1)
|Depends: transmission-qt (>= 2.84-3ubuntu3.1)
Depends: transmission-cli (>= 2.84-3ubuntu3.1)

Recommended packages, unlike dependencies, can be removed without
removing the parent package. However, even if trisquel depended on
transmission, it would still be safe to remove:

If a metapackage A has dependencies B, C, and D, removing D does remove
A, but does not remove B or C. A doesn't actually do anything except
install its dependencies, so removing it is harmless, usually. An
exception is a situation like upgrading from Belenos to Flidas. If a
Belenos user has removed trisquel, then when upgrading the Flidas the
*new* dependencies of trisquel (like mate-desktop-environment) will not
be installed, resulting in a broken desktop.

Magic Banana

I am a member!

Desconectado/a
se unió: 07/24/2010

Great explanations. Nevertheless, I am unsure of your "exception", at the end of the post. Even with the "trisquel" metapackage removed, updating the distribution should not "result in a broken desktop", as far as I understand: the still-installed dependencies of the older "trisquel" metapackage should be updated (they can even have new dependencies), and so should packages installed on top of that. That should be fine. Simply, the user does not discover the new default applications that entered the new version of the distribution.

So, for the specific example you gave, the user of Belenos who removed the "trisquel" metapackage and updates to Flidas should still have a working GNOME Flashback (at least if I correctly remember what is Belenos's default desktop environment). That said, and as I wrote before, I am unsure: I have not tested that.

chaosmonk

I am a member!

I am a translator!

Desconectado/a
se unió: 07/07/2017

> So, for the specific example you gave, the user of
> Belenos who removed the "trisquel" metapackage and
> updates to Flidas should still have a working GNOME
> Flashback (at least if I correctly remember what is
> Belenos's default desktop environment). That said, and
> as I wrote before, I am unsure: I have not tested that.

Many forum users have reported logging into a broken system after
upgrading from Belenos to Flidas, and installing "trisquel" fixed the
issue. Here's one example,[1] and I recall there being several others.
I'm not sure why LightDM would choose to default to MATE or whether
GNOME Flashback was still intact.

[1] https://trisquel.info/en/forum/tirsquel-8-upgrade-disaster-windowing-broken-panels-broken-etc#comment-132921

CitoplasmaX
Desconectado/a
se unió: 11/24/2016

I confirm the problem.

MistahDarcy
Desconectado/a
se unió: 03/18/2016

Had the same thing happen to me. Port forwarding was still configured correctly in my router and everything. Not a single torrent would start or resume. Got tired of fiddling with it so I just switched to qBittorrent and it works fine.

Go Rin No Sho
Desconectado/a
se unió: 07/19/2019

i'll start testing torrent clients on Trisquel 8 somewhere next weekend and see how Transmission performs compared to Qbittorrent. On Debian 9.4 and Ubuntu 18.04 Qbittorrent is working excellent, whereas Transmission has had several issues, including the "suddenly not running" problem.
Clients i will be testing on Trisquel 8 are: Qbittorrent 4.*, Transmission, Deluge 1.3.*, uTorrent-linux server-alpha_3.3 and Aria2 (Aria2 in Nextcloud).

Screenshot attached shows Qbittorrent stats after 14 months of operation on Ubuntu :)

Will start posting test-results when available.

Regards, Lou aka GoRinNoSho

seeded 1.005 Petabyte.png
Libreshop
Desconectado/a
se unió: 10/27/2018

1.005 PiB upload
85.500 TiB download

dude, what are you sharing all that 14 months :P

MistahDarcy
Desconectado/a
se unió: 03/18/2016

Asking the real questions. I want to know as well!

I've been torrenting for years and am nowhere near those stats.

Go Rin No Sho
Desconectado/a
se unió: 07/19/2019

A bit off-topic, but questions should be answered :)

I mainly upload and seed a lot of "bootleg recordings", both on private and public sites; kindly note i do not touch any officially released, commercially available music, period. (better safe than sorry). See screenshot for an example of a bootleg recording related to JP Barlow (RIP);

I also seed quite a few linux iso's via Distrowatch :)
further seeding Defcon torrents https://media.defcon.org/DEF%20CON%20Torrents/
as well as some Wiki torrents like f.e. Finfisher https://wikileaks.org/spyfiles4/finfisher.torrent
Also seeding many documentaries on any subject you can think of, as i support mvgroup, which releases docu's produced with public funding, like f.e. BBC, PBS, CBC etc. mvgroup.org

I look forward to testing torrent clients on T8 & T9 :)

Best regards, Lou aka GoRinNoSho.

jpbarlow.png
Go Rin No Sho
Desconectado/a
se unió: 07/19/2019

Ever since reading the initial posts in this thread, something has been nagging my brain... "Could it be that Transmission suddenly has the same "bug" as i already noted months ago to be existing in uTorrent 3.* (Windows though!) and Bit Torrent 7.10.4???" This "bug" i noted on several private (bootleg) trackers as well with public trackers. Please allow me to elaborate: in such torrents, all torrent-clients except the 2 mentioned above perform as they should, i.e. downloading and uploading data, actively engaging in the swarm. The mentioned clients however, only connect to other peers, but do not exchange a single bit of data, they just stay at 0% progress. This happens to peers with these client from all over the globe and all of them use an ISP with a good connection / reputation. The common factor are these particular torrent-clients and them at 0% progress. However, after a while all these peers waiting at 0%, all of a sudden SIMULTANUOUSLY start downloading and sharing data until after a brief moment (upto 2 minutes) they SIMULTANUOUSLY pause again. Until, again after minutes, they suddenly act in unison with all other peers and finally perform as they should. Looking at this anomaluous behaviour, i have concluded that the pattern might be pointing towards the fact that either uTorrent 3.* and BitTorrent 7.10.4 are corrupt, or the OS used by them (Windows) is. Anyway, such simultanuous behaviour looks like the peers are controlled by a C & C center (command & control), which is often used by virii and worms. I made a few screencasts from such torrents, an example in my Nextcloud here: https://grns3.rocks/nextcloud/index.php/s/gRBHiYGQJAwY8KD (skip to halfway)

Although i did NOT note this fishy behaviour with Transmission clients back then, it might be that recent versions are now either corrupt or the peers experiencing a suddenly not running client are somehow infected.

As a Qbittorrent user i formerly left it for what it is and kinda ignored the not running issue, as the few times i posted in the threads belonging to those torrents, advising peers to downgrade to uTorrent 2.2.1, no-one replied. And hey, when a peer chooses to use that OS and that software, it's their problem, not mine. Please excuse me for not reporting at appropiate channels upto now.

I would appreciate if some peers here would look at the whole matter, as i am only a simple guy with very limited knowledge when it comes to looking at software (i haven't touched IDA in ages lol).

More screencasts from various trackers are available, i will share them upon request. Please guide me to the appropiate thread if needed, i feel like i might be a bit off-topic.

Thanks and kind regards, Lou aka GoRinNoSho.