X60 Libreboot Trisquel 7 Overheating

26 respuestas [Último envío]
404
404
Desconectado/a
se unió: 04/09/2015

Hi
That's my first post,i wanna thank you all guy for the info that i'm finding on this forum.

I've just Libreboot my Lenovo X60 and i'm currently writing from it on Trisquel 6.0.1.

Initially i've tried to install Trisquel 7 but i've never been able to finish the installation because the fan was increasing the speed and the CPU was in a overheat state causing a shutdown.

I've been able only to run Trisquel 7 in "Live" mode and i've realized that both cores were at 100% usage (without doing any tasks) and the laptop was getting really hot and shutdown after few minutes.

On Trisquel 6.0.1 everything runs fine (CPU around 4% with few open tabs on Abrowser).The fan seems to be a bit noisy than when it was running windows but maybe i might be wrong(or paranoid)

Additional infos:
The X60 had a BOE-Hydis HT121X01-101 Display that was replaced with a Samsung LTN121XJ-L07 that took it from a X60s.

Libreboot version:20150208

I flashed the Libreboot by software

Anyone has encountered this kind of issue?
Any tips?

Thanks in advance!

tomlukeywood
Desconectado/a
se unió: 12/05/2014

i once tried to run trisquel 7 from the live usb on a thinkpad and it was high cpu usage(99% - 100%) and it was very slow:
https://trisquel.info/en/forum/libreboot-x60-always-100-cpu-usage

but as soon as i installed it onto a harddrive all was fine

so if your having problems installing trisquel 7 try using the text installer

or the the netinstall(which runs in text mode)

as this will require much less work for your cpu

marioxcc
Desconectado/a
se unió: 08/13/2014

If I recall correctly, the text installer in the live CD/DVD image is the same as the stand alone net installer; ideally it would use the packages included in the disk, but it seems like it doesn't.

Magic Banana

I am a member!

Desconectado/a
se unió: 07/24/2010

I've been able only to run Trisquel 7 in "Live" mode and i've realized that both cores were at 100% usage (without doing any tasks) and the laptop was getting really hot and shutdown after few minutes.

Some process necessarily occupies the CPU. If you do not see it from the first tab of the "System monitor" (in the "System settings"), it must be because only *your* processes are displayed. You can see "All processes" by clicking in the related entry in the "Display" menu.

404
404
Desconectado/a
se unió: 04/09/2015

I've tried to install Trisquel 7 in text mode without notice any overheating so it looks like the issue happens only in graphical mode.
Anyway i've got an error installing GRUB(because of libreboot i guess)and i've skipped his installation and when i restart no OS was found.
The installation process was more than 1 hour anyway,is really wierd because reinstalling Trisquel 6 it took me only 15 minutes.
Thank you for your answers anyway.

404
404
Desconectado/a
se unió: 04/09/2015

Anyway seems that i have a problem even on the Trisquel 6.
The CPU fan is quite noisy(3658 rpm)and never slow down.
Temperatures(checked with xsendors) are 79^C and 53^C.
Sometimes i even notice some latency scrolling on the browser or closing some tabs.
Did i messed up something flashing Libreboot?

tomlukeywood
Desconectado/a
se unió: 12/05/2014

"Did i messed up something flashing Libreboot?"
as you can boot i think not

what error did grub give you when you tried to boot to trisquel 7 and failed?

404
404
Desconectado/a
se unió: 04/09/2015

Grub didn't find the os,i don't remember correcly but is kind of:
./vmlinuz...
no os found

tomlukeywood
Desconectado/a
se unió: 12/05/2014

this has happened to me before
are you using lvm partitioning? as
this seemed to be the problem for me

404
404
Desconectado/a
se unió: 04/09/2015

tomlukeywood you're right,it was because of lvm partitioning.I've installed Trisquel 7 in text mode successfully.

Now i have another issue:
The X60 is costantly beeping but at lower volume than the louder beep of a bios error code.

I'm almost sure that is not a:
Ram issue(because i've tried few sodimms)
Hard Disk (because i've run a live system with a physically removed drive)
Os (i've tried Trisquel 6 and Trisquel 7 noticing the same beepy noise)

If i scroll the page on the browser the noise get triggered and then continues to beep.
If i open quickly lots of tabs on the browser the noise disappear until i stop to click constantly.

Somethingwrong with the motherboard?

Might be the fan not working properly?

Is there something that i can check or try to set on the Libreboot BIOS?

404
404
Desconectado/a
se unió: 04/09/2015

No hums,buzz noises with a fresh install of Trisquel 6.
I'm gonna try to install Trisquel 7 and try to fix it following this:
http://www.libreboot.org/docs/misc/index.html#trisquel7_powertop

mortenlarsen
Desconectado/a
se unió: 04/11/2015

I had a similar problem, it was caused by the wifi driver attempting to load firmware in an infinite loop.

404
404
Desconectado/a
se unió: 04/09/2015

what about if i phisically remove the wifi card?
i'm currently running a ethernet cable so i don't need wifi until i buy an Atheros card.

404
404
Desconectado/a
se unió: 04/09/2015

I've removed the mini PCI WiFi card and the temperatures went down to 66 and 41^C
and the fan speed to 2800 rpm.
Thank you very much for your help morenlarsen.

tomlukeywood
Desconectado/a
se unió: 12/05/2014

btw i also had this problem and its not a infinite loop you just have to wait like 4 minits for it to start up

miguelbejarano
Desconectado/a
se unió: 01/15/2015

Hey thank you very much, i was having the same overheating issue with my x60/Trisquel7 and after searching for a solution in a while i did not find one until i stumble with this post and saw your feedback,take out the wifi card not compatible with software libre and that's it!, now i have my system running smoothly, really appreciate your help.

sebelius
Desconectado/a
se unió: 08/22/2013

Hey, I had the same problem. Here's how I solved it.

First, the annoying high pithced sound emitting from the motherboard?

https://github.com/fenrus75/powertop

Download and Compile it, only if apt-get's version ain't got the '--auto-tune' option.

First issue,
$ powertop --calibrate #and wait until it finishes

Then issue,
$ powertop --auto-tune #wait...

##if the sound still persists, just repeat the two commands,
##i remember, the sound still persisted after my first time.
##also issuing 'powertop --auto-tune' before plugging in my
##external sound card, then plugging it in, the noise will come
##back into effect. I have not tried to issue the command
##after plugging in my external sound card.
##ALSO, leaving my USB wireless card plugged in WHILE
##having my ath9k modules loaded removes the high pitched
##noise. As well as, writing to files, temporarily removes the
##noise. I've not tested doing things in RAM.
##I don't know, is that a stupid question?

The noise will be significantly decreased, however on my x60, it still is to some degree, but not at the point of annoyance.
Actually, the high pitched sound is gone, replaced by a more low pitch, almost harddrive working sound.

sources: coreboot.org #can't remember the exact url this solution was at.

As to the temperature problem, I've managed to get my x60 at an usual 40-50 degrees (before at 90-100) (celsius) (without any external tools except a few kernel modules).
I suspect that this solution works for any computer running Linux as its kernel (with these modules). It also works without coreboot, so it's a solution regardless, though I noticed the temperatures did increase after i installed libreboot, so i did never care until now to find a solution.

modules you'll need:
acpi_cpufreq
cpufreq_powersave
cpufreq_stats

look, i don't know the details and the dependencies these modules have got, but i think they're found in many (gnu/busybox/*)linux distributions by default.

I've seen them in, debian and Tiny Core. I suspect they're also in Trisquel.

Issue,
$ lsmod | grep cpu

If you see them there, then that's cool, otherwise i guess you'll have to find a way to install them.

You could try loading them,
$ modprobe acpi_cpufreq
$ modprobe cpufreq_stats
$ modprobe cpufreq_powersave

So, i wrote these two sh scripts that i call on startup to handle the temperature and high pitched noise problem automatically.
I leave them here as attachments, they're public domain, so you may use them however you like.

First, i call,
$ ./lowlevel.sh #as root
$ ./dectemp.sh #

Also, you might want to disable cpufreqd,
$ service cpufreqd stop
or, something like that, i'm not sure. it might intervene
or something.

Also, these scripts are entirely informal, not professional, and maybe not 100% correct. They work for me, and maybe they're a little bit unorganized / messy.

sources: a little bit of everywhere, and https://ixquick.com/ with keywords such as: cpufreq, acpi, linux, overheat, coreboot, temperature, etc

AdjuntoTamaño
dectemp.sh 918 bytes
lowlevel.sh 1.27 KB
sebelius
Desconectado/a
se unió: 08/22/2013

I forgot to mention,

look in /sys/devices/system/cpu/cpu*/cpufreq/

interesting files are,
scaling_governor
#do $ cat scaling_available_governors
#to figure out which governors you can use
#you must also load the equivalent kernel module
#ie, cpufreq_(powersave|performance|conservative|ondemand|userspace)
#and during $ lsmod | grep cpufreq
#the governor you have chosen must have a number
#greater than 0 after it (this means that it is actually
#being used)
what the fuck is a governor anyway?
it's a CPU policy that the cpufreq module uses to control the frequency of the cpu(s).
for instance, the 'performance' governor will always use full frequency on the cpu(s), while 'powersave' will always use the lowest.
you can do an internet search for these governors and modules to get details about them.

scaling_min_freq and scaling_max_freq
#for certain governors, these files controls
#minimum and maximum frequency the CPU should
#(try) to be at

you can also find minor explanations for these governors, in
the cpufreq man page.

what i'm doing, is basically writing directly to these files instead
of using the cpufreq-* front ends, as i found that cpufreq-* did not have any effect. I also found that when using cpufreq,
then the cpufreq_performance module would get
automatically loaded after X time.

also, look in /sys/devices/virtual/thermal

experiment here, that's what i did (i found them just lurking in /sys).
I found that cooling_device*/cur_state has significant effect on temperature.

writing to these files is just a matter of,
$ echo XXX > file

say to change cooling_device0/cur_state to 5, then,
$ echo 5 > /sys/devices/virtual/thermal/cooling_device0/cur_state

to change governor to powersave, then,
$ echo powersave > /sys/devices/system/cpu/cpu1/cpufreq/scaling_governor

you might not have two CPU's/CORES, so i guess replace cpu1 with cpu0?

northernarcher
Desconectado/a
se unió: 12/24/2014

This is a problem with my X60 too. I repasted the heatsink and all I use it for is text based things and music. I should not get as hot as it does. It burns my hand to type and I have to carry around an external keyboard and mouse with my laptop because it's too hot too touch.

tomlukeywood
Desconectado/a
se unió: 12/05/2014

this rely should not happen

have you removed the intel wifi card?
also when did the machine start doing this?
as i could just be a hardware problem

sebelius
Desconectado/a
se unió: 08/22/2013

hey, i've been continously searching for a solution to the heat problem.
it seems that playing music, watching videos, visiting websites that uses alot javascript, makes the
temperature of 1 CPU core to rise dramatically, while the other core remain ~constant in temperature.
i've always had a temperature issue with my thinkpad x60 on Linux, though on Windows i installed a
software from lenovo that fixed everything, so i am certain it is possible to fix this heat issue on Linux too.
currently i've managed to decrease the temperature maybe 10-15 degrees celsius, but it still rises to 70~90
during said activities. i've scoured the net for settings that got the potential to decrease temperature.
success? not really very much. i've come to a final resort, which is to look at the appropriate kernel modules's
source code for documentation about how they work and their different power saving settings. i might do this
when i have time. i would hope though that someone would already have a plain text file documenting these
settings, hopefully and most likely can they all be interfaced by /sys/ and/or /proc/ or as arguments to the
modules.
away from that, my previous 'scouring' have had some effect. namely i randomly managed to disable the
high pitched noise during an attempt to decrease temperature by interfacing /sys/ and /proc/.
i was surprised because before i used powertop --auto-tune to disable the noise, and that rendered
the noise into effect again when plugging in certain (not wifi nor external hard drive, but soundcard and audio
player) usb devices (powertop also disabled power supply to them, when i called powertop --auto-tune after
plugging them in). i've not tested which line(s) in that script that had this effect, when i get time i might.
it would maybe be useful to know for the coreboot developers. i have assembled this script from various sources,
but i cannot remember them all. i wish there were a complete reference and explanation of the /sys/ and /proc/
interfaces, but i am sure the needed information can be obtained by reading the kernel/module sources (if not,
then who has the knowledge? is it forgotten?). my experience with power management on Linux, is that it sucks,
with or without coreboot. that is, atleast out of the box. i'm just thinking some configuration must be done.
one useful thing regarding decrease of temperature that i've come across is fan control. on my debian os it was
not enabled by default. i had to pass fan_control=1 to the thinkpad_acpi module,
# modprobe thinkpad_acpi fan_control=1
then it would be possible to interface /proc/acpi/ibm/fan,
# echo level full-speed > /proc/acpi/ibm/fan #set fan speed to maximum
# echo level auto > /proc/acpi/ibm/fan #automatically controlled
# cat /proc/acpi/ibm/fan #you will see a numberical value, 0-X
# echo level X > /proc/acpi/ibm/fan #X is the numerical value

with the settings in this file and fan speed at maximum, running,
$ nice -n 19 mplayer video.mp4
the *one* core temperature starts out at ~45, gradually very slowly but surely reaches up to ~90 celsius after
a while. note that the other core will stay at a nearly constant ~45 celsius.
then when the process, mplayer, exits, then the temperature will almost rapibly decrease. in a few
minutes, the core temperature will be back at ~45 celsius. i think this is weird, just seems like it has
to do with how Linux handles the cpu frequency, not some inherent hardware issue nor a lack of capability to
prevent it. i will maybe try out different cpufreq drivers and recompile my kernel in detail, then i will
report back results. if that won't work then my only solution is to delve into the kernel/module sources...
and i'm just a darn amateur who is clueless.

ASLO: trisquel.info does not work well with webkit (it does not render well at all, everything is line wrapped at like 300 pixels and you cannot see complete posts, words are invisible!) in neither uzbl, luakit, vimb, etc. I would appreciate if you disabled this fancy page style, whatever it is that is causing it.

AdjuntoTamaño
supscrpt.sh 1.93 KB
lembas
Desconectado/a
se unió: 05/13/2010

Here's some random thoughts on overheating.

One bandaid might be the cpufreqd package. It allows you to monkey with cpu freq depending on circumstances like temperature, cpu usage and running programs. The manual page for cpufreqd.conf will get you started.

Physically removing dust helps but opening laptops is a b*tch and probably that's by design... If you use a vacuum cleaner, be careful not to allow the fans to spin (too fast), it might damage their bearings.

In a similar Captain Obvious vein removing unused hardware, kernel modules and programs helps.

I guess a custom kernel might help at least a little bit even just by setting your CPU type instead of generic. Probably a kernel whiz could do wonders.

It also might be possible to underclock/volt your CPU (in the BIOS) and GPU (for AMD cards, see package rovclock).

I suggest NoScript for primarily freedom and security issues but it also helps here.

sebelius
Desconectado/a
se unió: 08/22/2013

My script basically does what cpufreqd would do for me,
manually writing to /sys/devices/system/cpu*/cpufreq/.
In vimb i use,
:set scripts=off
which works also to disable javascript, but it's not selective.

SuperTramp83

I am a translator!

Desconectado/a
se unió: 10/31/2014

Is the package "cpufrequtils" installed by default on Trisquel 7?

Magic Banana

I am a member!

Desconectado/a
se unió: 07/24/2010

Searching http://cdimage.trisquel.info/trisquel-images/trisquel_7.0_amd64.iso.manifest gives the answer: no (at least for version 7 on 64-bit architectures).

sebelius
Desconectado/a
se unió: 08/22/2013

I've isolated which line of my script that removes the high pitched noise.
The line,
# rmmod uhci_hcd #disable module uhci_hcd
which is the kernel module for USB 1.1 support, right?
That line disables the module and with it the noise. However, USB 1.1 devices won't work without it.
I've tested with my NokiaN95 (which've got a mini/micro usb 1.1 port to transfer files). The kernel did not
recognize it after i disabled the module (while indeed got recognized when uhci_hcd was enabled),
# dmesg
produced no additional output when uhci_hcd was disabled by mentioned command.
Well, that did it for me (and i never use 1.1usb devices, except my NokiaN95 when transfering files).
Am currently recompiling the kernel with as many thinkpadx60/intel specifics as
possible, hopefully to solve the heat issue. If it does, then i will report back here such that it may be useful
to others as well.
by the way, is it really safe to apply the suction of a vaacum cleaner on tiny electronics?
i've read that a can of compressed air is the safer option.
I've not yet removed the intel wireless card nor the fingerprint reader due to the screws being too small
for my current screwdriver. The wireless card is generating alot of heat, yes, but the CPU is the thing
that makes my system unbearably hot, as when it's on idle, then the temperatures are acceptable.
So i can get away with text editing, internet browsing (usually), but long copies and any long-lasting operation
makes the CPU too hot. So compiling, say, the kernel... my system will probably burn up :D
my former post, i forgot to include some sources, so here they are:
http://www.thinkwiki.org/wiki/How_to_redu
ce_power_consumption

https://wiki.gentoo.org/wiki/Power_management/Guide

https://www.kernel.org/doc/Documentatio
n/cpu-freq/governors.txt

of course, there are others, but i did not note them down.

lembas
Desconectado/a
se unió: 05/13/2010

Canned air is probably fine as long as you make sure it's dry. You should consider doing the build on another machine. (I don't know how.)