Problem with the output to the external Monitor

Categoría:informe de fallo
Asignado:No asignado
Estado:needs more info

I am facing an "issue" after upgrade from toutatis to belenos (the upgrade went smoothly, thanks quidam for making smooth transition !), which results in my external Samsung VGA LCD monitor not getting any output from my laptop's VGA port. Previously I had a virtual dual-screen setup, which worked, and the external monitor got the picture, when I started X/gdm (not before) but now the command "xrandr" which is supposed to list the outgoing outputs gives an error:

root@trisquel# xrandr
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 1366 x 768, current 1366 x 768, maximum 1368 x 768
default connected primary 1366x768+0+0 0mm x 0mm
1366x768 0.0*
1368x768 0.0

Previously it listed "VGA-0" as secondary output which went to my external monitor, so I was able to use the virtual screen solution there. I should add that the /etc/X11/xorg.conf file hasn't changed during the upgrade and remained the same as being used in toutatis.

root@trisquel# lspci -v |grep VGA
00:01.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Wrestler [Radeon HD 7340] (prog-if 00 [VGA controller])

Current kernel whicch I use is 3.18.5-gnu #1 SMP Fri Jan 30 19:28:39 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

I already googled up the "xrandr" error, but couldn't find anything related that would fix my issue, I assume that it could be maybe a (proprietary) driver related issue ?

Any hints are appreciated, I can paste more commands if needed to investigate the error ...

Thank you !

Mié, 03/04/2015 - 18:42

Hi !

This is the solution for a wider virtual screen, but it doesn't enable the output through the VGA-OUT port.


Sáb, 04/11/2015 - 00:21
Estado:active» needs more info

According to the Ubuntu page on the driver an xorg.conf is no longer needed. So...

Try booting a Trisquel Live CD / USB stick. If that works (play with any laptop screen switching keys), your first move should be to *move* your xorg.conf in the installed system somewhere else and reboot.

Then if it doesn't work, still move the xorg.conf and reboot but then add the output of dmesg and the contents of /var/log/Xorg.0.log to this issue.

Vie, 01/15/2016 - 12:19

Case solved.

This is just a reference for myself to check on it later.
Solution was to comment #blacklist radeon in /etc/modprobe.d/disable-radeon.conf