Wireless drop out

Categoría:petición de ayuda técnica
Asignado:No asignado

I'm not a programmer. I'm trying to load up Trisquel on to two computers - a Lenovo x61s and an HP 6460b. Upon use of an inspected USB Trisquel installation disc I run into the same problem on both computers -- the wireless has dropped out. These computers don't recognize that there are any wireless networks. I've erased my entire discs - forget about parallel running with Windows. [I'll still be hauling two laptops to accommodate my alternative-to- googlemaps map/atlas software.] I've down loaded drivers and .exe files that always proclaim their errors of one sort or another. I've done online searches. Looked on help. Searched the forum. I can't seem to get the information I need.

I've been with Linux through Ubuntu and Trisquel for about ten years this issue with wireless drop out is the most frequent, virually routine, problem I run into. Ubuntu used to have an "Additional Drivers" setting that (I think) worked. Until now, several re-installations was sometimes the answer.

At the risk of being flippant, a disclaimer at the very start of installation might be "your wireless is likely to drop out, here's what needs to be done . . .".

I don't get it. I've spent my free time for days trying to figure this out.


Mar, 02/19/2019 - 04:48

> a Lenovo x61s and an HP 6460b

The X61s comes with a WiFi card for which no free firmware exists, and the BIOS will prevent you from installing a different WiFi card. Your best bet with this computer is to use a wireless adapter.[1]

I don't know what WiFi card the HP 6460b comes with. Try opening a terminal with Ctrl+Alt+T, typing "lspci | grep Network" and pressing enter. Then create a forum post (people don't check the issue tracker as regularly, and this is not yet a confirmed bug) saying something along the lines of

"Is there free firmware for my WiFi card? The lspci output is" [and then copy/paste the output of the command you ran above]

One of these possibilities is probably the case:
- there is free firmware for your WiFi card, but you need to upgrade to a newer kernel
- there is no free firmware, but you can install a new WiFi card
- there is no free firmware, and the BIOS won't allow you to install a new one (like with your X61s)

[1] https://www.thinkpenguin.com/gnu-linux/penguin-wireless-n-usb-adapter-gnu-linux-tpe-n150usb

Mar, 02/19/2019 - 05:16

thanks. I let you know my results tmw or later.

Mar, 02/19/2019 - 16:47

Thanks for your help. The whole landscape of problem origins - hardware, software, internet provider - lay before me.

Unexpected divergence: I ordered a free dongle for the x61s (found in a dumpster needing a screen replacement). But the HP 6460b has gone to grub rescue. O.k. I have the path: (hd0,1)/../boot/grub/ but I don't know what to do with it. I hope this grub rescue is temporary and doesn't mean I've done some irreversible damage.

Mar, 02/19/2019 - 18:13

I suggest making a forum post about the grub rescue. There are people who can help you better than I can with that, who probably aren't checking the issue tracker regularly. When you have problems in general, start with the forum to see if the community can help you through them, and then go to the issue tracker if/when we conclude that the issues are due to a bug.

Jue, 02/21/2019 - 01:42

Sorry. Not lingo savvy. Forum? Issues? . . . fill in the boxes. I was looking for a horse and I guess I got the farm's tractor. Thanks again.

Jue, 02/21/2019 - 18:23

You are using the issue tracker. You presumably got here by clicking "Issues" on this website's sidebar. This is for reporting and keeping track of bugs, or things that need to be fixed in Trisquel's code.

If you instead click "Forum" at the top of the page, you will see that there are several forums, including the "Trisquel Users" forum. This is for troubleshooting and guidance toward fixing things on your own computer.

The grub rescue is probably a problem with your system, not Trisquel's code. The WiFi issues is probably a problem with your hardware, not Trisquel's code. Therefore, you should ask about these issues on the Forum instead of here.

Since you have two problems, you should make two forum posts:

(1) Make a post with a title like "grub rescue" and ask for help fixing your system on the HP.

(2) Once your HP is up and running, create a new post about your HP's WiFi card. Include the output of the "lspci | grep Network" command and ask if there is free firmware for your WiFi card.