Icedove Segfaults in Trisquel 9 Etiona

Proyecto:Trisquel
Versión:8.0
Componente:Programs
Categoría:informe de fallo
Prioridad:normal
Asignado:No asignado
Estado:active
Descripción

I tried starting with the -safe-mode and -P flags, with an empty ~/.icedove directory, but it continues to segfault. Thunderbird from Ubuntu Bionic also crashes, but in a different way.

I also had to add ');' to /usr/lib/icedove/defaults/pref/vendor.js. I tried booting after commenting out all of the lines containing the word "trisquel", as well as removing all lines, but that did not solve the issue.

Mié, 01/01/2020 - 20:24

According to strace, icedove was failing to create a file in /dev/shm, due to a permissions error. Stopping apparmor wasn't enough to get it to work, but uninstalling apparmor and then rebooting resolved this issue for me.

I also previously removed / downgraded packages that were stuck in versions from Flidas / Xenial, and switched from the default kernel from the Freesh one.

Now I have to figure out why Icedove seems to not detect my previous profile.

Mié, 01/01/2020 - 20:31

I got my icedove profile to work. My .icedove directory was in the wrong location.

The issue with apparmor still stands.