Latvian e-ID unmet dependencies - broken packages? (eParaksts.lv browser extension for Firefox)

Proyecto:Trisquel
Versión:8.0
Componente:Packages
Categoría:informe de fallo
Prioridad:normal
Asignado:No asignado
Estado:active
Descripción

The following packages have unmet dependencies:
eparaksts-token-signing : Depends: libqt5core5a (>= 5.9.0~beta) but 5.5.1+dfsg-16ubuntu7.7 is to be installed
Depends: libstdc++6 (>= 7) but 5.4.0-6ubuntu1~16.04.12 is to be installed
E: Unable to correct problems, you have held broken packages.

Footnote: Probably works with Ubuntu. I am unable to authenticate in a Latvian customs and excise (EMDAS) declaration page as a result of discontinued in-person services due to US sanctions. My only alternative is to use a browser extension. The attachment of this issue was also sent to customer support at the Latvian state radio and television center. They have since asked me to report how things turn out.

AdjuntoTamaño
bash_listing_eid_install_1_(utf-16).TXT15.99 KB
Mié, 05/06/2020 - 07:00

Looking at your attachment, I see that you are using Trisquel 8, based on Ubuntu 16.04, but that the repository you have added, is for Ubuntu 18.04 (bionic).

> deb https://www.eparaksts.lv/files/ep3updates/debian bionic eparaksts

Try removing this repository, and re-adding it replacing "bionic" with "xenial". If that still does not work, make a forum post about this, because you'll get more help in the forum and this is not a bug in Trisquel.

Jue, 05/07/2020 - 08:39

Thank-you for the prompt reply. I'll check back once having tried this out. I did purposely follow documentation meant for a 16.04 setup. :-)