Is there a reason why bundled apps are so out of date?

Proyecto:Trisquel
Versión:9.0
Componente:Packages
Categoría:petición de ayuda técnica
Prioridad:normal
Asignado:No asignado
Estado:active
Descripción

the version of Jami included with 9.0 is nearly a year out of date and quite a few updates have been released since the bundled version.

Sáb, 02/27/2021 - 08:47

Trisquel 9 is based on Ubuntu 18.04, which was released in 2018.

So yeah several packages are a bit old, Jami got special treatment since it was installed with the latest version possible to upgrade for Etiona.

Jami development is done on bleeding edge qt libraries, that is a bit troublesome when our distro is based on Long Term Support (LTS) releases, also since Trisquel policy is to distribute software that can be build there might be some restrictions on the latest packages.

There is a big intention to get Jami on the latest version possible for trisquel, I guess that newer versions will come for Nabia (trisquel 10) which is already on development.