Ubiquity waits infinitely for repo servers when testing connections

Categoría:informe de fallo
Asignado:No asignado

This is what i got during installation of 5.5:
Check the screenshots. It stop there and nothing happen next...

I got a Core 2 Duo Intel with Intel motherboard G31. Got 2Go of RAM 667MHZ.


Vie, 04/20/2012 - 01:54
Estado:active» needs more info

Sorry I think you forgot to either link or attach the picture. Some people said there was a hangup on the "please wait" part of the installer but if they waited (~30 minutes) it eventually worked. I am not saying waiting 30 minutes is not a bug but if this is the case you may want to wait a while and see if it is truly frozen. Let us know.

sirgazil (no verificado):
Sáb, 04/21/2012 - 14:42

I've got the same issue.

The installer seems to be frozen for some minutes (5 minutes in my case). And yes, it does continue after that, but I got some error and warning messages.

I couldn't copy/paste the details of the installation process because the installer doesn't allow that, but I attached the screenshots.

Notice that even when the installation continued, the messages shown in the screenshots didn't change (and the embedded terminal should display whatever is running in the background, right?).


  • RAM: 1 GiB
  • Processor: Intel Pentium Dual CPU E2180 @ 2.00GHz
sirgazil (no verificado):
Sáb, 04/21/2012 - 14:53

It seems the issues system didn't attach my screenshots. Read them in this order to understand the whole message: Screenshot 1, Screenshot 2, Screenshot 3

Jue, 01/17/2013 - 11:10

I also hit this "Please wait" bug. I waited for 1 hour and then despaired and restarted. And my system was messed and wouldn't boot anymore.

Sáb, 04/21/2012 - 20:24
Estado:needs more info» active

Thanks for the info guys.

Dom, 04/22/2012 - 09:24

I remade the liveusb and tried the installer again. This time it worked. I did run the integrity test the first time and it said all ok though, so I don't know whether remaking the liveusb had anything to do with it or just trying again.

This time around the please wait thing was there for like 1 minute only or so and then proceeded to download packages. This made me think that perhaps the bug could be related to some networking woes?

Dom, 04/29/2012 - 23:04

Installing trisquel 5.5 using a USB drive the installation seemed to freeze after some time. In the gui there was the "Please wait" with the cursor spinning.

It appears there is a malformed command somewhere in the installation script. Using "top" I noticed a line similar to the following:

"sudo wget -o /dev/null -O /dev/null ftp://in.archive.trisquel.info/trisquel//speedtest"

I believe the line is incorrectly formed as a server at in.archive.trisquel.info does not exist but archive.trisquel.info does. In addition I'm not sure the double "//" is correct. Using "sudo top" to identify and kill this offending command, the installation seemed to move ahead and complete.

Hope this helps work around and perhaps fix the bug.

Mar, 05/01/2012 - 01:55

Mine stops at "trisquel ubiquity[4376]: log-output -t ubiquity laptop-detect" problem is, I'm using a desktop.

Mar, 05/01/2012 - 13:04

Try it without a network connection.

Jue, 05/10/2012 - 08:55

Wow! It worked!

Dom, 10/14/2012 - 19:03

Same bug. Installer hangs on "Please wait" with the progress bar somewhere around 5-10%. This happened on 3 consecutive install attempts.

Luckily I found this thread https://trisquel.info/en/forum/trisquel-installer-55 and re-attempted the install without a network connection. This time it worked.

Lun, 10/22/2012 - 12:59

Every time that happens to me, I just fire "sudo killall wget" to kill that "sudo wget -o /dev/null -O /dev/null ftp://in.archive.trisquel.info/trisquel//speedtest" process and everything ahead goes fine. Also, that's always in.archive.trisquel.info...

Happened with 20121021 6.0 beta image ( http://devel.trisquel.info/makeiso/iso ). I didn't find a "6.0" option in "Version", though.

Lun, 10/22/2012 - 21:24

i also just got the exact same bug from the trisquel-mini 6.0 alpha installer

Mar, 10/23/2012 - 01:13
Estado:active» patch (needs review)

I too have had this bug both on the 5,5 and the 6.0 beta installer. Ubiquity is in the process of using wget to estimate server delay so it can select a repos for the user. The wget should be invoked with a -T aka --timeout= option and the --tries=1 aka -t 1 option or it will keep retrying forever that is how it is designed.

In the Ubiquity source package for 5.5 the broken wget call is on line 13 of


which should read something like

wget -T 60 -t 1 -o /dev/null -O /dev/null $i/speedtest || continue

Mar, 10/23/2012 - 18:31

I forgot to mention that if you're installing from a USB stick you can apply the change (adding -T 60 -t 1 to the wget command) by editing the line number 13 in file


This was how I tested the patch using Trisquel Mini 6.0 beta where the bug fix is exactly the same.

Attaching an actual patch file.

Mar, 10/23/2012 - 18:36

The patch was uploaded, but not attched to my post. Here is a link to it


Mar, 10/23/2012 - 18:39

Anyone know if there is an upstream Ubuntu bug that we can link to?

Mar, 10/23/2012 - 21:28

From what I can tell the bug is in Trisquel only code. One of our patches, I was unsurprised not to find any upstream bug.

Jue, 12/13/2012 - 18:25

I generated a file to patch the helper with this fix and posted it to trisquel-devel here


Jue, 12/13/2012 - 18:56
Versión:» 6.0

Bug still exists in 6.0

sirgazil (no verificado):
Sáb, 03/02/2013 - 18:29

I just installed "trisquel_6.0_i686.iso 02-Mar-2013 07:08 696M" and can't experience this bug anymore.

Sáb, 03/23/2013 - 19:23
Título:Installer bug» Ubiquity waits infinitely for repo servers when testing connections
Prioridad:normal» critical

Marking as "critical" since it can stop the show for non-technical users.

Mar, 04/16/2013 - 01:14

I've put a git format patch for the helper against Toutatis on Triquel-devel here:


@sirgazil - The bug is intermittent, it only happens when one of the servers is down. That's why you can't recreate it.

Lun, 08/26/2013 - 03:32
Estado:patch (needs review)» patch (ready)

The code is fixed in Trisquel 6.0.1 beta

@sirgrant please close

Lun, 08/26/2013 - 14:42
Estado:patch (ready)» closed