Fixed NTFS volume corruption using ntfs-3g

Pas de réponses
Hors ligne
A rejoint: 05/01/2018

I wanted to install a larger HDD to my desktop, but I first needed to free at least one 3.5-inch drive bay, so I chose to copy all contents on my old 3.5-inch 2-TB HDD to a 2.5-inch one and replace it with the latter. (I had a 2.5-inch SSD in that desktop, too, but two 2.5-inch drives can fit into single 3.5-inch bay. In this way one 3.5-inch bay was freed.)

After copying everything, I unmounted the new disk and installed it to the desktop. Yet the operating system halted while the HDD indicator was constantly on. I initially tried to disconnect the new disk to log on the system and then re-connect it when the system started, however I still couldn't mount the file system. I also tried certain commonly-used disk utilities under Losedows PE, but they reported that the file system was corrupt and couldn't be repaired.

I then returned to GNU/Linux, and launched Gparted anyway. It stuck for a while when detecting partitions on the new disk. But finally I could see the NTFS volume on the new disk, but the used capacity was unknown, and the file system still couldn't be mounted. In the context menu of Gparted, I found an option to try to fix any possible problem with it. I selected the option and Gparted took several minutes to detect the problems. At last, Gparted reported that the file system wasn't successfully repaired, and the log file recorded a long list of error messages.

I exited Gparted and re-launched it. It still complained something was wrong with the NTFS volume on my new disk. But this time I could see the used capacity, and in other words, the file system was mountable at this point.

I re-opened the log file from the previous repairing attempt. At the end of the log file, it was suggested that I should run "chkdsk /f" on Losedows and then reboot twice. Then I started a trial copy of Losedows, opened a cmd window with Administrator privilege and run "chkdsk /f". It did fix certain errors. I rebooted for the first time and when Losedows started, it complained that the Recycle Bin was corrupt. I chose to clean the Recycle Bin and then rebooted for a second time.

Then the NTFS file system was successfully recovered. I did an integrity check for my important files. Very few files were corrupt, and I could re-copy them from my old disk.