Problèmes avec webradio

5 réponses [Dernière contribution]
claro
Hors ligne
A rejoint: 02/18/2018

Bonjour,

Je viens d'installer Trisquel sur un vieux portable pour l'utiliser en radio internet. Mais problème: l'une des radios que j'écoute le plus (NRK.no) ne fonctionne pas. Sur un autre portable avec Linux Mint, le navigateur Opera me fait savoir que je dois installer des codecs pour mp4 pour pouvoir écouter le son. C'est possible d'installer ces codecs avec Trisquel, ou je dois revenir à une version non-libre?

J'ai du reste le même problème avec Trisquel pour Danmarks radio (dr.dk), alors que tout va bien avec France Culture, Sveriges radio, Ekko Moskva, Muzaiko, etc.

Amicales salutations de Norvège
claro

uboot
Hors ligne
A rejoint: 06/01/2016

Salut,

Pour nrk.no : https://www.nrk.no/mp3aac/
Pour dr.dk : https://www.dr.dk/hjaelp/digtal-radio/direkte-links-til-dr-radio-paa-nettet

Tu peux soit ouvrir les liens avec le navigateur ou avec VLC.
Sinon tu peux installer RadioTray et importer les stations voulues, c'est pas mal du tout !

Cdlt

claro
Hors ligne
A rejoint: 02/18/2018

Merci pour le lien vers NRK: ca fonctionne parfaitement.

Mais j'ai encore un petit problème: Trisquel ne reconnait pas ma carte wifi et je ne sais pas comment résoudre le problème.

lspci donne l'information suivante sur la carte wifi:

24:00.0 Network controller: Ralink corp. RT3592 Wireless 802.11abgn 2T/2R PCIe

J'avais Linux Mint sur ce PC pendant quelque temps et l'OS avait trouvé et configuré automatiquement la carte wifi, donc je sais qu'il n'y a pas de problème avec le matériel. Pour l'instant, je suis dépendant d'une liaison Internet par cable, ce qui limite l'usage de ce PC dans d'autre pièces de mon logement.

claro

Magic Banana

I am a member!

Hors ligne
A rejoint: 07/24/2010

Les noyaux Linux libres ne supportent pas ce chipset. Il te faut acquérir un dongle Wifi avec un chipset supporté. L’ennui c’est qu’il est très difficile de savoir quel chipset est dans un modèle donné. Pire : ce chipset (la seule chose qui importe pour le support) peut être changé dans un même modèle ! Du coup les constructeurs n’écrivent même pas sur l’emballage de la carte quel chipset elle inclut.

Une solution est le marché d’occasion si le vendeur spécifie le chipset. Les chipsets AR9170, AR9270 et AR9271 sont par exemple supportés avec le micrologiciel libre « ath9k_htc ». Une autre solution est d’entendre parler d’un utilisateur de Trisquel (ou d’une autre distribution 100% libre) qui a récemment acheté un matériel qui fonctionne et d’espérer que le chipset n’a pas été changé entre temps. J’ai moi-même acheté, il y a quelques années, quatre ou cinq dongles http://www.tp-link.com/us/products/details/cat-5520_TL-WN722N.html (pour pouvoir en donner/vendre à ceux chez qui j’installe Trisquel) après qu’un utilisateur ait ici dit qu’ils fonctionnaient parfaitement avec Trisquel (car ayant un chipset AR9271).

Mais le plus simple est d’acheter sur http://libre.thinkpenguin.com ou sur http://tehnoetic.com (les deux livrent à l’étranger). Ce sont, à ma connaissance, les deux seuls vendeurs qui garantissent que leurs matériels fonctionnent parfaitement avec Linux-libre. Les prix qu’ils pratiquent ne sont pas petits. Mais il est bon de supporter les entreprises qui respectent nos libertés.

claro
Hors ligne
A rejoint: 02/18/2018

Merci pour la réponse sur le chipset. Est-ce que c'est le même problème avec les imprimantes: pas de driver pour certains modèles sur les noyaux Linux libres?

J'ai une imprimante multifonctions Samsung SCX 3200 que Linux Mint reconnaissait automatiquement, mais que Trisquel ne détecte pas du tout, alors que les ports USB fonctionnent. Je ne peux donc pour l'instant ni scanner, ni imprimer. Il y a une solution?

claro

Magic Banana

I am a member!

Hors ligne
A rejoint: 07/24/2010

C’est possible. En tout cas, le pilote en téléchargement sur plusieurs sites Web n’est pas libre. Les imprimantes HP, sont, en général, les mieux supportées.

Les pilotes des imprimantes sont livrés séparément du noyau. As-tu le paquet « printer-driver-all » installé ? Peut-être aussi qu’un pilote libre existe mais qu’il est plus récent que Trisquel 7. Tu peux voir si Trisquel 8 supporte(ra) ton imprimante depuis le système Live : http://jenkins.trisquel.info/makeiso/iso/trisquel_8.0_amd64.iso