Mounted volume Icons are not automatically displayed in default desktop enviornment

Projet:Trisquel
Version:7.0
Composant:Gnome
Catégorie:Rapporter un bogue
Priorité:normal
Attribué:levlaz
Statut:by design
Description

Mounted volume Icons (like those for a USB flash drive, microsSD cards, CD, DVD etc.) are not automatically displayed on desktop while using the default desktop enviornment(Trisquel(default)).

Strangely enough, when I manually select the external device from main menu -> places, its icon appears in desktop. I have enabled 'Icons in desktop' and selected 'Mounted Volumes' along with other options in gnome-tweak-tool.(see screenshot.)

But with Gnome desktop enviornment, there is no such problem; mounted volume icons are automatically displayed on the desktop, the moment they are connected.

Fichier attachéTaille
Screenshot from 2014-11-13 00:26:57.png38.91 Ko
mer, 11/19/2014 - 21:14
dim, 11/23/2014 - 22:22
Assigné à:anonymous» levlaz
Statut:active» patch (ready)

I can confirm this behaviour, but it looks like the real problem is that the volume is not auto-mounting when plugged in.

The reason why I say this is because clicking on the volume in Nautilus is what actually mounts the volume.

In order to fix this issue, you will need to install usbmount. Open a terminal and type:

sudo apt-get install usbmount

Now you will see that when you plug in your USB drive the volume will be mounted automatically in Nautilus and appear on the desktop.

dim, 11/23/2014 - 23:08
Statut:patch (ready)» patch (needs work)

Correction. After further investigation it appears that installing usbmount only fixes the issue for usbdrives, it looks like for SD cards and CD/DVD there is no simple utility that will auto-mount these things. I am messing with some UDEV rules, but not sure how fall this will get.

Also, I don't have a CD/DVD drive so testing will be a bit challenging. :)

In any case, usbmount will fix the issue for all USB drives.

lun, 11/24/2014 - 10:27

I installed usbmount and pmount, restart.

Now insert the USB key, it goes well, I see the icon on the desktop.
When I want to disassemble, against it by asking for my password, but only the first time.

If I restart again when I want to disassemble it requires password.

lun, 11/24/2014 - 22:09
Statut:patch (needs work)» active

Hello,

Thanks for the note. I can confirm the same behaviour as well. It looks like when the disk is mounted the first time it is not by the currently logged in user which is why it is asking you to authenticate when trying to unmount.

This is certainly strange - I am marking this issue as not fixed and it will require a bit more investigation and work to get USB, SD, and CD/DVD to mount and unmount automatically.

Best,
Lev

dim, 12/14/2014 - 09:17

There is a Gnome setting for automount search on 'gnome 3.12 enabling automount of media' will find many entries E.g. http://askubuntu.com/questions/89244/how-to-disable-automount-in-nautiluss-preferences

IIUC not automounting is working as designed.

dim, 12/14/2014 - 14:25
Statut:active» by design
mar, 12/16/2014 - 13:05

error

dim, 08/30/2015 - 15:04

Hello,

I'm facing the same problem of devices not automounting though the proper options are checked in dconf-editor as described here : http://askubuntu.com/questions/89244/how-to-disable-automount-in-nautiluss-preferences.

Installing usbmount is a workaround to get automount working for USB key, but it does not work for my USB Western Digital hard drive.

Regards,

Denis

dim, 08/30/2015 - 20:17

Problem solved for my USB Hard disk, by adding "ntfs" to the managed filesystem types in /etc/usbmount/usbmount.conf

Edit : just one more problem : after mounting devices that way, unmounting does not work as normal user. Only root can unmount... (looks like the problem described above by levlaz)