Starting SMB/CIFS File and Active Directory Server. [ SOLVED ]

Catégorie:Rapporter un bogue
Attribué:Non assigné

During startup, GNU/Linux Trisquel shows a detailed list of process, usually with an [ OK ], but there was one with [fail], and I didn't like that it was "Starting SMB/CIFS File and Active Directory Server.". So I sought information about this error and, soon enough, I found it in the AskUbuntu website:

I learnt from this information that this wasn't really an issue, but only that the SMB had been tried to start too early, when the network is still starting to work. So the fix-up was simply to not try to start SMB automatically and leave its startup configuration on "manual" so it would be started later, when action from the user caused it to actually being demanded. The fix-up was the following:

In a root shell do:
echo manual > /etc/init/samba-ad-dc.override

This creates the file /etc/init/samba-ad-dc.override with the content "manual", that overrides samba startup script /etc/init/samba-ad-dc.conf .