Error authenticating libcontent-hub0 upgrading from 7.0

Projet:Trisquel
Version:8.0
Composant:Packages
Catégorie:Rapporter un bogue
Priorité:normal
Attribué:Non assigné
Statut:active
Description

Upgrading from Trisquel 7.0 to 8.0, I received a message that there was an error authenticating the libcontent-hub0 package.

I tried removing the package to find out what it had been installed for. I got this:
bernie@morpheus:~$ sudo apt-get remove libcontent-hub0
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
libaccount-plugin-generic-oauth signon-plugin-oauth2
The following packages will be REMOVED:
libcontent-hub0 qtdeclarative5-ubuntu-content0.1 ubuntu-system-settings
ubuntu-system-settings-online-accounts
The following NEW packages will be installed:
libaccount-plugin-generic-oauth signon-plugin-oauth2
0 to upgrade, 2 to newly install, 4 to remove and 0 not to upgrade.
Need to get 63.2 kB of archives.
After this operation, 4,304 kB disk space will be freed.

... which was more than I was expecting - removing some old packages, yes, but installing some new ones?

Well, looks like it's something to do with online account settings. I don't know how ubuntu-system-settings came to be installed anyway (this is an old laptop with a long history that has been through a number of Trisquel upgrades). I noticed that the online accounts entry is missing from the Gnome user menu (that one that drops down when clicking top right in Gnome 3).

I've continued with the removal (and installation), will restart now and retry upgrade.