Virtual package libcapi20-3 breaks upgrade in Brigantia

Project:Trisquel
Version:5.5
Component:Packages
Category:bug report
Priority:normal
Assigned:Unassigned
Status:active
Description

I'm unable to do safe-upgrade and full-upgrade on Brigantia, because of a virtual / missing package libcapi20-3.

Full upgrade :

sudo aptitude full-upgrade
The following NEW packages will be installed:
libopal3.10.2{ab} wine1.3{ab}
The following packages will be REMOVED:
libcamel1.2-19{u} libebook1.2-10{u} libedataserver1.2-14{u} libopal3.6.8{u} libpt2.6.7{u} libsrtp0{u}
The following packages will be upgraded:
ekiga wine
2 packages upgraded, 2 newly installed, 6 to remove and 0 not upgraded.
Need to get 26.0 MB of archives. After unpacking 104 MB will be used.
The following packages have unmet dependencies:
libopal3.10.2: Depends: libcapi20-3 which is a virtual package.
Depends: libspandsp2 (>= 0.0.6~pre18) but it is not going to be installed.
wine1.3: Conflicts: wine1.2 but 1.2.3-0ubuntu1 is installed.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
The following actions will resolve these dependencies:

Remove the following packages:
1) appmenu-qt
2) arora
3) ekiga
4) fet
5) ia32-libs-multiarch
6) libacl1
7) libattica0
8) libattr1
9) libaudio2
10) libavahi-client3
11) libavahi-common3
12) libc6
13) libcomerr2
14) libcups2
15) libcupsimage2
16) libcurl3
17) libdb5.1
18) libdbus-1-3
19) libdbusmenu-qt2
20) libdrm-intel1
21) libdrm-nouveau1a
22) libdrm-radeon1
23) libdrm2
24) libexpat1
25) libffi6
26) libfontconfig1
27) libfreetype6
28) libgcc1
29) libgcrypt11
30) libgdbm3
31) libgl1-mesa-dri
32) libgl1-mesa-glx
33) libglapi-mesa
34) libglib2.0-0
35) libgnutls26
36) libgpg-error0
37) libgssapi-krb5-2
38) libice6
39) libidn11
40) libjpeg62
41) libk5crypto3
42) libkatepartinterfaces4
43) libkcmutils4
44) libkdecore5
45) libkdesu5
46) libkdeui5
47) libkdnssd4
48) libkemoticons4
49) libkeyutils1
50) libkfile4
51) libkhtml5
52) libkidletime4
53) libkio5
54) libkjsapi4
55) libkjsembed4
56) libkmediaplayer4
57) libknewstuff3-4
58) libknotifyconfig4
59) libkntlm4
60) libkparts4
61) libkpty4
62) libkrb5-3
63) libkrb5support0
64) libkrosscore4
65) libktexteditor4
66) liblcms1
67) libldap-2.4-2
68) libllvm2.9
69) libmng1
70) libnepomuk4
71) libnepomukquery4a
72) libnepomukutils4
73) libnspr4
74) libnss3
75) libpciaccess0
76) libpcre3
77) libphonon4
78) libpng12-0
79) libpolkit-qt-1-1
80) libqt4-dbus
81) libqt4-dbus
82) libqt4-declarative
83) libqt4-declarative
84) libqt4-designer
85) libqt4-designer
86) libqt4-dev
87) libqt4-help
88) libqt4-network
89) libqt4-network
90) libqt4-opengl
91) libqt4-opengl
92) libqt4-qt3support
93) libqt4-qt3support
94) libqt4-script
95) libqt4-script
96) libqt4-scripttools
97) libqt4-scripttools
98) libqt4-sql
99) libqt4-svg
100) libqt4-svg
101) libqt4-test
102) libqt4-xml
103) libqt4-xmlpatterns
104) libqt4-xmlpatterns
105) libqtcore4
106) libqtgui4
107) libqtgui4
108) libqtwebkit-dev
109) libqtwebkit4
110) librtmp0
111) libsasl2-2
112) libsasl2-modules
113) libselinux1
114) libsm6
115) libsolid4
116) libsoprano4
117) libsqlite3-0
118) libssl1.0.0
119) libstdc++6
120) libtasn1-3
121) libtiff4
122) libuuid1
123) libx11-6
124) libxau6
125) libxcb1
126) libxdamage1
127) libxdmcp6
128) libxext6
129) libxfixes3
130) libxi6
131) libxrender1
132) libxss1
133) libxt6
134) libxxf86vm1
135) merkaartor
136) qdbus
137) soprano-daemon
138) virtualbox
139) virtualbox-dkms
140) virtualbox-ose
141) virtualbox-ose-dkms
142) virtualbox-ose-qt
143) virtualbox-qt
144) vlc
145) wine1.2
146) wkhtmltopdf
147) zlib1g

Keep the following packages at their current version:
148) libopal3.10.2 [Not Installed]

Accept this solution? [Y/n/q/?]

Safe upgrade

sudo aptitude safe-upgrade
Resolving dependencies...
Unable to resolve dependencies for the upgrade: no solution found.
Unable to safely resolve dependencies, try running with --full-resolver.

Using --full-resolver gives the same result as full-upgrade. I suspect that if I accept the solution, I will end up with broken system.

Any suggestions are welcome.

ivaylo:

A work-around is to download the package from Ubuntu [1] and intall it with dpkg -i.

[1] http://packages.ubuntu.com/lucid/libcapi20-3

Fri, 11 May, 2012
mtw:

I confirm this problem. I couldn't install ekiga because of missing "libcapi20-3". The problem was solved after downloading it from link above and installing it. Thank you.

Thu, 24 May, 2012
Andrzej P:

This is a licensing issue. The corresponding source package 'isdnutils' was explicitly removed from the Trisquel repos [1]. The good news is that upstream know about it and it looks like it is being worked on. See Ubuntu bug #511988 [2].

[1] http://bzr.trisquel.info/ubuntu-purge/trunk/annotate/head:/purge-oneiric
[2] https://bugs.launchpad.net/ubuntu/+source/isdnutils/+bug/511988

Sat, 26 May, 2012
ivaylo:

Thanks for sharing. I was unable to find the reason for the missing package myself. Licensing issues are important, but without knowing why packages are missing leads to work-arounds like mine which does not actually solve anything if a package is potentially non-free or at least parts of its source code. Simply removing packages breaks dependencies and leads to broken system, like what I am reporting.

Isn't it possible instead of purging packages to make them virtual or dummy with a short explanation why they are missing and potentially a link to the bug report in Trisquel or upstream?

Sun, 27 May, 2012
sudoman:

According to launchpad, the issue has been fixed in Debian, but hasn't been imported to Ubuntu.

https://bugs.launchpad.net/ubuntu/+source/isdnutils/+bug/511988

Maybe Trisquel could offer a version of it before it's imported to Ubuntu?

Fri, 22 Jun, 2012
Andrzej P:

This bug is not present in Toutatis (6.0) since Toutatis has the fixed 'isdnutils' source package imported from Debian[1]. However it seems that the relevant bug in Ubuntu has finally been fixed[2] so Trisquel should be able to revert back to the Ubuntu package in the next version. I have not checked the fix myself.

[1] http://devel.trisquel.info/gitweb/?p=package-helpers.git;a=blob;f=helpers/make-isdnutils;h=c8c9b3cbff89b92a58e8f53d9dd98039761ea7ed;hb=refs/heads/toutatis

[2] https://bugs.launchpad.net/ubuntu/+source/isdnutils/+bug/511988/comments/9

Wed, 4 Dec, 2013