Include GNU LibreJS by default with abrowser

Projekt:Trisquel
Komponente:License problems
Kategorie:Fehlerbericht
Priorität:critical
Zugewiesen:nicht zugewiesen
Status:won't fix
Beschreibung

GNU LibreJS is an abrowser add-on which blocks non-free javascript. It works to solve the problem described in RMS's The JavaScript Trap

Sa, 04/21/2012 - 21:41

+1 for the cause.
The problem is we'd need to fix this first:
https://trisquel.info/files/js/js_32df76638af22b6121d01c4b14db8bb1.js

Also some sites break in functionality, e.g. Yahoo Mail is totally unusuable even if scripts are allowed since the script name changes on each re-load. Hopefully this will be fixed in an update of LibreJS though.

Sa, 04/21/2012 - 23:25

The developer is aware of the first issue (http://trisquel.info/en/forum/librejs). It is because of how this content management system works. I actually mentioned on the LibreJS mailing list that I wanted to have a look at it but I never got round to it. A proper solution would make it possible for other sites using Drupal to pass the test (if they really use only free JS). We are using Drupal 6 on this site and the solution would ideally have to be ported to Drupal 7 to allow other Drupal-based sites to work properly too.

Fr, 03/28/2014 - 22:37

+1 for the cause

Sa, 03/29/2014 - 23:31

thats my Boy

TOR BROWSER must be default browser and at least it must come pre-installed Trisquel

u can still spoof user-agent by using anon**** web proxy add-on in mozilla and others

Mo, 03/31/2014 - 05:50

+1 for the cause. Abrowser is nice. Yeah, TOR browser might be a better idea.

Mo, 01/12/2015 - 22:04
Status:active» won't fix

LibreJS is included by default with IceCat, now available in the repos.

Mi, 01/21/2015 - 04:16

Yeah, this can be closed now since LibreJS is included with IceCat and Abrowser.