(breaking) Mumble SSL verification and profile persistence

Category:bug report

taken from https://trisquel.info/en/forum/eng-mumble-problems-toutatis

If I run Mumble normally (as a regular user), I cannot connect to a server I have previously verified on. Whenever I do, I get certificate errors, where even if I accept the certificate anyway, Mumble warns me in an infinite loop.

After this, I found the list of servers was not persistent, and favourite servers were not saved. This made me think it was a user config problem. I ran mumble as root (experimenting) and the problem went completely. So to have mumble functioning properly, I either have to run as root or re-install mumble totally (remove, purge, clean) for it to work once.

I've created a new user called 'mumble' using adduser, when logging a shell into the user and running mumble, I get many permission errors (e.g. PulseAudio server etc.). But, if I do this then mumble works fine and stores settings etc:

(add new user 'mumble')

su mumble //login-as mumble, enter password
sudo mumble //gives elevated priveleges if mumble requires them

This is working so far, I'll fix the permissions so the user 'mumble' can run mumble without sudo; at the weekend when these exams are gone.

P.S. I tried clearing every morsel of mumble (and ALL it's dependencies) doing an apt-get remove/clean/purge, and looking for any .config files remaining and no luck. This new user idea did work however.

mumble.jpg78.86 KB