Revision of How to Create a LiveUSB from Thu, 04/16/2015 - 16:05
The revisions let you track differences between multiple versions of a post.
The goal of this manual is to instruct the user on how to make a bootable USB drive with Trisquel installed.
Described methods
- Linux Trisquel (GUI: graphical user interface)
- Linux (terminal)
- Windows (GUI)
- Mac OS X (terminal)
Note: It is possible to enlarge the images via the button right click of your mouse.
Trisquel (Graphical)
Launch System Settings from the main menu.
Select Startup Disk Creator.
Select a source disk image or burned Trisquel disk and a designated device. Click Make Startup Disk.
Confirmation will display that the startup drive is complete.
Terminal (dd of GNU Coreutils)
$ sudo dd if=/path/to/image.iso of=/dev/sdX bs=8M;syncNote that you want the device name (e.g. /dev/sdx) not the partition name (e.g. /dev/sdx1).
Windows (Universal USB Installer (GPLv2))
This manual is not an endorsement for the use of non-free operating systems. This manual is designed to help users migrate from non-free systems to free ones, as it is the case of Trisquel.The easiest way to get up an running with USB is to use the USB installer provided by pendrivelinux.com. You’ll need to download and install and follow the instructions.
- Insert a USB stick with at least 2GB of free space.
- Download Pen Drive Linux's USB Installer.
- Select Trisquel from the dropdown list.
Click 'Browse' and open the downloaded ISO file.
Choose the USB drive and click 'Create'.
In Mac OS X (Terminal)
This manual is not an endorsement for the use of non-free operating systems. This manual is designed to help users migrate from non-free systems to free ones, as it is the case of Trisquel.- Download a Trisquel disc image from our downloads page.
- Open the Terminal from Applications/Utilities.
- Convert the .iso file to a .img.
Enter:
$ hdiutil convert -format UDRW -o ~/path/to/trisquel.img ~/path/to/trisquel.iso
$ diskutil listfor the list of devices currently attached. Insert your USB stick with at least 2GB of free space and Enter:
$ diskutil listagain to figure out the device file assigned to your USB stick (e.g.
/dev/disk2
). $ diskutil unmountDisk /dev/diskNwhere N is the number from the last command. (If your USB stick is
/dev/disk2
, N would be 2). $ sudo dd if=/path/to/trisquel.img of=/dev/rdiskN bs=1mIf you see the error
dd: Invalid number '1m'
, replace 1m
with 1M
in the previous command. $ diskutil eject /dev/diskN