Blocage de l'ordi

13 réponses [Dernière contribution]
Raistlin
Hors ligne
A rejoint: 04/06/2020

Bonjour, j'ai le même problème que celui signalé sur ce fil (https://trisquel.info/en/forum/blocage-de-lordi) sauf que parfois soit le son se coupe, soit comme Thibaud il est rejoué à l'infini. Les solutions données à l'époque sont-elles aujourd'hui encore recommandées ?

Je précise que la version 8.

Merci d'avance !

Raistlin
Hors ligne
A rejoint: 04/06/2020

Bonjour, personne n'a d'idée ? Ca devient infernal, ça arrive à chaque fois ou presque qu'on regarde une vidéo. Passer de Abrowser à Ice cat ne change rien (celui-ci est au demeurant très lent à démarrer).

boba
Hors ligne
A rejoint: 08/28/2017

Le fil auquel tu fais référence ne précise pas si le problème est spécifiquement lié au navigateur ou à un lecteur vidéo autonome (VLC, Vidéos, Totem, etc.). Dans ton cas, le blocage se produit-il uniquement pour les vidéos lues sur le navigateur, ou bien pour toute vidéo, y compris hors navigateur?

La "solution" proposée consiste à tester la RAM, c'est toujours une bonne idée de commencer par là. Si la RAM s'avère défectueuse, c'est probablement la source du problème, sinon il faudra continuer à tester.

Raistlin
Hors ligne
A rejoint: 04/06/2020

Merci pour ces éléments, à priori le problème ne concerne que les navigateurs, mais je vais vérifier tout ça dés que possible et je reviens vers vous.

boba
Hors ligne
A rejoint: 08/28/2017

Le problème se produit-il aussi sous Trisquel 9?

unareil
Hors ligne
A rejoint: 02/26/2020

Bonjour,

Peux-tu expliquer clairement le contexte dans lequel se passe ton problème de façon à ce qu'il soit possible de proposer des solutions car le problème peux venir de plusieurs éléments (navigateur qui bloque des fonctionnalités, script javascript qui tourne en boucle et sature la mémoire, carte vidéo défaillante, processeur qui chauffe trop,etc...).
Exemple de contexte :
je lance le navigateur Abrowser.
je vais sur le site : https://peertube.fedi.quebec/videos/watch/c9d0d086-3963-4e72-a6ab-951723a424d8 pour visionner la bande annonce la bataille du libre.
Je pense que cela permettra d'apporter une meilleure réponse en vérifiant de quoi cela peut venir...

Cordialement.

Raistlin
Hors ligne
A rejoint: 04/06/2020

Alors, d'abord merci à tous de votre aide. Ensuite, et dans l'ordre :

1) du côté de la mémoire, rien à signaler, ça à tourné toute la nuit, zéro défaut.

2) du côté de vlc, pas de problème, les vidéos marchent, ce n'était que quand je lisais une vidéo sur abrowser ou ice cat (depuis facebook mais je n'ai pas eu le temps d'essayer ailleurs) que cela bloquait.

3) un de vos confrères, que j'en profite pour remercier, m'a aussi conseillé plusieurs solutions, que je permets de partager avec la communauté pour que ça serve à d'autres compagnons de galère :

- afficher les dossiers cachés CTRL + H, supprimer .abrowser. On est alors obligé de tout reconfigurer, afficher les barres, remettre les modules complémentaires, les favoris. Je n'ai pas eu le temps d'essayer cette solution, mais encore une fois le problème existait aussi avec Ice cat.

- Ouvrir le capot de la bête pour voir si le ventilateur n'était pas poussiéreux. Effectivement il était beaucoup plus que ce que je supposait. J'ai donc tout nettoyé à l'aspi et au coton tige. Mais ça n'a rien changé.

- Installer le paquet xsensors par synaptic ou via apt : si la température était supérieure à 50°C, changer la pâte thermique du ventilateur. Je n'ai pas installé le paquet, mais de toute façon changer la pâte thermique est une opération un poil trop sensible pour mon niveau. Et puis j'ai du mal à comprendre pourquoi, si c'était le ventilateur le problème, cela n'affectait que la consultation de vidéos en ligne ?

4) C'est là que l'ordinateur a planté, impossible d'arriver à l'écran de démarrage. Perdant patience, j'ai alors réinstallé Trisquel 8 à neuf. Ca a marché deux jours, et puis j'ai eu droit de manière aléatoire à la fameuse frise, et puis… l'ordinateur a à nouveau planté, avec les messages d'erreur figurant en pièce jointe.

5) Je ne peux donc pas répondre à Unareil, si ce n'est que je regardais des vidéos via facebook (vidéos en direct), et que le problème concernait aussi bien icecat que abrowser (j'ai alterné entre les deux).

6) le problème actuel est donc décrit en pièce jointe. Mon ordi est âgé, et je me doute que le problème est lié à ça, même si ce n'est apparemment pas la mémoire; Je vous le communique donc, si jamais vous avez des conseils qui peuvent le régler ou au moins que ça serve à d'autres, avant que je consulte un informaticien (mais le devis de réparation va probablement me conduite à changer le matos dans le boîtier, voire prendre un boîtier neuf). Je resterai fidèle à Trisquel de toute façon.

Quelque chose me dit que réinstaller Trisquel à neuf ne règlera rien...

Fichier attachéTaille
problème Trisquel.doc 27.5 Ko
Magic Banana

I am a member!

En ligne
A rejoint: 07/24/2010

Tu ne devrais pas communiquer dans un format privateur : https://www.gnu.org/philosophy/no-word-attachments.html

Dans cette pièce jointe :

  • quand j’exécute la commande « journalctl -xb », plein de lignes défilent, certaines en rouge
    Lire ce qui fut écrit les journaux système peu avant un gel (il y a une date au début de chaque ligne) peut, en effet, être instructif. Se concentrer sur les messages graves aussi. Pour filtrer les messages en rouge, de niveau "erreur" ou pire, utilise '-p 3' en option de 'journalctl'. Enfin, terminer la ligne de commande par '> "mon fichier"', où "mon fichier" est le chemin vers un fichier de ton choix (mais, s'il existe, le fichier actuel sera perdu !) redirige sa sortie standard vers le fichier en question. Ainsi, et cela vaut pour n'importe quelle ligne de commande, il n'est pas nécessaire de copier ce qui est écrit dans le terminal. Les guillemets, autour de "mon fichier", sont inutiles si le nom du fichier ne contient pas d'espace.
  • [600.233902] XFS (dm-1) : corruption of in-memory data detected. Shutting down file system
    [600.233909] XFS (dm-1) : Please unmount the file system and recitfy the problem (s)

    Un de tes systèmes de fichiers, probablement celui monté en /home (car, par défaut, l'installateur Trisquel choisit XFS pour ce système de fichiers), est corrompu. Certainement à cause d'un d'un gel en plein milieu d'une écriture dans ton dossier personnel... qui pourrait être du à un disque (celui où se trouve /home) défaillant. Tu peux peut-être "rectifier le problème" avec 'xfs_repair', comme te le suggère le journal. Néanmoins le problème reviendra si le disque est défaillant. Lire les données SMART du disque, voire l'auto-tester, permet de le savoir. Une façon simple (graphique) de procéder est d'utiliser un système live (comme celui qui t'a permis d'installer Trisquel), d'y installer GNOME Disques avec le gestionnaire de paquets (le paquet s'appelle "gnome-disk-utility" dans Debian et dérivées, y compris Trisquel), de le lancer, de sélectionner le disque suspect à gauche de la fenêtre et, dans le menu dont l'icône représente trois segments empilés, de cliquer sur "Données SMART et auto-tests... (Ctrl+S)". Une nouvelle fenêtre s'affiche, avec les données SMART et la possibilité de "Démarrer l'auto-test", d'un clic sur le bouton éponyme. Si le disque est sain, procède à la réparation du système de fichiers XFS et le problème reste entier. Si le disque est défaillant, change-le. De nos jour, 1 To coûte environ 50€, si tu achètes un disque de cette taille.
Raistlin
Hors ligne
A rejoint: 04/06/2020

Alors d'abord merci Magic banana pour ces éléments. Pour ce qui concerne le format, comme mon ordi perso est en rade, je suis plus ou moins forcé d'utiliser celui du boulot… et donc les logiciels qui vont avec.

Je vais essayer la deuxième solution et je reviens vers vous. Pour la première j'ai pas tout compris mais je vais essayer de recopier les lignes en rouge et de vous les restituer si le reste ne marche pas. On m'a aussi conseillé par ailleurs de mettre à jour le BIOS via freedos et une clef usb. Je vous tiens au courant...

Magic Banana

I am a member!

En ligne
A rejoint: 07/24/2010

Pour ce qui concerne le format, comme mon ordi perso est en rade, je suis plus ou moins forcé d'utiliser celui du boulot…

Il n'y avait ici pas besoin de pièce jointe. Tu peux tout écrire dans le commentaire et même le mettre en forme : https://trisquel.info/fr/filter/tips

Je vais essayer la deuxième solution et je reviens vers vous.

Tester un vieux disque est de toute façon une bonne idée : les disques mécaniques s'usent.

Pour la première j'ai pas tout compris mais je vais essayer de recopier les lignes en rouge et de vous les restituer si le reste ne marche pas.

De nouveau : ce n'est pas la peine. Ajouter '-p 3' à la commande 'journalctl -xb' ne garde que les lignes rouges; suffixer la commande par '> /mnt/erreurs' écrit la sortie dans le fichier /mnt/erreurs (sais-tu comment monter, avec 'mount' un système de fichiers, par exemple d'une clé USB ?) :
$ journalctl -xbp 3 > /mnt/erreurs

Raistlin
Hors ligne
A rejoint: 04/06/2020

Alors déjà pour ce qui concerne le BIOS, il était à jour.

Vu pour le commentaire, je m'en souviendrai, merci.

Pour le disque dur, alors déjà gnome disc s'appelle "discs" tout court dans le menu ( rigolez pas j'ai passé 5 bonnes minutes à chercher gnome discs ou gdisc). Ensuite bingo semble-t'il , le résultat est "self test failed", je suppose que donc que c'est le résultat attendu (du coup le disque devient rouge dans le menu)?

Par conséquent, je n'ai pas utilisé la fonction de réparation ni -p 3 (et, non je ne sais pas monter un système de fichiers avec une clef).

Il me faut donc acquérir un nouveau disque dur. Et la question est : puis-je acquérir n'importe lequel, ou dois-je faire attention au reste de mon matériel (carte mère, processeur,... ? - je ne vois aucune info en ce sens sur wikipédia) voire même de Trisquel (je ne vois pas de disque dur en vente sur Thinkpenguin) ?

Magic Banana

I am a member!

En ligne
A rejoint: 07/24/2010

Les premiers disques compatibles SATA datent de 2003. C'est très probablement ce que tu as. Il y a aussi l'interface SAS, mais pour les serveurs.

Plus le disque est de grande capacité, moins le To coûte cher. Néanmoins, comme tu viens de le voir, un disque dur n'est pas éternel : s'il meurt avant que tu ne l'ais rempli, tu auras payer plus pour rien. Je compte huit ans de vie et estime la quantité de données accumulée sur cette période.

Niveau marque, certaines, comme Western Digital (WD), ont de meilleures réputations que d'autres, compte tenu de leur passé. Mais bon...

Raistlin
Hors ligne
A rejoint: 04/06/2020

En fait je me demande si je vais pas prendre un disque à semi-conducteurs (connus aussi sous leur acronyme anglais : SSD) plutôt qu'un disque dur classique. Ils apparaissent beaucoup moins fragiles qu'un disque dur classique. J'ai demandé au fabricant de ma carte-mère si je devais respecter certaines caractéristiques de compatibilités (à priori 3 To maximum mais je suis même pas sûr que j'aurai besoin d'1 To).

Merci à tous pour vos éléments en tout cas qui vont servir à plus d'un débutant je pense.

Magic Banana

I am a member!

En ligne
A rejoint: 07/24/2010

Le Go sur un SSD est bien plus cher. Ceci étant, les débits d'un SSD sont environ trois fois supérieur à ceux d'un HDD. Pour le système c'est très agréable : tout démarre vite. Mais le système prend peu de place. Au contraire des données. Tu peux vouloir un "petit" SSD (disons 120 Go) et un plus gros HDD pour le meilleur des deux mondes (la vitesse du système et de la place bon marché).