Clé USB amorçable ne fonctionne pas

11 réponses [Dernière contribution]
Éfrit
Hors ligne
A rejoint: 04/22/2015

Bonjour,

J’ai actuellement un ThinkPad X60 acheté sur http://www.gluglug.org.uk/, donc avec le chargeur d’amorcage Libreboot. Le système d’exploitation qui y est installé est Trisquel 6.0 LTS Toutatis.

Mon problème est que j’essaye de mettre à jour le système vers la version 7.0 Bénélos en utilisant une clé USB amorçable. Cependant, lorsque j’éteins et j’allume mon ordinateur, celui-ci n’amorce pas sur la clé. J’ai bien essayé de sélectionner les différentes options à l’écran de configuration de Libreboot, notamment en suivant les étapes indiquées sur ce site http://libreboot.org/docs/gnulinux/grub_boot_installer.html, mais cela ne fonctionne pas. Il affiche comme message d’erreur :

error: file '/boot/grub/i386-coreboot/sfs.mod' not found
error: file '/boot/grub/i386-coreboot/affs.mod' not found
error: unknown filesystem

À noter que j’ai un Trisquel 32 bits, que l’image ISO que j’ai utilisé pour la clé est le fichier trisquel_7.0_i686.iso, que j’ai d’abord utilisé l’utilitaire de créateur de clé USB amorçable de Trisquel pour ma clé, avant d’utiliser LinuxLive USB Creator sur Windows et que j’ai d’autres petits soucis avec cet ordinateur, mais je ne pense pas que ce soit lié au problème que je viens de décrire.

Merci d’avance pour votre aide.

Magic Banana

I am a member!

Hors ligne
A rejoint: 07/24/2010

Sais-tu que tu peux mettre à jour ta distribution depuis le gestionnaire de mise à jour ?

As-tu vérifié le md5sum de l'ISO ? Les sommes correctes sont là : http://cdimage.trisquel.info/trisquel-images/

Éfrit
Hors ligne
A rejoint: 04/22/2015

Oui je le sais mais d’après ma propre expérience ce n’est jamais réussi (j’ai essayé avec Ubuntu et Debian), depuis je préfère faire une réinstallation propre de la partition racine plutôt que de passer par le gestionnaire de mises à jour (et ça a très bien marché pour Elementary OS sur un autre ordinateur). Voir ce tutoriel en particulier, dans lequel j’ai suivi la méthode 4 : http://forum.ubuntu-fr.org/viewtopic.php?id=1566641

En outre, mon système de paquets semble mal fonctionner (un problème avec la mise à jour du noyau).

J’ai également vérifié la somme md5 du fichier et elle est correcte. Par ailleurs la clé USB est bien formatée en FAT32 (vérifié avec GParted).

nmrk.n
Hors ligne
A rejoint: 11/01/2013

Pour faire les clés USB j'utilise dd.

Le BIOS libre ne reconnait peut-être pas FAT32 ? :-)

merci

Mangy Dog

I am a member!

I am a translator!

Hors ligne
A rejoint: 03/15/2015

Efrit a écrit:

Mon problème est que j’essaye de mettre à jour le système vers la version 7.0 Bélénos en utilisant une clé USB amorçable

Pourquoi passer par une clef USB ?

Soit comme sugère Magic Banana de mettre à jour ta distribution depuis le gestionnaire de mise à jour.Ou une nouvelle installation USB/DVD avec nouvelle image iso de Trisquel 7 Beleneos

Parfois certaines clefs USB ne fonctione pas et ne s'affiche pas au BIOS/BOOT;verifie si possible si elle elle est reconnue au boot sur un autre PC,ou essaye une autre clef USB et DVD.

Éfrit
Hors ligne
A rejoint: 04/22/2015

J’ai essayé sur un autre ordinateur, et ça marche. Donc je pense que le problème vient de Libreboot. Peut-être effectivement que celui-ci ne reconnaît pas FAT32, mais je pensais que c’était nécessaire pour avoir une clé USB amorçable. Est-il possible de la formater en une partition comme ext4 puis de l’amorcer pour installer Trisquel 7 ?

nmrk.n
Hors ligne
A rejoint: 11/01/2013

Ça peut fonctionner et tu ne risques rien à essayer.

Pour la faire tu peux aussi essayer avec dd.

merci

Sasaki
Hors ligne
A rejoint: 08/11/2014

J'ai une clé live debian persistente toute en ext4 et ça fonctionne très bien.

Éfrit
Hors ligne
A rejoint: 04/22/2015

Bonjour,

J’ai fini par résoudre mon problème, mais ce fut assez étrange. Il semblerait effectivement que le problème était que la clé était formatée en FAT32. Je l’avais alors d’abord formaté en ext4 avec GParted, mais lorsque j’utilisais ensuite l’utilitaire de création de clé amorçable du système, celui-ci le reformatait en FAT32 avant de continuer.

J’ai alors essayé avec dd, et bien que ça ait fini par marcher, il s’est passé des choses un peu bizarres. En effet, la première fois que j’ai essayé le système s’est amorcé sur la clé et je voyais le menu me demandant d’installer ou d’essayer Trisquel (et les autres options). Mais lorsque j’ai choisi d’essayer, le système a redémarré, et il m’affichait la même erreur qu’auparavant lorsque je tentais d’amorcer sur la clé.

J’ai alors recommencé avec dd, et là j’ai réussi à essayer Trisquel 7.0 à partir de ma clé. J’étais pris d’un doute concernant mes partitions et comme le système sur la clé n’indiquait pas les points de montage des partitions, j’ai redémarré pour revenir sur le système installé sur mon ordinateur. Lorsque j’ai ensuite redémarré, l’ordinateur ne voulait à nouveau plus amorcer sur ma clé ! J’ai repris alors l’étape avec dd, et j’ai directement installé la Trisquel 7.0 sur ma partition système. Je suis actuellement sur celui-ci, et ça fonctionne plutôt bien (mise à part quelques comportements intempestifs), mais je ne sais que penser de tout cela…

Enfin, merci pour l’aide que vous m’avez apporté.

nmrk.n
Hors ligne
A rejoint: 11/01/2013

Quelle est la commande que tu as utilisée avec dd ?

- Il ne faut pas monter la clé

- Est-ce que tu as exécuté la commande :

sync

une fois que dd a eu terminé ?

Lorsque ça "ne voulait à nouveau plus amorcer sur la clé" est-ce que tu as simplement essayé de la débrancher puis la rebrancher avant de tout recommencer avec dd ?

merci

Éfrit
Hors ligne
A rejoint: 04/22/2015

J’ai utilisé la commande suivante :

dd if='source' of='cible' bs=1M; sync

Oui j’avais essayé de débrancher rebrancher, redémarrer encore, mais ça ne marchait pas toujours pas.

nmrk.n
Hors ligne
A rejoint: 11/01/2013

Bizarre, je ne sais quoi dire.

Sinon pour citer sur le forum c'est "<" et ">", pas "[" et "]" :

Citation

merci